1 (edited by rockandroller 2020-02-13 19:35:02)

Topic: php-pecl-zip requires libzip5(x86-64) >= 1.6.0

CentOS7 looking to update...  get this:


Resolving Dependencies
--> Running transaction check
---> Package php-pecl-zip.x86_64 0:1.15.5-1.el7.remi.7.3 will be updated
---> Package php-pecl-zip.x86_64 0:1.17.1-1.el7.remi.7.3 will be an update
--> Processing Dependency: libzip5(x86-64) >= 1.6.0 for package: php-pecl-zip-1.17.1-1.el7.remi.7.3.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-zip-1.17.1-1.el7.remi.7.3.x86_64 (remi-php73)
           Requires: libzip5(x86-64) >= 1.6.0
           Installed: libzip5-1.5.2-1.el7.remi.x86_64 (@remi-safe)
               libzip5(x86-64) = 1.5.2-1.el7.remi
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I see the newer version is available ( see https://pkgs.org/download/libzip5(x86-64) )  - but not in the remi-safe repo??
(remi-safe only has 1.5.2-1.el7.remi  ...)

Am I misconfigured with my repos ?

here is my current repolist:


yum repolist
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.ca-west.mirror.fullhost.io
* epel: mirrors.syringanetworks.net
* extras: mirror.its.sfu.ca
* remi-php73: mirrors.ukfast.co.uk
* updates: mirror.its.sfu.ca
repo id                           repo name                                            status
base/7/x86_64                     CentOS-7 - Base                                      10,097
epel/x86_64                       Extra Packages for Enterprise Linux 7 - x86_64       13,524
extras/7/x86_64                   CentOS-7 - Extras                                       323
mysql-connectors-community/x86_64 MySQL Connectors Community                              141
mysql-tools-community/x86_64      MySQL Tools Community                                   105
mysql57-community/x86_64          MySQL 5.7 Community Server                              404
r1soft/x86_64                     R1Soft Repository Server                                 21
remi-php73                        Remi's PHP 7.3 RPM repository for Enterprise Linux 7    353
updates/7/x86_64                  CentOS-7 - Updates                                    1,446
repolist: 26,414

Re: php-pecl-zip requires libzip5(x86-64) >= 1.6.0

According to your output, "remi-safe" is not enabled (only "remi-php73")

And libzip5 (version 1.6.1) is in remi-safe

See https://rpms.remirepo.net/enterprise/7/ … bzip5.html

Notice: remi-safe is enabled by default when installing "remi-release" package (see wizard instructions)

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php-pecl-zip requires libzip5(x86-64) >= 1.6.0

Thanks Remi!!  I ran

yum-config-manager --enable remi-safe

and all is well now.