Topic: phpMyAdmin, dépendance : apache

Salut Remi,

pourquoi avoir httpd en dépendance de phpMyAdmin ?
C'est bête de devoir l'install alors qu'un autre serveur tourne déjà.

Me semble que c'est juste pour phpmyadmin.conf dans le dossier d'apache hmm

Il y a une solution pour l'install sans la dépendance en question ?
(Serveur lighttpd)

(Oui, il y a la solution téléchargement du script a la main mais c'est beaucoup moins pratique niveau m.a.j.)

Marci d'avance wink

CentOS : 7-1511 x86_64
Utilisateur des dépôts : RHEL, REMI

Re: phpMyAdmin, dépendance : apache

Ben... c'est pas moi qui gère le paquet en question... donc...

Mais effectivement, surtout avec php-fpm.

Perso je verais bien un découpage
- phpMyAdmin => paquet avec la config pour apache (compatibilité avec l'ancien, cas le plus courant, ...)
- phpMyAdmin-lighttpd => paquet avec la config pour lighttpd (requires lighttpd-alias + lighttpd-php-fpm)
- phpMyAdmin-core => les pages

Mais pour gérer correctement les dépendances, et avoir une configuration qui fonctionne "out of the box" il faudrait aussi éclater lighttpd :
- lighttpd
- lighttpd-alias
- lighttpd-php-fpm

Etc.
Donc, oui, ce serait bien, ce serait "juste" un très gros boulot.

+

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: phpMyAdmin, dépendance : apache

Enfin puisque la version dans mon dépôt est légèrement différente de la version fedora :
https://github.com/remicollet/remirepo/ … 95a72caf6d

++

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70