Topic: php-sebastian-finder-facade2 Requires: php(language) >= 7.3

Morning All,

I have been using the REMI repos for some time and find the set of PHP versions great, thanks for you hard work in keeping them up to date.

On to my issue, I have been looking at a docker image and why composer didnt get installed. That was fixed by enabling the base REMI repo, but after doing that I now cant install the list of RPMs as there is a Dependency Resolution error. I have the base remi repo and the PHP72 repos enabled. Below is the list of RPMs, below that is the error from yum.

php-pecl-memcache php-xmlrpc php-mcrypt php-mysqlnd php-xml \
    php-enchant php-tidy php-devel php-pdo php-gd php-soap \
    php-pecl-memcached php-pear php-pear-DB php-intl \
    php-pear-phing php-opcache php-phpunit-git php-fpm \
    mysql-community-client mysql-community-common \
    composer
--> Finished Dependency Resolution
Error: Package: php-sebastian-finder-facade2-2.0.0-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.3
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(language) = 5.3.3
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(language) = 5.3.3
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-7.2.31-2.el6.remi.x86_64 (remi-php72)
               php(language) = 7.2.31
           Installing: php-common-7.2.32-1.el6.remi.x86_64 (remi-php72)
               php(language) = 7.2.32
Error: Package: php-sebastian-version3-3.0.1-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.3
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(language) = 5.3.3
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(language) = 5.3.3
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-7.2.31-2.el6.remi.x86_64 (remi-php72)
               php(language) = 7.2.31
           Installing: php-common-7.2.32-1.el6.remi.x86_64 (remi-php72)
               php(language) = 7.2.32
Error: Package: php-phpunit-phploc-6.0.2-1.el6.remi.noarch (remi)
           Requires: php(language) >= 7.3
           Available: php-common-5.3.3-49.el6.x86_64 (base)
               php(language) = 5.3.3
           Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
               php(language) = 5.3.3
           Available: php-common-5.4.45-17.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-5.4.45-18.el6.remi.x86_64 (remi)
               php(language) = 5.4.45
           Available: php-common-7.2.31-2.el6.remi.x86_64 (remi-php72)
               php(language) = 7.2.31
           Installing: php-common-7.2.32-1.el6.remi.x86_64 (remi-php72)
               php(language) = 7.2.32
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Re: php-sebastian-finder-facade2 Requires: php(language) >= 7.3

php-sebastian-finder-facade2 is only used by phpunit9
Need to understand why phpunit9 is pulled...

Please post full yum transaction


Try without phploc.

And don't forget than C6 is close to its end of live in November....

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php-sebastian-finder-facade2 Requires: php(language) >= 7.3

Indeed looks like you cannot install php-pear-phing without 7.3 because of dependency of latest phpunit tools (phpcov, phpcpd, phploc)

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php-sebastian-finder-facade2 Requires: php(language) >= 7.3

I have remove optional dependencies (using weak dependencies when possible)

Should allow to install php-pear-phing


Notice, about php-mcrypt, please read
https://blog.remirepo.net/post/2015/07/ … php-mcrypt

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php-sebastian-finder-facade2 Requires: php(language) >= 7.3

Thanks so much, will try now.