Topic: CentOS not finding php

The command I'm using:

yum --enablerepo=remi update php

The error message I get:

Loading "rhnplugin" plugin
Loading "security" plugin
Excluding Packages in global exclude list
Setting up Update Process
Could not find update match for php
No Packages marked for Update

I tried removing the repos and reinstalling them again, even went as far as to list the contents using:

yum --enablerepo=remi list | grep php

The output I got from that was:

graphviz-php.i386                        2.12-8.el5             epel
mod_suphp.i386                           0.6.3-1.el5            epel
rrdtool-php.i386                         1.2.27-3.el5.remi      remi
uuid-php.i386                            1.5.1-3.el5            epel

Essentially... for some reason yum has issues locating a php package. I tried reinstalling repos, adding the gpg key and so on and so forth, no luck whatsoever. Assistance would definitely be welcome, considering McAffe has decided to mark php version lower than 5.2.7 as a high-risk issue and as such my site no longer appears marked as McAffe Secure.

Re: CentOS not finding php

See your "exlude" and "priority" repository configuration.