Topic: Problems installing php-intl and php-mbstring on CentOS 8

Hello,

I'm trying to install php-intl and php-mbstring for PHP 7.4 packages on CentOS 8.3.2011. I have enabled Remi repository, PowerTools and set PHP version like this:

yum-config-manager --add-repo https://rpms.remirepo.net/enterprise/$r … $basearch/
dnf config-manager --set-enabled PowerTools
dnf module enable -y php:remi-7.4

I have successfully installed other PHP modules required by the application, but when I try to install php-intl I get the following:

dnf install php-intl
Last metadata expiration check: 0:31:37 ago on Fri 05 Feb 2021 07:30:47 AM UTC.
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides libicudata.so.65()(64bit) needed by php-intl-7.4.15-1.el8.remi.x86_64
  - nothing provides libicui18n.so.65()(64bit) needed by php-intl-7.4.15-1.el8.remi.x86_64
  - nothing provides libicuuc.so.65()(64bit) needed by php-intl-7.4.15-1.el8.remi.x86_64
  - nothing provides libicuio.so.65()(64bit) needed by php-intl-7.4.15-1.el8.remi.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages

And for php-mbstring the following:

dnf install php-mbstring
Last metadata expiration check: 0:33:22 ago on Fri 05 Feb 2021 07:30:47 AM UTC.
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides libonig.so.105()(64bit) needed by php-mbstring-7.4.15-1.el8.remi.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Why is this?

Re: Problems installing php-intl and php-mbstring on CentOS 8

> yum-config-manager --add-repo

This is not the correct way.

For a proper repository, please follow the Wizard instructions (link on top of all pages of the repo / blog / forum...)

You need, at least, remi-safe (for common dependencies) and remi-modular  (for PHP) repositories, which are both configured and enabled using the remi-release package.

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Problems installing php-intl and php-mbstring on CentOS 8

Remi wrote:

You need, at least, remi-safe (for common dependencies) and remi-modular  (for PHP) repositories, which are both configured and enabled using the remi-release package.

Yep, I added remi-safe and I was able to install the packages without problems. Thanks!