Topic: Error updating ImageMagick6-libs

I tried to update PHP running on Amazon Linux 2 today and got the following error:

----
Error: Package: ImageMagick6-libs-6.9.12.1-1.el7.remi.x86_64 (remi-safe)
           Requires: libraw_r.so.19()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
----

It seems Amazon Linux 2 only has version libraw_r.so.5:

----
# yum provides "*/libraw_r.so.*"
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
585 packages excluded due to repository priority protections
LibRaw-0.14.8-5.amzn2.20120830git98d925.x86_64 : Library for reading RAW files obtained from digital photo cameras
Repo        : amzn2-core
Matched from:
Filename    : /usr/lib64/libraw_r.so.5.0.0
Filename    : /usr/lib64/libraw_r.so.5

LibRaw-0.14.8-5.amzn2.20120830git98d925.1.i686 : Library for reading RAW files obtained from digital photo cameras
Repo        : amzn2-core
Matched from:
Filename    : /usr/lib/libraw_r.so.5
Filename    : /usr/lib/libraw_r.so.5.0.0

LibRaw-0.14.8-5.amzn2.20120830git98d925.1.x86_64 : Library for reading RAW files obtained from digital photo cameras
Repo        : amzn2-core
Matched from:
Filename    : /usr/lib64/libraw_r.so.5.0.0
Filename    : /usr/lib64/libraw_r.so.5
----

I have the following repos enabled:

----
# grep enabled=1 *
amzn2-core.repo:enabled=1
epel.repo:enabled=1
remi-php74.repo:enabled=1
remi-safe.repo:enabled=1
----

Any advice?

Re: Error updating ImageMagick6-libs

> It seems Amazon Linux 2 only has version libraw_r.so.5:

Yes, amzn2 is really outdated


You need LibRaw-0.19.2-0.el7.remi which is in "remi" repository.


I just add it to "remi-safe", so should be fixed (once your mirror will be in sync with primary)


P.S. official RHEL/CentOS have 0.19.4-1.el7, so the build in my repository is ONLY for Amzn users

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Error updating ImageMagick6-libs

That's amazing, thanks for the quick response. Much appreciated.

Re: Error updating ImageMagick6-libs

Hi there,

I've run into the same error on Amazon Linux 2. The `remi-safe` repo is already enabled and I've refreshed yum cache but still can't get the right version of LibRaw. See below:

List of active repos

yum repolist | grep remi
remi-php80                     Remi's PHP 8.0 RPM repository for Ente     221+79
remi-safe                      Safe Remi's RPM repository for Enterpr    4,120+4


LibRaw available versions

yum info LibRaw
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
317 packages excluded due to repository priority protections
Available Packages
Name        : LibRaw
Arch        : i686
Version     : 0.14.8
Release     : 5.amzn2.20120830git98d925.1
Size        : 263 k
Repo        : amzn2-core/2/x86_64

Name        : LibRaw
Arch        : x86_64
Version     : 0.14.8
Release     : 5.amzn2.20120830git98d925.1
Size        : 248 k
Repo        : amzn2-core/2/x86_64


Any suggestions?

Re: Error updating ImageMagick6-libs

> 317 packages excluded due to repository priority protections

Check priority configuration or disable the plugin

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Error updating ImageMagick6-libs

Thanks a lot!

editing /etc/yum/pluginconf.d/priorities.conf and setting enabled = 0 worked

Not sure why but adding
priority=11 to your .repo (-safe and php-80) which is higher than the priority=10 of amazon own repo didn't work.

Re: Error updating ImageMagick6-libs

> priority=11 to your .repo (-safe and php-80) which is higher than the priority=10 of amazon own repo didn't work.

Lower number means higher priority wink

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Error updating ImageMagick6-libs

Thanks for clarifying!

Have a great day