Topic: Conflict on php74-php-pecl-ssh2

I am trying to install  php74-php-pecl-ssh2 on Amazon Linux2 using remi-safe
but getting conflict on libssh2 version.
Any thought on this?

  --> Running transaction check
---> Package php74-php-pecl-ssh2.x86_64 0:1.2-1.el7.remi will be installed
--> Processing Dependency: libssh2(x86-64) >= 1.8.0 for package: php74-php-pecl-ssh2-1.2-1.el7.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php74-php-pecl-ssh2-1.2-1.el7.remi.x86_64 (remi-safe)
           Requires: libssh2(x86-64) >= 1.8.0
           Installed: libssh2-1.4.3-12.amzn2.2.3.x86_64 (@amzn2-core)
               libssh2(x86-64) = 1.4.3-12.amzn2.2.3

Re: Conflict on php74-php-pecl-ssh2

Looks like amazon is really too much outdated...

CentOS 7 have 1.8.0 since 7.7... (2019...)

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Conflict on php74-php-pecl-ssh2

As a workaround, I just upload libssh2 1.8.0-0 in the repository, which should solve your issue

Release have been lowered, so RHEL / CentOS users will keep using 1.8.0-4 from the official repository

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Conflict on php74-php-pecl-ssh2

Thank you, excuse me my ignorance, but can I test this?

Re: Conflict on php74-php-pecl-ssh2

run the same transaction, it should work (if used mirror is synced with primary)

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Conflict on php74-php-pecl-ssh2

Still same, could it be just slow replication?

I did run > yum clean all

---> Package php74-php-pecl-ssh2.x86_64 0:1.3.1-1.el7.remi will be installed
--> Processing Dependency: libssh2(x86-64) >= 1.8.0 for package: php74-php-pecl-ssh2-1.3.1-1.el7.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php74-php-pecl-ssh2-1.3.1-1.el7.remi.x86_64 (remi-safe)
           Requires: libssh2(x86-64) >= 1.8.0
           Installed: libssh2-1.4.3-12.amzn2.2.3.x86_64 (@amzn2-core)
               libssh2(x86-64) = 1.4.3-12.amzn2.2.3

Re: Conflict on php74-php-pecl-ssh2

Please post full yum output

Also check priority plugin is disable or properly configured

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Conflict on php74-php-pecl-ssh2

Repos config:

[amzn2-core]
name=Amazon Linux 2 core repository
priority=10
gpgcheck=1
enabled=1
metadata_expire=300
mirrorlist_expire=300
report_instanceid=yes

[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
failovermethod=priority
enabled=1
gpgcheck=1


[remi-safe]
name=Safe Remi's RPM repository for Enterprise Linux 7 - $basearch
enabled=1
gpgcheck=1


[remi-php74]
name=Remi's PHP 7.4 RPM repository for Enterprise Linux 7 - $basearch
mirrorlist=https://cdn.remirepo.net/enterprise/7/php74/mirror
enabled=1
gpgcheck=1

And you output:

 yum install php74-php-pecl-ssh2
Loaded plugins: ovl, priorities
amzn2-core                                                                                                                                                                          | 3.7 kB  00:00:00     
epel/x86_64/metalink                                                                                                                                                                |  26 kB  00:00:00     
epel                                                                                                                                                                                | 4.7 kB  00:00:00     
remi-php74                                                                                                                                                                          | 3.0 kB  00:00:00     
remi-safe                                                                                                                                                                           | 3.0 kB  00:00:00     
(1/8): amzn2-core/2/x86_64/group_gz                                                                                                                                                 | 2.5 kB  00:00:00     
(2/8): amzn2-core/2/x86_64/updateinfo                                                                                                                                               | 350 kB  00:00:01     
(3/8): epel/x86_64/group_gz                                                                                                                                                         |  95 kB  00:00:00     
(4/8): remi-php74/primary_db                                                                                                                                                        | 232 kB  00:00:01     
(5/8): epel/x86_64/updateinfo                                                                                                                                                       | 1.0 MB  00:00:01     
(6/8): remi-safe/primary_db                                                                                                                                                         | 1.9 MB  00:00:01     
(7/8): epel/x86_64/primary_db                                                                                                                                                       | 6.9 MB  00:00:03     
(8/8): amzn2-core/2/x86_64/primary_db                                                                                                                                               |  50 MB  00:00:23     
258 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php74-php-pecl-ssh2.x86_64 0:1.3.1-1.el7.remi will be installed
--> Processing Dependency: libssh2(x86-64) >= 1.8.0 for package: php74-php-pecl-ssh2-1.3.1-1.el7.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php74-php-pecl-ssh2-1.3.1-1.el7.remi.x86_64 (remi-safe)
           Requires: libssh2(x86-64) >= 1.8.0
           Installed: libssh2-1.4.3-12.amzn2.2.3.x86_64 (@amzn2-core)
               libssh2(x86-64) = 1.4.3-12.amzn2.2.3
           Available: libssh2-1.4.3-10.amzn2.1.x86_64 (amzn2-core)
               libssh2(x86-64) = 1.4.3-10.amzn2.1
           Available: libssh2-1.4.3-10.amzn2.1.2.x86_64 (amzn2-core)
               libssh2(x86-64) = 1.4.3-10.amzn2.1.2
           Available: libssh2-1.4.3-12.amzn2.2.x86_64 (amzn2-core)
               libssh2(x86-64) = 1.4.3-12.amzn2.2
           Available: libssh2-1.4.3-12.amzn2.2.1.x86_64 (amzn2-core)
               libssh2(x86-64) = 1.4.3-12.amzn2.2.1
           Available: libssh2-1.4.3-12.amzn2.2.2.x86_64 (amzn2-core)
               libssh2(x86-64) = 1.4.3-12.amzn2.2.2
 You could try using --skip-broken to work around the problem
** Found 18 pre-existing rpmdb problem(s), 'yum check' output follows:
ca-certificates-2020.2.41-70.0.amzn2.0.1.noarch is a duplicate with ca-certificates-2019.2.32-76.amzn2.0.3.noarch
glibc-2.26-41.amzn2.x86_64 is a duplicate with glibc-2.26-39.amzn2.x86_64
glibc-common-2.26-41.amzn2.x86_64 is a duplicate with glibc-common-2.26-39.amzn2.x86_64
glibc-minimal-langpack-2.26-41.amzn2.x86_64 is a duplicate with glibc-minimal-langpack-2.26-39.amzn2.x86_64
libcrypt-2.26-41.amzn2.x86_64 is a duplicate with libcrypt-2.26-39.amzn2.x86_64
libgcc-7.3.1-12.amzn2.x86_64 is a duplicate with libgcc-7.3.1-11.amzn2.x86_64
libgomp-7.3.1-12.amzn2.x86_64 is a duplicate with libgomp-7.3.1-11.amzn2.x86_64
libstdc++-7.3.1-12.amzn2.x86_64 is a duplicate with libstdc++-7.3.1-11.amzn2.x86_64
1:openssl-libs-1.0.2k-19.amzn2.0.6.x86_64 is a duplicate with 1:openssl-libs-1.0.2k-19.amzn2.0.4.x86_64
p11-kit-0.23.22-1.amzn2.0.1.x86_64 is a duplicate with p11-kit-0.23.21-2.amzn2.0.1.x86_64
p11-kit-trust-0.23.22-1.amzn2.0.1.x86_64 is a duplicate with p11-kit-trust-0.23.21-2.amzn2.0.1.x86_64
4:perl-5.16.3-299.amzn2.0.1.x86_64 is a duplicate with 4:perl-5.16.3-294.amzn2.x86_64
4:perl-libs-5.16.3-299.amzn2.0.1.x86_64 is a duplicate with 4:perl-libs-5.16.3-294.amzn2.x86_64
4:perl-macros-5.16.3-299.amzn2.0.1.x86_64 is a duplicate with 4:perl-macros-5.16.3-294.amzn2.x86_64
php74-php-pecl-igbinary-3.2.1-1.el7.remi.x86_64 is a duplicate with php74-php-pecl-igbinary-3.1.6-1.el7.remi.x86_64
python-2.7.18-1.amzn2.0.3.x86_64 is a duplicate with python-2.7.18-1.amzn2.0.2.x86_64
python-libs-2.7.18-1.amzn2.0.3.x86_64 is a duplicate with python-libs-2.7.18-1.amzn2.0.2.x86_64
tzdata-2020d-2.amzn2.noarch is a duplicate with tzdata-2020a-1.amzn2.noarch

thanks for your help

Re: Conflict on php74-php-pecl-ssh2

> Loaded plugins: ovl, priorities
> 258 packages excluded due to repository priority protections

So priority plugin fault.

Disable it or configure it properly

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Conflict on php74-php-pecl-ssh2

I've disabled priority (/etc/yum/pluginconf.d/priorities.conf) and magic, works now :-)

Resolving Dependencies
--> Running transaction check
---> Package php74-php-pecl-ssh2.x86_64 0:1.3.1-1.el7.remi will be installed
--> Processing Dependency: libssh2(x86-64) >= 1.8.0 for package: php74-php-pecl-ssh2-1.3.1-1.el7.remi.x86_64
--> Running transaction check
---> Package libssh2.x86_64 0:1.4.3-12.amzn2.2.3 will be updated
---> Package libssh2.x86_64 0:1.8.0-0.el7.remi will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================================================================================
 Package                                                Arch                                      Version                                               Repository                                    Size
===========================================================================================================================================================================================================
Installing:
 php74-php-pecl-ssh2                                    x86_64                                    1.3.1-1.el7.remi                                      remi-safe                                     41 k
Updating for dependencies:
 libssh2                                                x86_64                                    1.8.0-0.el7.remi                                      remi-safe                                     87 k

Transaction Summary
===========================================================================================================================================================================================================
Install  1 Package
Upgrade             ( 1 Dependent package)

Thanks again