Topic: Failed to update php-mbstring

Hi all,

I failed to update the php-mbstring package. The error message was following.

How should I do to fix this situation? I'm using RHEL6.

By the way, I found the oniguruma5php-6.9.6-1.el6.remi.x86_64 rpm file in remi-safe repository.

==========
Error: Package: php-mbstring-7.3.10-1.el6.remi.x86_64 (@remi-php73)
           Requires: libonig.so.5()(64bit)
           Removing: oniguruma5-6.9.4-1.el6.remi.x86_64 (@remi-safe)
               libonig.so.5()(64bit)
           Obsoleted By: oniguruma5php-6.9.6-1.el6.remi.x86_64 (remi-safe)
               Not found
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************



--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-754.28.1.el6 will be erased
---> Package kernel-devel.x86_64 0:2.6.32-754.28.1.el6 will be erased
---> Package oniguruma5.x86_64 0:6.9.4-1.el6.remi will be obsoleted
--> Processing Dependency: libonig.so.5()(64bit) for package: php-mbstring-7.3.10-1.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-mbstring-7.3.10-1.el6.remi.x86_64 (@remi-php73)
           Requires: libonig.so.5()(64bit)
           Removing: oniguruma5-6.9.4-1.el6.remi.x86_64 (@remi-safe)
               libonig.so.5()(64bit)
           Obsoleted By: oniguruma5php-6.9.6-1.el6.remi.x86_64 (remi-safe)
               Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
==========

This is my remi-safe.repo.

==========
# cat remi-safe.repo

# This repository is safe to use with RHEL/CentOS base repository
# it only provides additional packages for the PHP stack
# all dependencies are in base repository or in EPEL

[remi-safe]
name=Safe Remi's RPM repository for Enterprise Linux 6 - $basearch
mirrorlist=http://cdn.remirepo.net/enterprise/6/safe/mirror
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
[...]
==========

Re: Failed to update php-mbstring

You need to keep remi-php73 repository  enabled to get the benefit of the latest version 7.3.25 which uses the new library.

BTW, RHEL 6 have reached its end of life in November 2020
so the repository is closed and won't receive any more updates.

I heartily recommend upgrading to a supported version.


P.S. latest upstream version is 7.3.27 (only available in the repository for EL >= 7), which fixes some security related issues.

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi