Topic: phpMyAdmin not TOTP options for 2FA

When I try to set up 2FA in phpMyAdmin, the option for TOTP (google2fa) does not appear. Similarly, when I try to use

use PragmaRX\Google2FA\Google2FA;

It also doesn't work.

I have verified that I have installed

php-pragmarx-google2fa.noarch
php-pragmarx-google2fa5.noarch
php-pragmarx-google2fa-qrcode.noarch

The files are in /usr/share/php, but I can't for the life of me get this to work.

CentOS7. Remi repository. Everything is up to date.

Any ideas?

Re: phpMyAdmin not TOTP options for 2FA

Indeed, I found a typo in the autoloader which is fixed in new build (5.1.0-2)

https://git.remirepo.net/cgit/rpms/php/ … 1ae3f79bc8

Please try it
https://rpms.remirepo.net/enterprise/7/ … Admin.html

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: phpMyAdmin not TOTP options for 2FA

That did the trick. Thank you!

Re: phpMyAdmin not TOTP options for 2FA

Is there some way to fix this?

<?php
use PragmaRX\Google2FA\Google2FA;
$google2fa = new Google2FA();
?>
PHP Fatal error:  Uncaught Error: Class 'PragmaRX\Google2FA\Google2FA' not found in Standard input code:3
Stack trace:
#0 {main}
  thrown in Standard input code on line 3

Re: phpMyAdmin not TOTP options for 2FA

you need to require the autoloader

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: phpMyAdmin not TOTP options for 2FA

Thank you x 2!

Re: phpMyAdmin not TOTP options for 2FA

smile

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi