Topic: phpMyAdmin 5.1 for EL7

First and foremost my appreciation to Remi for making updated packages available to the community.

My CentOS 8 Stream server has: 

Installed Packages
Name         : phpMyAdmin
Version      : 5.1.0
Release      : 1.el8.remi
Architecture : noarch
Size         : 38 M
Source       : phpMyAdmin-5.1.0-1.el8.remi.src.rpm
Repository   : @System
From repo    : remi

But my CentOS 7.9 server has:

Installed Packages
Name        : phpMyAdmin
Arch        : noarch
Version     : 5.0.4
Release     : 1.el7.remi
Size        : 31 M
Repo        : installed
From repo   : remi

Google turned up https://centos.pkgs.org/7/remi-testing- … h.rpm.html but no other information or news about phpMyAdmin 5.1 for EL7. Am I missing something or is it in the work queue?

Re: phpMyAdmin 5.1 for EL7

This is in my TODO list

In short: missing dependencies

I need to updates lot of packages (doctrine, symfony, laminas...)

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: phpMyAdmin 5.1 for EL7

Thanks for the update.

Re: phpMyAdmin 5.1 for EL7

> 100 packages have been updated today, included phpMyAdmin 5.1

https://rpms.remirepo.net/enterprise/7/ … Admin.html

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

5 (edited by nomind 2021-04-04 14:56:51)

Re: phpMyAdmin 5.1 for EL7

I'm still not seeing the 5.1 version of phpMyAdmin. My yum repolist reports:

repo id                                      repo name                                                                        status
base/7/x86_64                                CentOS-7 - Base                                                                  10,072
epel/x86_64                                  Extra Packages for Enterprise Linux 7 - x86_64                                   13,571
extras/7/x86_64                              CentOS-7 - Extras                                                                   463
mariadb-main/7/x86_64                        MariaDB Server                                                                       98
mariadb-maxscale/7/x86_64                    MariaDB MaxScale                                                                      4
mariadb-tools/7/x86_64                       MariaDB Tools                                                                        13
remi-php80                                   Remi's PHP 8.0 RPM repository for Enterprise Linux 7 - x86_64                       309
remi-safe                                    Safe Remi's RPM repository for Enterprise Linux 7 - x86_64                        4,148
updates/7/x86_64                             CentOS-7 - Updates                                                                1,901

Do I have something misconfigured or am I missing a repo?

Re: phpMyAdmin 5.1 for EL7

you need "remi" repo which provides noarch packages, and stuff
overriding base or Epel repo

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: phpMyAdmin 5.1 for EL7

Thanks for the quick response. Enabled and now I've got phpMyAdmin 5.1.

Now I need to investigate why the repository was disabled on the server.

Re: phpMyAdmin 5.1 for EL7

probably because it is not enabled by default

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi