Topic: GD conflict

The error:

Last metadata expiration check: 0:00:07 ago on Thu 15 Apr 2021 04:44:02 PM EDT.
Dependencies resolved.

Problem: gd-2.3.0-3.fc33.i686 has inferior architecture
  - cannot install both gd-2.3.2-3.fc33.remi.x86_64 and gd-2.3.0-3.fc33.x86_64
  - cannot install the best update candidate for package gd-2.3.0-3.fc33.x86_64
  - cannot install the best update candidate for package gd-2.3.0-3.fc33.i686
====================================================================================================
Package           Architecture          Version                          Repository           Size
====================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
gd                x86_64                2.3.2-3.fc33.remi                remi                140 k

Transaction Summary
====================================================================================================
Skip  1 Package

Nothing to do.
Complete!


OS: Fedora 33, up to date except for gd
I followed the wizard on this forum for Fedora 33, and have a working php8 install (thank you), but the gd conflict remains.

I should note that I've re-installed several times, and this issue has plagued me in F29 through F33, in each build, regardless of the machine.

Re: GD conflict

Try removing gd.i686, you probably don't need it


(else ignore this issue, and keep 2.3.0 from F33)

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: GD conflict

Sadly, I game with Wine on this machine, so I have to keep gd.

Re: GD conflict

So keep gd 2.3.0 from Fedora and ignore this update (ABI is compatible, you will simply don't benefit from avif support, btw, PHP don't use it for now)

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: GD conflict

Until Fedora 30, I was building both i686 and x86_64 packages, but since F31 the 32-bit distribution is  no more a primary arch, so I don't build them.

I need to see if I can set a mock configuration, only for this package....

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: GD conflict

32-bit build of gd are now also available in the repo

this issue should be fixed

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi