Topic: Imagick PECLpackage obsolete?

Checking yum updates, seems that imagick is becoming obsolete:

...
php74-php-xml.x86_64                    7.4.21-1.el7.remi           remi
Obsoleting Packages
php74-php-pecl-imagick-im6.x86_64       3.5.0-1.el7.remi            remi
    php74-php-pecl-imagick.x86_64       3.4.4-17.el7.remi           @remi


Does this mean that Imagick PECL package is now obsolete, or is this something I have to check with the remi repository?

If it's becoming obsolete, what's the alternative API to use?

Thank you.

Re: Imagick PECLpackage obsolete?

php74-php-pecl-imagick is obsoleted by php74-php-pecl-imagick-im6

So no change (only different package name)

but you can now choose between php74-php-pecl-imagick-im6 and php74-php-pecl-imagick-im7

As described in https://github.com/remicollet/remirepo/issues/179
And announced
https://twitter.com/RemiRepository/stat … 4870247424

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Imagick PECLpackage obsolete?

Thanks!

Sorry - does this mean then, that if I do "yum update", the package will be replaced?
So, there's nothing I need to do like removing one and installing the other manually?


I use ImageMagick 7, but seems yum wants to make it use im6:


# convert -v
Version: ImageMagick 7.1.0-0 Q16 x86_64


Thank you

Re: Imagick PECLpackage obsolete?

After I did "yum update", I did:

yum swap -- install php74-php-pecl-imagick-im7 -- remove php74-php-pecl-imagick-im6


which resolved my problem.
Thank you.

Re: Imagick PECLpackage obsolete?

As explained in linked issue, previous version use ImageMagick6 library,
so the update pull the im6 variant, to keep same behavior and don't break anything.

> yum swap -- install php74-php-pecl-imagick-im7 -- remove php74-php-pecl-imagick-im6

> which resolved my problem.

smile

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi