Topic: php7.4.30 cant not load zip.so

OS:centos7

installed php packages:
gd3php.x86_64                          2.3.3-7.el7.remi               @remi-safe
oniguruma5php.x86_64                   6.9.8-1.el7.remi               @remi-safe
php74-php-bcmath.x86_64                7.4.30-1.el7.remi              @remi-safe
php74-php-cli.x86_64                   7.4.30-1.el7.remi              @remi-safe
php74-php-common.x86_64                7.4.30-1.el7.remi              @remi-safe
php74-php-fpm.x86_64                   7.4.30-1.el7.remi              @remi-safe
php74-php-gd.x86_64                    7.4.30-1.el7.remi              @remi-safe
php74-php-json.x86_64                  7.4.30-1.el7.remi              @remi-safe
php74-php-mbstring.x86_64              7.4.30-1.el7.remi              @remi-safe
php74-php-mysqlnd.x86_64               7.4.30-1.el7.remi              @remi-safe
php74-php-opcache.x86_64               7.4.30-1.el7.remi              @remi-safe
php74-php-pdo.x86_64                   7.4.30-1.el7.remi              @remi-safe
php74-php-pecl-crypto.x86_64           0.3.2-1.el7.remi               @remi-safe
php74-php-pecl-geoip.x86_64            1.1.1-11.el7.remi              @remi-safe
php74-php-pecl-imagick-im6.x86_64      3.7.0-1.el7.remi               @remi-safe
php74-php-pecl-mcrypt.x86_64           1.0.5-1.el7.remi               @remi-safe
php74-php-pecl-recode.x86_64           1.0.0~DEV.20190723-4.el7.remi  @remi-safe
php74-php-pecl-zip.x86_64              1.21.0-3.el7.remi              @remi-safe
php74-php-snmp.x86_64                  7.4.30-1.el7.remi              @remi-safe
php74-php-soap.x86_64                  7.4.30-1.el7.remi              @remi-safe
php74-php-xml.x86_64                   7.4.30-1.el7.remi              @remi-safe
php74-runtime.x86_64                   1.0-3.el7.remi                 @remi-safe

error:
PHP Warning:  PHP Startup: Unable to load dynamic library 'zip.so' (tried: /opt/remi/php74/root/usr/lib64/php/modules/zip.so (/opt/remi/php74/root/usr/lib64/php/modules/zip.so: undefined symbol: zip_register_cancel_callback_with_state), /opt/remi/php74/root/usr/lib64/php/modules/zip.so.so (/opt/remi/php74/root/usr/lib64/php/modules/zip.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

.

zip.so is in the directory but can not load,i dont know why.

libzip package/version:
 libzip5                    x86_64         1.9.2-3.el7.remi          @remi-safe         125 k
 php74-php-pecl-zip         x86_64         1.21.0-3.el7.remi         @remi-safe         140 k
.

Re: php7.4.30 cant not load zip.so

only zip.so can not work ,but others work well\

i think its libzip's problem ,
cant find this function zip_register_cancel_callback_with_state,
but i just have installed one libzip:
[root@vultr php.d]# yum list installed | grep libzip
libzip5.x86_64                         1.9.2-3.el7.remi               @remi-safe

Re: php7.4.30 cant not load zip.so

Cannot reproduce

# php74 --ri zip

zip

Zip => enabled
Zip version => 1.21.0
Libzip version => 1.9.2
BZIP2 compression => Yes
XZ compression => Yes
ZSTD compression => Yes
AES-128 encryption => Yes
AES-192 encryption => Yes
AES-256 encryption => Yes

Please check where is found the library

# rpm -qf /opt/remi/php74/root/usr/lib64/php/modules/zip.so
php74-php-pecl-zip-1.21.0-3.el7.remi.x86_64

# ldd /opt/remi/php74/root/usr/lib64/php/modules/zip.so | grep libzip
    libzip.so.5 => /lib64/libzip.so.5 (0x00007f384649d000)

# rpm -qf /lib64/libzip.so.5
libzip5-1.9.2-3.el7.remi.x86_64

# rpm --verify php74-php-pecl-zip libzip5

I suspect some manually installed old version of libzip (in /usr/local ? build from sources ?)

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi