Topic: Problème de paquet

Bonjour,

j'ai quelques problèmes de mise à jour des paquets rémi, je sais pas trop comment résoudre les problèmes. Pourtant les dépôt vers rémi sont ouverts sur mon serveur.

Erreur :
 Problème 1: cannot install both php-common-8.1.11-1.el8.remi.x86_64 and php-common-7.3.33-3.el8.remi.x86_64
  - package php-pecl-apcu-bc-1.0.5-1.el8.remi.7.3.x86_64 requires php(api) = 20180731-64, but none of the providers can be installed
  - package php-pecl-apcu-bc-1.0.5-1.el8.remi.7.3.x86_64 requires php(zend-abi) = 20180731-64, but none of the providers can be installed
  - cannot install the best update candidate for package php-common-7.3.33-3.el8.remi.x86_64
  - problem with installed package php-pecl-apcu-bc-1.0.5-1.el8.remi.7.3.x86_64
  - package php-common-7.3.5-3.module+el8.1.0+3551+6c05863c.x86_64 is filtered out by modular filtering
  - package php-common-7.3.5-5.module+el8.1.0+4560+e0eee7d6.x86_64 is filtered out by modular filtering
  - package php-common-7.3.20-1.module+el8.2.0+7373+b272fdef.x86_64 is filtered out by modular filtering
  - package php-common-7.3.33-3.el8.remi.x86_64 is filtered out by modular filtering
  - package php-common-7.3.33-5.el8.remi.x86_64 is filtered out by modular filtering
 Problème 2: package php-pecl-imagick-im6-3.7.0-1.el8.remi.8.1.x86_64 requires libMagickCore-6.Q16.so.7()(64bit), but none of the providers can be installed
  - package php-pecl-imagick-im6-3.7.0-1.el8.remi.8.1.x86_64 requires libMagickWand-6.Q16.so.7()(64bit), but none of the providers can be installed
  - cannot install both ImageMagick-libs-6.9.12.64-1.el8.x86_64 and ImageMagick-libs-1:6.9.11.48-1.el8.remi.x86_64
  - cannot install the best update candidate for package php-pecl-imagick-3.4.4-10.el8.remi.7.3.x86_64
  - problem with installed package ImageMagick-libs-1:6.9.11.48-1.el8.remi.x86_64
 Problème 3: cannot install both php-symfony4-common-4.4.46-1.el8.remi.noarch and php-symfony4-common-4.4.17-1.el8.remi.noarch
  - package php-symfony4-cache-4.4.17-1.el8.remi.noarch requires php-symfony4-common = 4.4.17-1.el8.remi, but none of the providers can be installed
  - cannot install the best update candidate for package php-symfony4-common-4.4.17-1.el8.remi.noarch
  - problem with installed package php-symfony4-cache-4.4.17-1.el8.remi.noarch
 Problème 4: cannot install both php-symfony4-filesystem-4.4.46-1.el8.remi.noarch and php-symfony4-filesystem-4.4.17-1.el8.remi.noarch
  - package php-symfony4-config-4.4.17-1.el8.remi.noarch requires php-composer(symfony/filesystem) = 4.4.17, but none of the providers can be installed
  - cannot install the best update candidate for package php-symfony4-filesystem-4.4.17-1.el8.remi.noarch
  - problem with installed package php-symfony4-config-4.4.17-1.el8.remi.noarch
 Problème 5: problem with installed package php-pecl-imagick-3.4.4-10.el8.remi.7.3.x86_64
  - package php-pecl-imagick-3.4.4-10.el8.remi.7.3.x86_64 requires php(api) = 20180731-64, but none of the providers can be installed
  - package php-pecl-imagick-3.4.4-10.el8.remi.7.3.x86_64 requires php(zend-abi) = 20180731-64, but none of the providers can be installed
  - package php-pecl-imagick-im6-3.6.0-2.el8.remi.8.1.x86_64 requires libMagickCore-6.Q16.so.7()(64bit), but none of the providers can be installed
  - package php-pecl-imagick-im6-3.6.0-2.el8.remi.8.1.x86_64 requires libMagickWand-6.Q16.so.7()(64bit), but none of the providers can be installed
  - package php-pecl-imagick-im6-3.7.0-1.el8.remi.8.1.x86_64 requires libMagickCore-6.Q16.so.7()(64bit), but none of the providers can be installed
  - package php-pecl-imagick-im6-3.7.0-1.el8.remi.8.1.x86_64 requires libMagickWand-6.Q16.so.7()(64bit), but none of the providers can be installed
  - cannot install both php-common-8.1.11-1.el8.remi.x86_64 and php-common-7.3.33-3.el8.remi.x86_64
  - cannot install both ImageMagick-libs-6.9.12.64-1.el8.x86_64 and ImageMagick-libs-1:6.9.11.48-1.el8.remi.x86_64
  - cannot install the best update candidate for package php-json-7.3.33-3.el8.remi.x86_64
  - cannot install the best update candidate for package ImageMagick-libs-1:6.9.11.48-1.el8.remi.x86_64
  - package php-common-7.3.5-3.module+el8.1.0+3551+6c05863c.x86_64 is filtered out by modular filtering
  - package php-common-7.3.5-5.module+el8.1.0+4560+e0eee7d6.x86_64 is filtered out by modular filtering
  - package php-common-7.3.20-1.module+el8.2.0+7373+b272fdef.x86_64 is filtered out by modular filtering
  - package php-common-7.3.33-3.el8.remi.x86_64 is filtered out by modular filtering
  - package php-common-7.3.33-5.el8.remi.x86_64 is filtered out by modular filtering

merci de votre aide.

Re: Problème de paquet

Visiblement il s'agit d'une tentative de passage de 7.3 à 8.1

Je n'ai pas toutes les informations pour bien comprendre le problème (dépôt actif, commande utilisé, paquet installés)

>  - problem with installed package php-pecl-apcu-bc-1.0.5-1.el8.remi.7.3.x86_64

l'extension apcu_bc n'est pas compatible avec PHP 8+

Soit elle est nécessaire, dans ce cas la mise à jour n'est pas possible
Sinon, il faut l'enlever avant la MAJ (l'option --allowerasing peut aider)

>  - cannot install both ImageMagick-libs-6.9.12.64-1.el8.x86_64 and ImageMagick-libs-1:6.9.11.48-1.el8.remi.x86_64

étrange.... faut que je fouille
le plus simple et de retirer ce paquet "avant" la mise à jour et réinstaller l'extension imagick ensuite

>  - problem with installed package php-symfony4-cache-4.4.17-1.el8.remi.noarch

ce paquet a du être installé depuis "remi" qui n'est plus activé.

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi