1 (edited by Lolo Irie 2023-02-03 13:42:42)

Topic: PostgreSQL (libpq) Version

Bonjour,

J'ai une application PHP 8.1 installée sur Red Hat Enterprise Linux Server release 7.9 (Maipo) qui se connecte à une base de données Postgresql.

Suite à changement du mode de chiffrement des mots de passes dans la base Postgresql, l'application ne peut plus se connecter:
Warning: pg_connect(): Unable to connect to PostgreSQL server: SCRAM authentication requires libpq version 10 or above

Effetivement PHP m'indique pour l'extension pgsql: PostgreSQL (libpq) Version    9.2.24

Comment puis je mettre à jour cette version de libpq ?

Merci pour toute aide et bravo/merci pour tout le travail ici (même si je ne suis plus trop sur PHP depuis des années, c'est fort appréciable !!!)

Re: PostgreSQL (libpq) Version

> Comment puis je mettre à jour cette version de libpq ?

Désolé mais ce n'est pas possible (sauf à tout recompiler)

> J'ai une application PHP 8.1 installée sur Red Hat Enterprise Linux Server release 7.9 (Maipo) qui se connecte à une base de données Postgresql.

RHEL 7 a plus de 8 ans et est proche de sa fin de vie (Juin 2024) et tout est vieux dessus.

Je recommande d'utiliser une version plus récente, en particulier pour utiliser des fonctionnalités récentes (ex: PHP 8)

* RHEL 8.7 fournit libpq 13.5
* RHEL 9.1 fournit libpq 13.5

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: PostgreSQL (libpq) Version

Un grand merci pour la réponse !

OK c'est noté pour RHEL 7, mais dans mes tentatives diverses pour résoudre le problème, je n'ai pas réussi l'installation de RHEL8 de mémoire. Mais je vais donc devoir m'y pencher sérieusement.

En attendant j'ai réussi à résoudre le problème avec une méthode pas très jolie jolie...
Installation complète de Postgresql sur la machine de l'application:

yum -y install https://download.postgresql.org/pub/rep … noarch.rpm
yum -y install postgresql14