Topic: Firefox dernière version beta

Salut remi,
Je viens d'essayer de mettre à jour firefox 4.0 beta 10 en installant firefox-4.0-0.22.beta11.build2.fc14.remi.x86_64 depuis ton dépôt remi-test et j'ai le message d'erreur suivant :

[root@localhost ~]# yum update
Modules complémentaires chargés : fastestmirror, langpacks, presto
Adding fr_BE to language list
Loading mirror speeds from cached hostfile
* fedora: mirror.netrino.co.uk
* kde: ftp.heanet.ie
* remi: iut-info.univ-reims.fr
* remi-test: iut-info.univ-reims.fr
* rpmfusion-free: mirror.karneval.cz
* rpmfusion-free-updates: mirror.karneval.cz
* rpmfusion-nonfree: mirror.karneval.cz
* rpmfusion-nonfree-updates: mirror.karneval.cz
* updates: mirror.leaseweb.com
Configuration du processus de mise à jour
Résolution des dépendances
--> Lancement de la transaction de test
--> Traitement de la dépendance : libmozalloc.so()(64bit) pour le paquet : firefox-4.0-0.22.beta11.build2.fc14.remi.x86_64
---> Paquet firefox.x86_64 0:4.0-0.22.beta11.build2.fc14.remi marqué pour être mis à jour
--> Traitement de la dépendance : xulrunner2 >= 2.0-0.19 pour le paquet : firefox-4.0-0.22.beta11.build2.fc14.remi.x86_64
--> Lancement de la transaction de test
---> Paquet xulrunner2.x86_64 0:2.0-0.19.beta11.build2.fc14.remi marqué pour être installé
--> Traitement de la dépendance : libjpeg.so.62(LIBJPEG_6.2)(64bit) pour le paquet : xulrunner2-2.0-0.19.beta11.build2.fc14.remi.x86_64
--> Résolution des dépendances terminée
Erreur : Package: firefox-4.0-0.22.beta11.build2.fc14.remi.x86_64 (remi-test)
    Requires: libmozalloc.so()(64bit)
    Suppression: firefox-4.0-0.20.beta10.fc14.remi.x86_64 (@remi-test)
        libmozalloc.so()(64bit)
    Updated By: firefox-4.0-0.22.beta11.build2.fc14.remi.x86_64 (remi-test)
        Not found
    Available: bluegriffon-0.9-0.1.hg20110128.fc14.remi.x86_64 (remi)
        libmozalloc.so()(64bit)
    Available: firefox4-4.0-0.11.beta7.build1.fc14.remi.x86_64 (remi-test)
        libmozalloc.so()(64bit)
    Available: firefox4-4.0-0.13.beta8.build1.fc14.remi.x86_64 (remi-test)
        libmozalloc.so()(64bit)
    Available: firefox4-4.0-0.17.beta9.fc14.remi.x86_64 (remi)
        libmozalloc.so()(64bit)
    Available: firefox4-4.0-0.19.beta10.fc14.remi.x86_64 (remi)
        libmozalloc.so()(64bit)
    Available: xulrunner2-2.0-0.18.beta10.fc14.remi.x86_64 (remi-test)
        libmozalloc.so()(64bit)
    Available: xulrunner2-2.0-0.19.beta11.build2.fc14.remi.x86_64 (remi-test)
        libmozalloc.so()(64bit)Package: xulrunner2-2.0-0.19.beta11.build2.fc14.remi.x86_64 (remi-test)
    Requires: libjpeg.so.62(LIBJPEG_6.2)(64bit)
Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
You could try running: rpm -Va --nofiles --nodigest

Il faut attendre encore un peu avant de réessayer ?

Re: Firefox dernière version beta

Oui, j'ai remarqué ça aussi sur une autre machine...

yum remove firefox
yum --enablerepo=remi,remi-test install firefox

Pour moi c'est un bug de yum.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Firefox dernière version beta

Remi wrote:

Oui, j'ai remarqué ça aussi sur une autre machine...

yum remove firefox
yum --enablerepo=remi,remi-test install firefox

Pour moi c'est un bug de yum.

Ok remi, ça a fonctionné.

Je suis maintenant avec firefox-4.0-0.23.beta11.build3.fc14.remi.x86_64
Ça m'a installé en même temps xulrunner2-2.0-0.20.beta11.build3.fc14.remi.x86_64

A+

Re: Firefox dernière version beta

Vi c'est normal.

C'est la grosse nouveauté de ce build. L'utilisation d'un xulrunner séparé (j'en ai besoin pour d'autres paquets, notamment BlueGriffon).

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi