Topic: mosquitto support in PHP8.x

Remi,

Are there any plans to support mosquitto in the PHP8 repos?

TheWitness

Re: mosquitto support in PHP8.x

See https://pecl.php.net/package/Mosquitto

This extension was never released as "stable"
Last "beta" version was released 6 years ago
and is not compatible with recent PHP versions

So you should try to ask upstream on https://github.com/mgdm/Mosquitto-PHP/

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: mosquitto support in PHP8.x

Thanks Remi.  I had reached out to him and there were things said, but never delivered.  I've switched to the composer 100% PHP version and it's working well. Not to sure about scalability.  I'll get there though.  I'm working on a streams plugin for Cacti.  Take me the summer to complete it.