Topic: php 8 with OpenSSL 1.1.1 on Centos 7

Hi,

is it possible to have php 8 with OpenSSL 1.1.1 on Centos 7?

I need to use an extension which needs OpenSSL 1.1.1, but seems overkill to have to upgrade the OS and all the ansible deploy scripts just to be able to use the php extension (couchbase PHP SDK 4.1.1)

Is there any way in which I could have the above setup?

Thank you,
Flaviu

Re: php 8 with OpenSSL 1.1.1 on Centos 7

> is it possible to have php 8 with OpenSSL 1.1.1 on Centos 7?

not from me.

Sorry, but OpenSSL is a too critical system library
and updating it will also imply to rebuild nearly all the distro

EL-7 is close to its end of life in a few months
Everything is too old on EL-7

And indeed couchbase extension, also available in the repository, is no more compatible with EL-7
SO you should really consider the update to EL-8 or EL-9

For modern feature, use modern distro.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: php 8 with OpenSSL 1.1.1 on Centos 7

IMHO you should rather report this to couchbase upstream

Changing such requirement in a minor release (4.1.0 => 4.1.1) may be considered as a regression

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: php 8 with OpenSSL 1.1.1 on Centos 7

Despite there is something in their changelog,
version 4.1.2 still requires OpenSSL 1.1,
so is still not buildable on CentOS 7

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: php 8 with OpenSSL 1.1.1 on Centos 7

I have talked to them and they were super nice and made a change that will allow us to make this work with opensslsl11 which is available in centos7. They had to do some custom work to make it work (detect the correct version)

Re: php 8 with OpenSSL 1.1.1 on Centos 7

> ... this work with opensslsl11 which is available in centos7.

This is damn crazy.

PHP and all extensions are built using OpenSSL 1.0

This will result in having both OpenSSL 1.0 and 1.1 in the same process
Nobody serious should do this

Prepare yourself to random segfault.


P.S. of course, I already know EL-7 have openssl11, but don't plan to use it
again EL-7 is old, terribly old. Really better to switch as soon as possible to EL-8 or EL-9

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi