Topic: libgd.so.103 missing

# yum --disablerepo=ius install phpmyadmin
Loaded plugins: fastestmirror, priorities, protectbase, remove-with-leaves, replace, show-leaves
Loading mirror speeds from cached hostfile
[...]
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:4.4.15.10-6.el7 will be installed
--> Processing Dependency: php-gd >= 5.3.7 for package: phpMyAdmin-4.4.15.10-6.el7.noarch
--> Processing Dependency: php-php-gettext for package: phpMyAdmin-4.4.15.10-6.el7.noarch
--> Processing Dependency: php-tcpdf for package: phpMyAdmin-4.4.15.10-6.el7.noarch
--> Processing Dependency: php-tcpdf-dejavu-sans-fonts for package: phpMyAdmin-4.4.15.10-6.el7.noarch
--> Processing Dependency: php-zip for package: phpMyAdmin-4.4.15.10-6.el7.noarch
--> Running transaction check
---> Package php-gd.x86_64 0:8.1.18-1.el7.remi will be installed
--> Processing Dependency: libgd.so.103()(64bit) for package: php-gd-8.1.18-1.el7.remi.x86_64
---> Package php-pecl-zip.x86_64 0:1.21.1-1.el7.remi.8.1 will be installed
--> Processing Dependency: libzip5(x86-64) >= 1.9.2 for package: php-pecl-zip-1.21.1-1.el7.remi.8.1.x86_64
--> Processing Dependency: libzip.so.5()(64bit) for package: php-pecl-zip-1.21.1-1.el7.remi.8.1.x86_64
---> Package php-php-gettext.noarch 0:1.0.12-1.el7 will be installed
---> Package php-tcpdf.noarch 0:6.2.26-1.el7 will be installed
--> Processing Dependency: php-composer(fedora/autoloader) for package: php-tcpdf-6.2.26-1.el7.noarch
--> Processing Dependency: php-tidy for package: php-tcpdf-6.2.26-1.el7.noarch
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.26-1.el7 will be installed
--> Running transaction check
---> Package php-fedora-autoloader.noarch 0:1.0.1-2.el7 will be installed
---> Package php-gd.x86_64 0:8.1.18-1.el7.remi will be installed
--> Processing Dependency: libgd.so.103()(64bit) for package: php-gd-8.1.18-1.el7.remi.x86_64
---> Package php-pecl-zip.x86_64 0:1.21.1-1.el7.remi.8.1 will be installed
--> Processing Dependency: libzip5(x86-64) >= 1.9.2 for package: php-pecl-zip-1.21.1-1.el7.remi.8.1.x86_64
--> Processing Dependency: libzip.so.5()(64bit) for package: php-pecl-zip-1.21.1-1.el7.remi.8.1.x86_64
---> Package php-tidy.x86_64 0:8.1.18-1.el7.remi will be installed
--> Processing Dependency: libtidy.so.5()(64bit) for package: php-tidy-8.1.18-1.el7.remi.x86_64
--> Running transaction check
---> Package libtidy.x86_64 0:5.4.0-1.el7 will be installed
---> Package php-gd.x86_64 0:8.1.18-1.el7.remi will be installed
--> Processing Dependency: libgd.so.103()(64bit) for package: php-gd-8.1.18-1.el7.remi.x86_64
---> Package php-pecl-zip.x86_64 0:1.21.1-1.el7.remi.8.1 will be installed
--> Processing Dependency: libzip5(x86-64) >= 1.9.2 for package: php-pecl-zip-1.21.1-1.el7.remi.8.1.x86_64
--> Processing Dependency: libzip.so.5()(64bit) for package: php-pecl-zip-1.21.1-1.el7.remi.8.1.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-zip-1.21.1-1.el7.remi.8.1.x86_64 (remi-php81)
           Requires: libzip.so.5()(64bit)
Error: Package: php-gd-8.1.18-1.el7.remi.x86_64 (remi-php81)
           Requires: libgd.so.103()(64bit)
Error: Package: php-pecl-zip-1.21.1-1.el7.remi.8.1.x86_64 (remi-php81)
           Requires: libzip5(x86-64) >= 1.9.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

i could take libzip5 from ius, but should libgd.so.103 as requireent of php-gd not be provided by remi-81 ?

Re: libgd.so.103 missing

1/ EL-7 is old, terribly old, close to its end of life in 1 year

https://blog.centos.org/2023/04/end-dat … s-linux-7/

For modern features, such as PHP 8.1, I recommend a modern distro, so EL-8 or best EL-9

2/ For proper repository configuration and usage follow the wizard instructions

https://rpms.remirepo.net/wizard/

3/ Missing dep

See the FAQ https://blog.remirepo.net/pages/English-FAQ#deps

I think "remi-safe" is missing or disabled

Please post full yum command output, some information is missing in your paste
So add the "yum repolist" output

4/ don't mix package from other 3rd party repository

especially from IUS which is no more active, and really outdated.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: libgd.so.103 missing

>  ---> Package phpMyAdmin.noarch 0:4.4.15.10-6.el7 will be installed

You are trying to install phpMyAdmin 4 from EPEL which is terribly old,
consistent for terribly old PHP 5.4 in the distribution, but not with recent PHP

In "remi" you will find version 5.2 which supports recent PHP versions

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: libgd.so.103 missing

oops about epel ...

ius was for git222 and tmux2

yum --enablerepo=remi install phpmyadmin # this works fine

thanks