Topic: Meilleur moyen d'avoir php 5.6 sur un VPS récent

Bonjour,

J'ai un ami qui voudrait remonter un vieux forum phpBB ainsi que d'autres vieux sites. À cet effet, il a investi dans un VPS chez OVH (Essential 2vcore, 4 Go de RAM, 80 Go de SSD) pour y mettre tous ses hébergements.
Le problème, c'est que j'ai des vieux sites encore en PHP 5.6 et que pour les mettre à jour, j'aurais besoin de pouvoir changer la version de PHP en incluant PHP 5.6 (passage du phpBB de la version 3.0 à 3.3, ainsi que d'autres sites pour lesquels je devrai mettre à jour les connexions MySQL via PDO).
Pour donner le contexte, mais si je ne suis pas mauvais en codage web, je suis par contre assez nul en administration de serveur.
Pour le moment, j'ai installé Virtualmin sur l'image Rocky 9 fournie par OVH. J'ai pu ajouter des versions plus récentes de PHP en suivant ce tutoriel : https://www.virtualmin.com/documentatio … ltiplephp/

Je suis bloqué sur la suite. Il est possible que ce ne soit même pas possible de le faire sur un système d'exploitation aussi récent. OVH propose d'autres distributions, peut-être une piste à explorer...

Bien sûr, je comprends les risques d'utiliser une version aussi ancienne que PHP 5.6 et j'agirai en conséquence en protégeant tout l'hébergement, par exemple, via une authentification Apache.
De plus, je tiens à souligner qu'il s'agit de vieilles données non critiques.

Merci d'avance pour toute réponse constructive !

Re: Meilleur moyen d'avoir php 5.6 sur un VPS récent

> ... VitualMin...

Désolé, je peux pas aider

Je ne peux aider qu'avec mon dépôt

Il est possible d'installer plusieurs versions

Voir les instructions de l'assistant (lien en haut à droite de toute les pages)

- EL-8 dispose de PHP 5.6 à 8.2
- EL-9 dispose de PHP 7.4 à 8.2

Pour mémoire, EL-9 fournit OpenSSL 3.0 est seul les versions PHP >= 8.1 sont officiellement compatibles
(donc dans mon dépôt 7.4 et 8.0 ont des correctifs de rétroportage de la compatibilité)

Donc pour toute version ancienne (<= 8.0), il est préférable de garder EL-8

Et pour info, toutes les failles de sécurité sont corrigées dans les versions non maintenues (rétro-portage)
Ex: https://blog.remirepo.net/post/2019/02/ … 6-est-mort

Voir pour un exemple de configuration:
https://blog.remirepo.net/post/2022/02/ … ravail-PHP

C'est sur ce principe que fonctionne le serveur qui héberge mes sites

- PHP 8.1 par défaut pour toutes les applis (blog...)
- PHP 7.4 installé à côté pour le vieux PunBB (forum)

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Meilleur moyen d'avoir php 5.6 sur un VPS récent

D’abord je tiens à vous remercier pour votre réactivité et également pour le travail que vous effectuez auprès de la fondation php et du support de votre dépôt.
Je ne comptes plus les machines (sous Centos 5 puis 6) ou j'ai eu à installer votre dépôt !

Pour Virtualmin, il s'agit justement d'activer votre dépôt pour faire du multiple php:

Installing on Alma, Rocky, CentOS Stream, Fedora Linux
Install Remi repository and clear cache

. /etc/os-release && dnf -y install https://rpms.remirepo.net/enterprise/remi-release-$(rpm -E %$ID).rpm && dnf clean all

Install additional PHP packages

dnf install php81-php-{cli,fpm,pdo,gd,mbstring,mysqlnd,opcache,xml,zip}

Note: php81 should be replaced with the PHP version you want to install, i.e. php74. Depending on your OS version, different versions of PHP may be available, which you'll have to check the Remi repository website or search for available packages using dnf search php command.

Sauf que malheureusement:

dnf install php56-php-{cli,fpm,pdo,gd,mcrypt,mbstring,mysqlnd,opcache,xml,zip}
Last metadata expiration check: 0:01:47 ago on Fri May 12 07:51:26 2023.
No match for argument: php56-php-cli
No match for argument: php56-php-fpm
No match for argument: php56-php-pdo
No match for argument: php56-php-gd
No match for argument: php56-php-mcrypt
No match for argument: php56-php-mbstring
No match for argument: php56-php-mysqlnd
No match for argument: php56-php-opcache
No match for argument: php56-php-xml
No match for argument: php56-php-zip
Error: Unable to find a match: php56-php-cli php56-php-fpm php56-php-pdo php56-php-gd php56-php-mcrypt php56-php-mbstring php56-php-mysqlnd php56-php-opcache php56-php-xml php56-php-zip

Me confirmez vous qu'avec une distribution compatible EL-8 je pourrais installer php56, que me conseillez vous entre almalinux 8 et rocky 8 ?
OVH propose aussi des distributions possible chez Debian, Ubuntu, Fedora, etc. mais que je connais moins, cependant je comptes plus sur virtualmin que sur mes capacités d'administration...

Merci d'avance pour votre réponse.

Re: Meilleur moyen d'avoir php 5.6 sur un VPS récent

j'ai déjà repondu et je confirme: EL-8 dispose de PHP 5.6 à 8.2

Pas d'avis sur les clones, juste une préférence pour l'original RHEL
(il y a des souscriptions gratuites)

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Meilleur moyen d'avoir php 5.6 sur un VPS récent

Merci encore et désolé du dérangement, je me noie vite dans un verre d'eau...

...enfin plutôt dans une fenêtre de terminal SSH pour être plus exact ! ;-)

Il n'y a malheureusement pas de RHEL dans les distributions possible pour les VPS OVH, je vais tenter AlmaLinux 8 qui semble perenne et légèrement plus proche de ce dont je mon expérience avec Centos.