Topic: Old Package EL6 php-imap-5.6

Hi.
I need the package php-imap-5.6 for CentOS 6.8 x86_64.

php-imap-5.6.26(el6) and dependent packages
php-imap-5.6.37(el6) and dependent packages
It probably depends on "libc-client"

I have read and understand the disclaimer.
Sorry, it became necessary due to customer's convenience.

Thank you.

Re: Old Package EL6 php-imap-5.6

> php-imap-5.6.26(el6) and dependent packages

Sorry but I don't have this very old thing in my online archive

> php-imap-5.6.37(el6) and dependent packages

See http://rpms.remirepo.net/store/php/imap/5.6.37/

> It probably depends on "libc-client"

This one is from EPEL

NOTICE: CentOS-6 went EOL on 30 November, 2020 ( 2 years, 23 weeks, 5 days, 6 hours, 9 minutes, and 46 seconds ago )

So you are missing years of security updates

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Old Package EL6 php-imap-5.6

Thank you so much Remi!

> Sorry but I don't have this very old thing in my online archive

I'll try another way.

> This one is from EPEL

Sorry, Thanks to you, I was able to find it.

> So you are missing years of security updates

I will try to advise the customer again.

Re: Old Package EL6 php-imap-5.6

At least you should use latest php-5.6.40-23 everywhere to get lot of recent PHP security fixes
All changes after 5.6.37 being security fixes

And plan ASAP an update to a supported distro (EL-7 will be EOL in 1 year, EL-8 still have PHP 5.6, EL-9 only have PHP 7.4+)

Latest build for 5.6 being 5.6.40-36

And also plan an update of all app to support PHP 8

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Old Package EL6 php-imap-5.6

> I need the package php-imap-5.6 for CentOS 6.8 x86_64.

And also update to 6.10..... without delay

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Old Package EL6 php-imap-5.6

I can't even understand how such an outdated server is still being used...
Seriously...

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Old Package EL6 php-imap-5.6

Thank you for your advice.
I think so too.
It's because a server on the local network, I heard.

Due to security concerns, could you please hide this topic just in case?