Topic: thunderbird-lightning 1.0 requires thunderbird3

I am continuously being asked to update thunderbird-lightning, which fails because has thunerbird3 listed as a dependency, which doesn't exist as of thunderbird-3.0-2.5.b3.

uname -a: Linux omega7 2.6.27.25-78.2.56.fc9.i686 #1 SMP Thu Jun 18 12:47:50 EDT 2009 i686 i686 i386 GNU/Linux
cat /etc/fedora-release: Fedora release 9 (Sulphur)
kded4 -v:
Qt: 4.5.2
KDE: 4.2.4 (KDE 4.2.4)
KDE Daemon: $Id: kded.cpp 944896 2009-03-26 13:00:10Z dfaure $

$ yum repolist | grep -i remi
remi                      Les RPM de remi pour Fedora 9 - i386    enabled:   205
remi-test                 Les RPM de remi en test pour Fedora 9 - enabled:     6

$ yum list thunderbird-lightning
Loaded plugins: refresh-packagekit
Installed Packages
thunderbird-lightning.i386                              0.9-2.fc9.1                                               installed
Available Packages
thunderbird-lightning.i386                              1.0-0.2.20090302hg.fc9.remi                               remi

$ yum deplist thunderbird-lightning-1.0-0.2.20090302hg.fc9.remi.i386 | grep -i thunderbird
package: thunderbird-lightning.i386 1.0-0.2.20090302hg.fc9.remi
  dependency: thunderbird3

$ yum list thunderbird
Loaded plugins: refresh-packagekit
Installed Packages
thunderbird.i386                                       3.0-2.5.b3.fc9.remi                                        installed

$ sudo yum update thunderbird-lightning
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package thunderbird-lightning.i386 0:1.0-0.2.20090302hg.fc9.remi set to be updated
--> Processing Dependency: thunderbird3 for package: thunderbird-lightning
--> Finished Dependency Resolution
thunderbird-lightning-1.0-0.2.20090302hg.fc9.remi.i386 from remi has depsolving problems
  --> Missing Dependency: thunderbird3 is needed by package thunderbird-lightning-1.0-0.2.20090302hg.fc9.remi.i386 (remi)
Error: Missing Dependency: thunderbird3 is needed by package thunderbird-lightning-1.0-0.2.20090302hg.fc9.remi.i386 (remi)


thanks.

Re: thunderbird-lightning 1.0 requires thunderbird3

You're right.

Actual version of lightning (20090302hg) is not compatible with latest TH 3.0b3. That's the reason why I haven't rebuild it yet. So I ned to work on it.

A "simple" rebuild version will not work (extension disabled at TH launch).

Stay tuned.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: thunderbird-lightning 1.0 requires thunderbird3

Please try new build

sunbird and thunderbird-lightning-1.0-0.5.20090715hg

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: thunderbird-lightning 1.0 requires thunderbird3

Perfect!  Thanks for the quick response.  I had no problem with the new build.