Topic: Dépendances php-pear pour php-pear-Cache-Lite

Bonjour, j'ai ajouté le dépôt EPEL pour installer GLPI sur une distribution FAN1.1 (CentOS5).

Seulement une dépendance ne peut être résolue:

[root@fan ~]# yum install glpi
...
--> Finished Dependency Resolution
php-pear-Cache-Lite-1.7.5-1.el5.noarch from epel has depsolving problems
  --> Missing Dependency: php-pear(PEAR) >= 1.4.9 is needed by package php-pear-Cache-Lite-1.7.5-1.el5.noarch (epel)
Error: Missing Dependency: php-pear(PEAR) >= 1.4.9 is needed by package php-pear-Cache-Lite-1.7.5-1.el5.noarch (epel)
[root@fan~]# rpm -qa php-pear
php-pear-1.5.0-3

le Package php-pear-Cache-Lite nécessite  php-pear 1.4.9 ou supérieure or j'ai la version 1.5.0. J'ai testé aussi avec le package php-pear-Cache-Lite-1.7.4-1.el5.remi.noarch avec le même résultat.

Y a t'il une solution a se genre de problème.

Merci.

Re: Dépendances php-pear pour php-pear-Cache-Lite

Malheureusement FAN remplace beaucoup de paquets standards, et visiblement pas très bien...

Avec le paquet officiel :

$ rpm -q php-pear
php-pear-1.4.9-4.el5.1
$ rpm -q --provides php-pear
config(php-pear) = 1:1.4.9-4.el5.1
php-pear(Archive_Tar) = 1.3.1
php-pear(Console_Getopt) = 1.2
php-pear(PEAR) = 1.4.9
php-pear(XML_RPC) = 1.5.0
php-pear = 1:1.4.9-4.el5.1

Avec le paquet de chez FAN

$ rpm -qp --provides /tmp/php-pear-1.5.0-3.noarch.rpm 
php-pear = 1:1.5.0-3

Donc déjà, je pense qu'il serait bien de leur signaler le problème pour qu'ils corrigent leur paquet.

Ensuite pour ton problème :
- soit revenir sur le php-pear standard, mais Centreon risque de ne pas apprécier
- soit monter en version en prenant le php-pear de mon dépôt.

A+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Dépendances php-pear pour php-pear-Cache-Lite

Merci, ça a l'air de fonctionner (pour GLPI et Centreon)

rpm -Uvh --force php-pear-1.8.1-1.el5.remi.noarch.rpm

J'ai du utilisé l'option --force pour passer quelque conflit.