Topic: PHP-CGI-5.3.2-1 avec pdo

Bonjour,

Je teste une solution collaborative installée sur un serveur sme7.5.1 basé sur Centos4.8.
J'utilise une contrib utilisant php5 en parallèle de php4 (natif sur sme). Ce fichier php-cgi-5.3.2-1
n'inclu pas php_pdo nécéssaire au bon fonctionnement de l'application.

Je tente de compiler les sources de php5-3.2 sur un serveur centos 4.8 ayant le même noyau que ma sme.

Je rencontre des pbs à la configuration:

root@localhost php5.3-201109030630]# ./configure --prefix=/usr/ --with-apxs2=/usr/bin/apxs2 --with-config-file-path=/etc/php/ --disable-ipv6 --with-curl --enable-ftp --with-gd --enable-intl --enable-mbstring --with-mcrypt --with-mhash --with-mysql=mysqlnd --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --enable-soap --with-pear --with-xsl --with-zlib --with-openssl
loading cache ./config.cache
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for icc... no
checking for suncc... no
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking whether ln -s works... yes
checking for system library directory... lib
checking whether to enable runpaths... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for gawk... gawk
checking for bison... bison -y
checking for bison version... 1.875 (ok)
checking for re2c... no
configure: warning: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking whether to enable computed goto gcc extension with re2c... no
checking whether to force non-PIC code in shared modules... yes
checking whether /dev/urandom exists... yes
checking for pthreads_cflags... -pthread
checking for pthreads_lib...

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
checking whether to enable Apache charset compatibility option... no
checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS...

Sorry, I cannot run apxs.  Possible reasons follow:

1. Perl is not installed
2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is displayed)

The output of /usr/bin/apxs2 follows:
./configure: line 6357: /usr/bin/apxs2: No such file or directory
configure: error: Aborting

- Il me manque certainement des bouts, j'ai installé les paquet de "dev" mais...

La méthode que j'utilise fonctionne bien avec ubuntu en installant les bon paquets apache2 etc.

Pour Centos c'est httpd et j'avoue que je m'y perd un peu.

Si quelqu'un peut m'aider à ce sujet.

Quelqu'un peut-il me renseigner sur la méthode utiliser?
Est-ce impossible?

S'il manque des explications n'hésitez pas.

Merci

Pascal

Re: PHP-CGI-5.3.2-1 avec pdo

Désolé, mais cela ne concerne pas mes RPM...

En plus l'erreur me semble explicite...

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: PHP-CGI-5.3.2-1 avec pdo

Je n'ai en aucun cas mis et souhaité mettre en cause vos RPM.

J'espérais juste un peu d'aide de votre part.

Merci pour votre réponse,

Cordialement.

Re: PHP-CGI-5.3.2-1 avec pdo

Dans tous les cas il n'est pas dans mes habitudes d'encourager la compilation à partir des sources.

Sur une distribution RPM on utilise des RPM, et surtout on n'installe pas les outils de développement sur un serveur.

Vous pouvez tenter de reconstruire le RPM de php53 (le src.rpm est disponible) pour avoir une version 5.3.8 installable en parallèle (mais je l'ai pas testé sous EL-4 qui est quasiment en fin de vie).

Sinon installez les RPM disponibles dans mon dépôt, ils remplaceront php 4, mais quel intéret de conserver une version aussi obsolète (datant de 2004).

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70