Topic: Problème de dépendances avec libevent et memcached

Bonjour à tous et à toutes!

Je vous écris car j'ai un petit pépin qui m'empêche de compléter la mise à jour de mon système. Je suis avec Centos 5. Il y a quelques semaines, j'ai installé PHP/Apache des RPM de Rémi afin d'avoir la dernière version de PHP et Memcached.

Aujourd'hui, je tente de faire la mise à jour du système ( à l'aide de la commande «yum update» ) et j'ai ce problème qui me semble être un petit problème de dépendances.

Voici une copie de l'exécution du «yum update» :

Loaded plugins: fastestmirror
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository addons is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Loading mirror speeds from cached hostfile
 * epel: archive.linux.duke.edu
 * remi: iut-info.univ-reims.fr
 * centosplus: centos.mirror.iweb.ca
centosplus                                                                                                                                              |  951 B     00:00     
Reducing Les RPM de remi pour Enterprise Linux 5 - i386 to included packages only
Finished
Reducing CentOS-5 - Plus to included packages only
Finished
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You mightconsider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package openssh-server.i386 0:4.3p2-36.el5 set to be updated
---> Package php-pear-Validate.noarch 0:0.8.2-1.el5.remi set to be updated
---> Package kernel-headers.i386 0:2.6.18-164.el5 set to be updated
---> Package nspr.i386 0:4.7.5-1.el5_4 set to be updated
---> Package ecryptfs-utils.i386 0:75-5.el5 set to be updated
--> Processing Dependency: libtspi.so.1 for package: ecryptfs-utils
--> Processing Dependency: keyutils for package: ecryptfs-utils
---> Package xulrunner.i386 0:1.9.0.14-1.el5_4 set to be updated
---> Package kernel-devel.i686 0:2.6.18-164.el5 set to be installed
---> Package kernel.i686 0:2.6.18-164.el5 set to be installed
---> Package openssl.i686 0:0.9.8e-12.el5 set to be updated
---> Package php-pear-PhpDocumentor-docs.noarch 0:1.4.3-1.el5.remi set to be updated
---> Package libevent.i386 0:1.4.9-1.rhel5 set to be updated
---> Package fetchmail.i386 0:6.3.6-1.1.el5_3.1 set to be updated
---> Package lftp.i386 0:3.7.11-4.el5 set to be updated
---> Package openssl-devel.i386 0:0.9.8e-12.el5 set to be updated
---> Package proj.i386 0:4.6.1-1.rhel5 set to be updated
---> Package mhash.i386 0:0.9.9.9-1.rhel5 set to be updated
---> Package php-pear-PHP-CodeSniffer.noarch 0:1.2.0-1.el5.remi set to be updated
--> Processing Dependency: libevent-1.1a.so.1 for package: memcached
---> Package php-pear-PhpDocumentor.noarch 0:1.4.3-1.el5.remi set to be updated
---> Package php-pear-PHPUnit.noarch 0:3.3.17-1.el5.remi set to be updated
---> Package proftpd.i386 0:1.3.2a-5.el5 set to be updated
---> Package openssh-clients.i386 0:4.3p2-36.el5 set to be updated
---> Package openssh.i386 0:4.3p2-36.el5 set to be updated
---> Package geos.i386 0:2.2.3-3.rhel5 set to be updated
--> Running transaction check
---> Package trousers.i386 0:0.3.1-4.el5 set to be updated
--> Processing Dependency: libevent-1.1a.so.1 for package: memcached
---> Package keyutils.i386 0:1.2-1.el5 set to be updated
--> Finished Dependency Resolution
memcached-1.4.1-1.el5.remi.i386 from installed has depsolving problems
  --> Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.1-1.el5.remi.i386 (installed)
--> Running transaction check
---> Package kernel.i686 0:2.6.18-128.2.1.el5 set to be erased
--> Processing Dependency: libevent-1.1a.so.1 for package: memcached
---> Package kernel-devel.i686 0:2.6.18-128.2.1.el5 set to be erased
--> Finished Dependency Resolution
memcached-1.4.1-1.el5.remi.i386 from installed has depsolving problems
  --> Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.1-1.el5.remi.i386 (installed)
Error: Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.1-1.el5.remi.i386 (installed)

Je dois dire que je suis un peu embêté par ce que je dois faire afin de régler ce problème. J'apprécierai vraiment si quelqu'un aurais l'amabilité de me donner quelques pistes de solutions!

Merci à l'avance et bonne journée smile

Xavier

Re: Problème de dépendances avec libevent et memcached

Etrange.

Pour moi, c'est toujours libevent-1.1a-3.2.1 qui est disponible dans les dépôts.

D'ailleurs il y a plusieurs paquets dont je ne comprends pas la version :

  • proj.i386 0:4.6.1-1.rhel5 => proj.i386 4.5.0-3.el5 chez moi

  • mhash.i386 0:0.9.9.9-1.rhel5 => mhash.i386 0.9.9-1.el5.centos

  • geos.i386 0:2.2.3-3.rhel5 => geos.i386  2.2.3-3.el5

un yum update --exclude=libevent doit permettre de passer la maj.

Faut que je trouve d'où viennent ces paquets (avec rhel5 dans le nom).
Quels sont exactement les dépôts activés ?

A suivre...

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Problème de dépendances avec libevent et memcached

Bonjour Rémi,

Merci pour avoir pris quelques instants pour me donner un petit coup de pouce!

Par rapport aux dépôts que j'ai d'actif sur mon système, j'ai les dépôts qui viennent par défaut avec Centos, epel, remi et pgdb.( j'y ai été avec ce que j'ai dans /etc/yum.repos.d/ , vu que je ne connais pas la commande exacte (si il y en a une) pour lister les dépôts activés ).

J'ai suivi ta recommandation d'exécuter «yum update --exclude=libevent». Elle fut un succès, et ma permis d'installer les mise à jour (dont une du kernel). Évidement, quand je lance «yum update» par après, il ne me propose que libevent.

Cependant, en visitant le dépôt pgdb ( http://yum.pgsqlrpms.org/8.4/redhat/rhel-5-x86_64/ ), je crois avoir trouvé la source de mon problème. Il semble que le paquet «libevent-1.4.9-1.rhel5.x86_64.rpm» est dans ce dépôt. Or, l'hypothèse que j'ai pour régler le problème (à long terme) serait d'ajouter libevent dans les paquets à exclure de ce dépôt. Est-ce que c'est la meilleure chose à faire? Je dois dire que je suis un peu embêté par la question.

Encore une fois, merci beaucoup et bonne journée!

Xavier

Re: Problème de dépendances avec libevent et memcached

Or, l'hypothèse que j'ai pour régler le problème (à long terme) serait d'ajouter libevent dans les paquets à exclure de ce dépôt.

Sauf si ce dépôt fournit des paquets qui ont besoin de cette version de libevent.

Dans ce cas, pour travailler proprement ils auraient du fournir une compat-libevent, ce qui n'est visiblement pas le cas.

C'est le problème de mélanger les dépôts "intrusifs" (qui remplacent des bibliothèques du système)

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test