Topic: Imagemagick PHP 5.3.3 demande d'aide urgente

Bonjour,
J'ai besoin d'aide.
Serveur mini chez OVH (4Go de Ram 1To disque dur).
Plesk : 10.3.1
OS Linux 2.6.38.2-xxxx-std-ipv6-64 (Centos 5.x)

Hier j'ai upgradé PHP de la version 5.1.6 à 5.3.3 et Mysql
Aucun problème (sinon actualiser Zend-loader) SourceGuardian et autres.
LE problème : Imagemagick
Avant fonctionnait nickel.
Mais je suis confronté au bug ici :
http://pecl.php.net/bugs/bug.php?id=16057&edit=1
J'ai vu ici  par exemple : http://blog.famillecollet.com/post/2009 … ick2-6.5.x
Mon problème, désolée je ne suis pourtant pas blonde, mais comment installer les rpm
Quelqu'un peut me faire un petit tuto à utiliser avec Yum pour ceci, ce qui serait utile à d'autres.
Depuis hier je galères..... sans solutions.
Merci et bises.
Cathy

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

1/ Il n'y a aucune demande qui puisse être considéré comme urgente.

Si vous voulez des réponses "garanties", merci de prendre un support commercial.

Ne pas oublier que tout ce que vous trouvez ici est "gratuit".

2/

rpm -qa php\* Image\*
Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

3 (edited by Cathy_fr 2011-09-08 15:27:34)

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Remi wrote:

1/ Il n'y a aucune demande qui puisse être considéré comme urgente.
Désolée.... vraiment !

Si vous voulez des réponses "garanties", merci de prendre un support commercial.
Qui vous a dit que je ne donnerai rien ?

Ne pas oublier que tout ce que vous trouvez ici est "gratuit".
Oui, ca au moins je l'avais compris big_smile

2/

rpm -qa php\* Image\*

Humm, oui, et ensuite .....
Ca me donne ceci :
php5-ioncube-loader-4.0.7-11032115
ImageMagick-perl-6.2.8.0-4.el5_5.3
php53-pdo-5.3.3-1.el5_6.1
php53-mbstring-5.3.3-1.el5_6.1
php53-common-5.3.3-1.el5_6.1
php53-5.3.3-1.el5_6.1
php53-mysql-5.3.3-1.el5_6.1
php53-imap-5.3.3-1.el5_6.1
php53-xml-5.3.3-1.el5_6.1
php-pear-1.4.9-6.el5
ImageMagick-devel-6.2.8.0-4.el5_5.
ImageMagick-6.2.8.0-4.el5_5.3
ImageMagick-devel-6.2.8.0-4.el5_5.
ImageMagick-6.2.8.0-4.el5_5.3
php53-cli-5.3.3-1.el5_6.1
php53-gd-5.3.3-1.el5_6.1
php53-sqlite2-5.3.2-11041315
php53-devel-5.3.3-1.el5_6.1

Et maintenant hmm:/

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Vous n'utilisez pas les paquets de mon dépôt...

Mon dépôt fournit php 5.3.8 et plein d'extensions, dont imagick (php-pecl-imagick)

Soit vous restez avec les dépôts officiels, et vous n'aurez pas l'extension (le paquet php53-pecl-imagick n'existe pas dans EPEL), soit utilisez mon dépôt

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

5 (edited by Cathy_fr 2011-09-08 18:52:33)

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Remi wrote:

Vous n'utilisez pas les paquets de mon dépôt...

Mon dépôt fournit php 5.3.8 et plein d'extensions, dont imagick (php-pecl-imagick)

Soit vous restez avec les dépôts officiels, et vous n'aurez pas l'extension (le paquet php53-pecl-imagick n'existe pas dans EPEL), soit utilisez mon dépôt

Le petit problème expliqué plus haut, est que j'ai besoin d'aide de comment utiliser votre dépot (installation, etc)... Je suis paumée dans les rpm, dépôts etc.....

Lignes de commandes en ssh, etc etc...

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Et vous avez lu la documentation ?
http://blog.famillecollet.com/pages/Config

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Remi wrote:

Et vous avez lu la documentation ?
http://blog.famillecollet.com/pages/Config

Oui bien sur, j'ai fait :
cd /etc/yum.repos.d
wget http://rpms.famillecollet.com/enterprise/remi.repo

Ce fichier contient la déclaration des dépôts remi et remi-test.

Par contre, ils ne sont pas actifs par défaut (enabled=0). Il est donc nécessaire de les activer lors de leur utilisation, par exemple

yum --enablerepo=remi install firefox-langpack-fr

C'est après que j'ai un problème, que dois je faire, quelles commandes et quels dépot ?
Merci d'avance

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Il me semble réellement urgent de vous former à l'administration Linux avant de prendre un serveur dédié.

Conseil : installé la distribution sur "votre" PC personnel et pratiquez, pratiquez, lisez de la doc, pratiquez

Et quand vous serez prête, prenez un dédié (et votre machine perso vous servira de serveur de test).
Là, clairement vous allez dans le mur.

Désolé...

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Remi wrote:

Il me semble réellement urgent de vous former à l'administration Linux avant de prendre un serveur dédié.

Conseil : installé la distribution sur "votre" PC personnel et pratiquez, pratiquez, lisez de la doc, pratiquez

Et quand vous serez prête, prenez un dédié (et votre machine perso vous servira de serveur de test).
Là, clairement vous allez dans le mur.

Désolé...

Merci !:rolleyes:
Au moins j'auarai économisé quelque chose !
Je n'ose penser si j'avais pris un "support commercial", pour obtenir ceci comme réponse.
Merci pour votre empathie et entraide, j'en suis très touchée.:/

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Bonjour,
dans le spec de php-pecl-imagick il y a un buildrequires ImageMagick >= 6.6 mais en fait dans le repo je ne vois que le 6.5

php-pecl-imagick compile sans soucis avec ImageMagick 6.5

Bonne journée

Re: Imagemagick PHP 5.3.3 demande d'aide urgente

Pourquoi squatter un vieux sujet... ?

il y a un buildrequires ImageMagick >= 6.6

Pas exactement :

%if 0%{?fedora} >= 14 || 0%{?rhel} >= 7
BuildRequires: ImageMagick-devel >= 6.6.0
%else
BuildRequires: ImageMagick2-devel >= 6.6.0
%endif

Et ImageMagick2 est disponible dans le dépôt

php-pecl-imagick compile sans soucis avec ImageMagick 6.5

pourquoi compiler et ne pas utiliser les RPM disponibles dans le dépôt ?

Oui, il compile, mais il ne disposera pas de toutes les fonctions possibles.
J'ai justement ajouté le paquet ImageMagick2, qui peut s'installer à côté d'ImageMagick, justement pour offrir une extension "complète" aux utilisateurs de mon dépôt.

P.S d'ailleurs il faudrait que je mettre à jour en 6.7...

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70