Topic: Conflit avec mysql en tentant un upgrade php 5.3

Bonjour à toutes et tous,
J'ai parcouru le forum et j'ai vu des topics sur ce sujet, mais rien qui ne corresponde vraiment.

D'abord les infos principales :

CentOS release 5.7 (Final)
Linux version 2.6.18-194.26.1.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48))
x86_64
Version Plesk : 10.2.0
PHP : 5.1.6

Infos MySQL

mysql.x86_64                           5.0.77-4.el5_4.2                installed
mysql-server.x86_64                    5.0.77-4.el5_4.2                installed
php-mysql.x86_64                       5.1.6-27.el5                    installed

neutral Sûrement ci-dessus que ça pêche...

J'ai essayé d'installer :


Et voici le résultat :

Dependencies Resolved

===============================================================================================================
Package                         Arch                Version                         Repository           Size
===============================================================================================================
Installing:
php-ioncube-loader              x86_64              1:4.0.10-1.el5.art              atomic              1.3 M
     replacing  php5-ioncube-loader.x86_64 3.1-07051711

Updating:
php                             x86_64              5.3.8-5.el5.remi.1              remi                2.8 M
php-cli                         x86_64              5.3.8-5.el5.remi.1              remi                2.6 M
php-common                      x86_64              5.3.8-5.el5.remi.1              remi                991 k
php-gd                          x86_64              5.3.8-5.el5.remi.1              remi                209 k
php-imap                        x86_64              5.3.8-5.el5.remi.1              remi                 89 k
php-mbstring                    x86_64              5.3.8-5.el5.remi.1              remi                2.3 M
php-mysql                       x86_64              5.3.8-5.el5.remi.1              remi                 95 k
php-pdo                         x86_64              5.3.8-5.el5.remi.1              remi                119 k
php-pear                        noarch              1:1.9.4-3.el5.remi              remi                436 k
php-xml                         x86_64              5.3.8-5.el5.remi.1              remi                223 k
Installing for dependencies:
mysql-libs                      x86_64              5.5.17-2.el5.art                atomic              1.1 M
php-devel                       x86_64              5.3.8-5.el5.remi.1              remi                1.3 M

Transaction Summary
===============================================================================================================
Install       3 Package(s)
Upgrade      10 Package(s)

Total size: 14 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/my.cnf from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with file from package mysql-5.
0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fi
le from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with f
ile from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/charsets/cp1251.xml from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with f
ile from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with file
from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fil
e from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with file
from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fi
le from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with f
ile from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fil
e from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fil
e from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with file
from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with
file from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fi
le from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with f
ile from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fil
e from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts wi
th file from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with
file from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fil
e from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with
file from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with f
ile from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fi
le from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fi
le from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fil
e from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fi
le from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with fi
le from package mysql-5.0.77-4.el5_4.2.x86_64
  file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.5.17-2.el5.art.x86_64 conflicts with
file from package mysql-5.0.77-4.el5_4.2.x86_64

Error Summary

Bref c'est le gros foutoir !
Comment puis-je faire pour nettoyer tout ça et installer PHP 5.3.8 proprement ? Sans perdre de données, si possible, le serveur est en prod.
Je vous remercie beaucoup pour votre aide.

Re: Conflit avec mysql en tentant un upgrade php 5.3

Si tu veux uniquement mettre à jour PHP, il faut commencer par installer compat-mysql55 depuis remi-test

Si tu veux aussi mettre à jour MySQL, il faut faire la mise à jour "avant" (ou en même temps) que celle de PHP

Attention aussi à ne pas mixer les dépôts remi/atomic.

+

P.S. et pour mémoire, Plesk est un truc proprio sur lequel je ne serais d'aucune aide.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Conflit avec mysql en tentant un upgrade php 5.3

Bonjour Rémi et merci de ta réponse très rapide.

Je suis débutant. J'ai donc besoin de précisions.
Je voudrais mettre à jour PHP et mySQL en même temps, tant qu'à faire.

Ces commandes ne le permettent pas ? :

# wget http://download.fedora.redhat.com/pub/e … noarch.rpm
# wget http://rpms.famillecollet.com/enterpris … ease-5.rpm
# rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm
# yum --enablerepo=remi update php php-*

Tu dis :

Attention aussi à ne pas mixer les dépôts remi/atomic.

Je vois en effet que c'est le cas. Mais que me conseilles-tu ? Quoi choisir ? Comment "nettoyer" cela et repartir propre ?
Ne faut-il pas que je remove mysql (et ses versions doublon) avant tout ?

Bref, je suis un peu paumé, je l'avoue.
Quant à ta remarque au sujet de Plesk : oui je l'ai lue en parcourant ton forum et j'en prends bonne note. J'ai cru comprendre, à travers tes mots, que tu n'étais pas trop pour "ce truc proprio"...  Mais je n'ai pas eu le choix. C'était livré avec.
Est-ce que cela présente un problème par rapport à ton package ? Vaut-il mieux, dans ces conditions, utiliser atomic ?

Merci d'avance pour tes réponses, qui, j'en suis sûr, sauront m'éclairer.

Re: Conflit avec mysql en tentant un upgrade php 5.3

Ces commandes ne le permettent pas ? :

Si tu fait un yum update php, forcément tu ne met à jour que PHP...
Donc, yum update mysql\* "avant"

Quoi choisir ? Comment "nettoyer" cela et repartir propre ?

Visiblement atomic propose ioncube, qui semble nécessaire avec plesk...

Après, c'est à toi de choisir le dépôt a utiliser pour chaque RPM.

Je ne critiquerais pas le contenu d'atomic, je ne connais pas suffisament ce qu'il propose. Je sais juste qu'on a fait des choix assez différents.

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Conflit avec mysql en tentant un upgrade php 5.3

Je ne sais pas si ioncube est nécessaire à PLesk. Il me semble que j'ai dû l'installer quand j'ai installé la librairie libssh2.
Bon, je ne suis pas beaucoup plus avancé.
Bon, supposons que j'utilise atomic, pour faire plaisir à Plesk.
Que dois-je supprimer de "remi", et comment, au stade où j'en suis pour éviter les conflits ?