Topic: Invalid links in remi-fedora.repo?

I am trying the manual YUM install found on this page http://blog.famillecollet.com/pages/Config-en?pub=1:

su -
cd /etc/yum.repos.d
wget [url]http://rpms.famillecollet.com/remi-...[/url]

I am trying to upgrade PHP/MySQL on FC4 and when I do what is listed above I get the following error(s):

[root@s15268048 yum.repos.d]# yum --enable remi install firefox-langpack-fr
Setting up Install Process
Setting up repositories
Cannot find a valid baseurl for repo: updates-released
Error: Cannot find a valid baseurl for repo: updates-released

I apologize if I am doing something wrong, but when looking at the .repo file it appears that the url's are not correct.

Thanks for the help!

Re: Invalid links in remi-fedora.repo?

Error: Cannot find a valid baseurl for repo: updates-released

This issue is on "updates-released" repository not remi one

You should update the URL for this repo.

FC4 is EOL for a very long time and you will probably have some problem to find a valid miror.
Remi repository for FC4 still available but doesn't receive any new update.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Invalid links in remi-fedora.repo?

Thanks for helping Remi.

I fixed that problem, but now when I get to the remi-fedor.repo it errors out.  I have manually copied the urls in the file and they do not exist via a browser.

[root@server yum.repos.d]# yum --enable remi install php-common-5.2.9-1.fc4.remi.i386
Setting up Install Process
Setting up repositories
http://rpms.famillecollet.com/fedora/4/remi/x86_64/repodata/repomd.xml: [Errno 4] IOError: HTTP Error 404: Date: Tue, 19 May 2009 12:45:22 GMT
Server: Apache/2.2.3 (CentOS)
Content-Length: 325
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
http://iut-info.univ-reims.fr/remirpms/fedora/4/remi/x86_64/repodata/repomd.xml: [Errno 4] IOError: HTTP Error 404: Date: Tue, 19 May 2009 12:45:23 GMT
Server: Apache/2.2.9 (Fedora)
Content-Length: 334
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: remi
failure: repodata/repomd.xml from remi: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from remi: [Errno 256] No more mirrors to try.

I can see the repo here: http://rpms.famillecollet.com/fedora/4/ … repoview/, but I am unsure what I need to change in the .repo file so everything works.

Again, thanks for the help and extending the life of my server another couple of years.

Re: Invalid links in remi-fedora.repo?

Sorry, but there is no remi x86_64 repository for FC4.

I've start providing a x86_64 repository with FC6

All is explain on the http://blog.famillecollet.com/pages/Config-en

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Invalid links in remi-fedora.repo?

Ok...I apologize as I am sort of new to this.

But after I do this:

wget http://rpms.famillecollet.com/remi-release-4.rpm
rpm -Uvh remi-release-4.rpm

Then what do I do?

I see the package here: http://rpms.famillecollet.com/fedora/4/ … /php.html, but I am unsure of what is the next step.

Thanks.

Re: Invalid links in remi-fedora.repo?

As I said before, and as written in the configuation page, If you are running FC4 x86_64, you cannot use the remi repository.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Invalid links in remi-fedora.repo?

Ok.  It states this on the page:

For older releases only the i386 (32 bits) repository is open.

And I find this in the list:

php-5.2.9-1.fc4.remi.i386

I am assuming that because it is listed I can install it, but like I said I am very new to this.

Sorry to bother you about it.

Thanks.

Re: Invalid links in remi-fedora.repo?

Yes 32bits version are available for FC4 (but, once more, not maintained as the repository is closed)
But it appear you are running a 64bits version of FC4

Perhaps it's possible to use the 32bits version, but I really don't know exactly how, and this will be very difficult (need to install all the 32bits dependencies and manage the 64bits conflicts, p.e. : httpd).

Definitively, you must upgrade to a recent / maintained  fedora version.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Invalid links in remi-fedora.repo?

Yeah I would really love to upgrade.

I might have to bite the bullet (not that it is more expensive, just time/pain consuming).

Thanks for the help.