Topic: php(53)-mysql-5.3.8 libmysqlclient.so dependencies

Hi,

  could you provide more universal/general php-mysql rpm package.

Your's requires - taken from REQUIRENAME of the rpm file:

libmysqlclient.so.18()(64bit)
libmysqlclient.so.18(libmysqlclient_16)(64bit)
libmysqlclient.so.18(libmysqlclient_18)(64bit)

But standard MySQL GA or Percona MySQL (which I use in the production enviromennt) don't provide "symbols" libmysqlclient.so.18(libmysqlclient_16) and libmysqlclient.so.18(libmysqlclient_18). These REQUIRENAMEs make impossible to use your PHP rpm packages with MySQL from other distributors.

System:
  CentOS 5.6  64bit

Installed packages:

[root@server]# rpm -qa | grep -i percona
Percona-Server-shared-55-5.5.14-rel20.5.149.rhel5
Percona-Server-client-55-5.5.14-rel20.5.149.rhel5
Percona-Server-server-55-5.5.14-rel20.5.149.rhel5
Percona-Server-shared-compat-5.5.14-rel20.5.149.rhel5
[root@server]# rpm -qa | grep -i remi
remi-release-5-8.el5.remi
php53-xmlrpc-5.3.8-1.el5.remi
php53-mbstring-5.3.8-1.el5.remi
php53-pdo-5.3.8-1.el5.remi
php53-xml-5.3.8-1.el5.remi
php53-gd-5.3.8-1.el5.remi
php53-common-5.3.8-1.el5.remi
php53-cli-5.3.8-1.el5.remi
php53-mysql-5.3.8-1.el5.remi

Percona MySQL PROVIDES:

Percona-Server-client-55-5.5.14

MySQL
MySQL-client
mysql
mysql-client
Percona-Server-client-55

Percona-Server-server-55-5.5.14

MySQL-server
adt_null.so()(64bit)
auth.so()(64bit)
auth_socket.so()(64bit)
auth_test_plugin.so()(64bit)
config(Percona-Server-server-55)
handlersocket.so.0()(64bit)
libdaemon_example.so()(64bit)
libfnv1a_udf.so.0()(64bit)
libfnv_udf.so.0()(64bit)
libmurmur_udf.so.0()(64bit)
mypluglib.so()(64bit)
mysql-server
qa_auth_client.so()(64bit)
qa_auth_interface.so()(64bit)
qa_auth_server.so()(64bit)
semisync_master.so()(64bit)
semisync_slave.so()(64bit)
Percona-Server-server-55

Percona-Server-shared-55-5.5.14

libmysqlclient.so.18()(64bit)
mysql-shared
Percona-Server-shared-55

Percona-Server-shared-compat-5.5.14

MySQL-shared
libmysqlclient.so.12()(64bit)
libmysqlclient.so.14()(64bit)
libmysqlclient.so.14(libmysqlclient_14)(64bit)
libmysqlclient.so.15()(64bit)
libmysqlclient.so.15(libmysqlclient_15)(64bit)
libmysqlclient.so.16()(64bit)
libmysqlclient.so.16(libmysqlclient_16)(64bit)
libmysqlclient_r.so.12()(64bit)
libmysqlclient_r.so.14()(64bit)
libmysqlclient_r.so.14(libmysqlclient_14)(64bit)
libmysqlclient_r.so.15()(64bit)
libmysqlclient_r.so.15(libmysqlclient_15)(64bit)
libmysqlclient_r.so.16()(64bit)
libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
mysql-libs
Percona-Server-shared-compat

The PROVIDES are similar for MySQL GA.


Thank you

Re: php(53)-mysql-5.3.8 libmysqlclient.so dependencies

> These REQUIRENAMEs make impossible to use your PHP rpm packages with MySQL from other distributors.
I don't plan to take care of other distributors.

Next version 5.4 (and perhaps a 5.3.x update)  will use mysqlnd (or libmysql), so will work without  dependency on libmysql.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: php(53)-mysql-5.3.8 libmysqlclient.so dependencies

You can also try to remove Percona-Server-shared and install compat-mysql55 from remi-test.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: php(53)-mysql-5.3.8 libmysqlclient.so dependencies

Another solution, use php-mysqlnd instead of php-mysql, which have no dependency on libmysqlclient.

Read : PHP with MySQL Client Library or MySQL Native Driver

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: php(53)-mysql-5.3.8 libmysqlclient.so dependencies

Hi there.

I too am trying to upgrade PHP on a server running Percona.

Did anyone get a working solution for this?

Remove Percona-Server-shared and install compat-mysql55 from remi-test?

Re: php(53)-mysql-5.3.8 libmysqlclient.so dependencies

Yes, or switch to mysqlnd.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: php(53)-mysql-5.3.8 libmysqlclient.so dependencies

@rkoziol7 read the link in comment #4

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi