Topic: Php 5.1 vers php 5.2

Bonjour à tous,

Voila mon soucis en exécutant cette suite de commande afin de passer mon serveur dédié de php 5.1 vers 5.2 :

wget http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm

wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm

rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm

yum --enablerepo=remi-test install mysqlclient16+

yum --enablerepo=remi --exclude=php*5.3* install php

Lorsque je fais la dernière commande à savoir :

yum --enablerepo=remi --exclude=php*5.3* install php

je me retrouve avec cette notification ce qui fais que l'update php 5.1 vers 5.2 ne focntionne pas...:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: ftp-stud.hs-esslingen.de
 * remi: rpms.famillecollet.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
Package php-5.1.6-23.2.el5_3.x86_64 already installed and latest version
Nothing to do
[root@s15370360 ~]# yum --enablerepo=remi --exclude=php*5.3* install php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: ftp-stud.hs-esslingen.de
 * remi: rpms.famillecollet.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
Package php-5.1.6-23.2.el5_3.x86_64 already installed and latest version
Nothing to do

Ce qui me pose question c'est qu'encore la semaine dernière quant je faisais cette suite je n'avais pas de problème pour migrer d'une version a l'autre... voyez vous un oubli de commande ou une solution pour contourner le problème ?

Bien cordialement,
EM

Re: Php 5.1 vers php 5.2

Je conserve toujours 2 versions dans le dépôt

La semaine dernière => 5.2.10 + 5.3.0
Désormais =>  5.3.0 + 5.3.1

La version 5.2.10 reste dans les archives pour ceux qui souhaitent la récupérer et l'installer manuellement.

Il n'y aura pas de MAJ (5.2.11 ou 5.2.12).
Je me concentre uniquement sur les dernières versions.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Php 5.1 vers php 5.2

D'accord Remi !

Mais concrètement j'ai une solution pour passer de 5.1 à 5.2 en faisant comment ?

j'ai peur ne pas comprendre quoi faire et quoi taper dans ma console pour mettre un 5.2...

Merci d'avance.

4 (edited by emilemecio 2009-11-23 15:19:00)

Re: Php 5.1 vers php 5.2

Du coup REMI je repasser en php 5.3 mais quand je tape la commande :

yum --enablerepo=remi install php

je me retrouve avec ces erreurs et du coup rien ne s'installe:

Transaction Summary
================================================================================================================================================================
Install     10 Package(s)
Update       9 Package(s)
Remove       0 Package(s)

Total size: 11 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/my.cnf from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64
  file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.x86_64

Error Summary
-------------

Saurais tu me dire pkoi je me retrovue avec ceci...

Apparement cela vient de mysql chose que j'avais réinstallé avec cette commande:

yum --enablerepo=remi update mysql

Mais après je me suis retrouvé avec l'impossibilité de créer des utilisateurs sous PLESK ... du coup j'avais totalement refais l'installation du serveur dédié... et je me retrouve donc avec les erreurs ci-dessus évoquées.

Si tu aas une idée et peu m'aider, merci d'avance.

EM

Re: Php 5.1 vers php 5.2

Ajout par rapport au précédent POST:

j'ai essayé cette commande et voici ce que cela me retourne et je sais pas vraiment ce que ca veut dire :

# rpm --verify mysql mysql-libs mysql-serveur
S.5....T  c /etc/my.cnf
package mysql-libs is not installed
package mysql-serveur is not installed

Re: Php 5.1 vers php 5.2

Il faut mettre à jour MySQL avant d'installer PHP ou prendre le paquet mysqlclient16 dans remi-testing qui évite la MAJ de MySQL.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

7 (edited by emilemecio 2009-11-24 13:35:16)

Re: Php 5.1 vers php 5.2

Remi,

Je vais repartir de l'archive pour php 5.2 car finalement ce que je veux faire n'a pas de compatibilité avec php 5.3 (C'est le bazard dans mes questions mais j'ai du mal a m'y retrouver moi même ... désolé.)

Pour installer les RPM de l'archive il faut que je fasse pour chaque RPM:

wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-5.2.10-1.el5.remi.x86_64.rpm

puis

rpm -ivh php-5.2.10-1.el5.remi.x86_64.rpm

et ceci pour tous les RPM de l'archive (http://rpms.famillecollet.com/enterprise/5/olds/x86_64/)?


de plus est ce qu'il y a un ordre pour tous ces RPM ?

( Tant de question naïve je suppose mais je débute ... désolé)

Merci
EM

Re: Php 5.1 vers php 5.2

C'est pas du flood mais j'essais de comprendre ...

En faisant comme je t'ai évoqué à savoir récupérer tout les RPM puis les installer via -ivh si je les prend dans l'ordre des achives cela ne focntionne pas a cause de dépendance donc je commence par ceci qui est apriori la principale à savoir:

~]# rpm -ivh php-common-5.2.10-1.el5.remi.x86_64.rpm
warning: php-common-5.2.10-1.el5.remi.x86_64.rpm: Header V4 DSA signature: NOKEY, key ID 00f97f56
Preparing...                ########################################### [100%]
        file /etc/php.ini from install of php-common-5.2.10-1.el5.remi.x86_64 conflicts with file from package php-common-5.1.6-23.2.el5_3.x86_64
        file /usr/lib64/php/modules/dbase.so from install of php-common-5.2.10-1.el5.remi.x86_64 conflicts with file from package php-common-5.1.6-23.2.el5_3.x86_64

Ma question est la suivante : comment faire pour ne plus avoir ces conflits ? A savoir que si je -Uvh le rpm j'obtiens ceci:

~]# rpm -Uvh php-common-5.2.10-1.el5.remi.x86_64.rpm
warning: php-common-5.2.10-1.el5.remi.x86_64.rpm: Header V4 DSA signature: NOKEY, key ID 00f97f56
error: Failed dependencies:
        php-common = 5.1.6-23.2.el5_3 is needed by (installed) php-pdo-5.1.6-23.2.el5_3.x86_64
        php-common = 5.1.6-23.2.el5_3 is needed by (installed) php-gd-5.1.6-23.2.el5_3.x86_64
        php-common = 5.1.6-23.2.el5_3 is needed by (installed) php-xml-5.1.6-23.2.el5_3.x86_64
        php-common = 5.1.6-23.2.el5_3 is needed by (installed) php-mbstring-5.1.6-23.2.el5_3.x86_64
        php-common = 5.1.6-23.2.el5_3 is needed by (installed) php-cli-5.1.6-23.2.el5_3.x86_64
        php-common = 5.1.6-23.2.el5_3 is needed by (installed) php-5.1.6-23.2.el5_3.x86_64
        php-common = 5.1.6-23.2.el5_3 is needed by (installed) php-imap-5.1.6-23.2.el5_3.x86_64
        php-common = 5.1.6-23.2.el5_3 is needed by (installed) php-mysql-5.1.6-23.2.el5_3.x86_64

ce que je te dis est surement basic mais étant de niveau très basic sur ce sujet je m'interroge ...

+

Re: Php 5.1 vers php 5.2

Il faut tous les installer en 1 seule commande et avec l'option -U (upgrade) et pas -i (install)

donc : rpm -Uvh php*.rpm

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Php 5.1 vers php 5.2

Merci de l'info, tout ce passe bien sauf que je me retrouve directement avec ca :

~]# rpm -Uvh php*.rpm
warning: php-5.2.10-1.el5.remi.x86_64.rpm: Header V4 DSA signature: NOKEY, key ID 00f97f56
warning: package php-gd = 5.2.10-1.el5.remi was already added, skipping php-gd < 5.2.8-1.el5.remi
error: Failed dependencies:
        autoconf is needed by php-devel-5.2.10-1.el5.remi.x86_64
        automake is needed by php-devel-5.2.10-1.el5.remi.x86_64
        libt1.so.5()(64bit) is needed by php-gd-5.2.10-1.el5.remi.x86_64
        libfbclient.so.2()(64bit) is needed by php-interbase-5.2.10-1.el5.remi.x86_64
        libmcrypt.so.4()(64bit) is needed by php-mcrypt-5.2.10-1.el5.remi.x86_64
        libmhash.so.2()(64bit) is needed by php-mhash-5.2.10-1.el5.remi.x86_64
        libsybdb.so.5()(64bit) is needed by php-mssql-5.2.10-1.el5.remi.x86_64
        libmysqlclient.so.16()(64bit) is needed by php-mysql-5.2.10-1.el5.remi.x86_64
        libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by php-mysql-5.2.10-1.el5.remi.x86_64
        libodbc.so.1()(64bit) is needed by php-odbc-5.2.10-1.el5.remi.x86_64
        libsqlite.so.0()(64bit) is needed by php-pdo-5.2.10-1.el5.remi.x86_64
        /usr/bin/pecl is needed by php-pecl-apc-3.0.19-1.el5.remi.x86_64
        php-eaccelerator conflicts with php-pecl-apc-3.0.19-1.el5.remi.x86_64
        /usr/bin/pecl is needed by php-pecl-imagick-2.2.1-1.el5.remi.x86_64
        libMagick.so.10()(64bit) is needed by php-pecl-imagick-2.2.1-1.el5.remi.x86_64
        libWand.so.10()(64bit) is needed by php-pecl-imagick-2.2.1-1.el5.remi.x86_64
        /usr/bin/pecl is needed by php-pecl-memcache-3.0.4-1.el5.remi.x86_64
        /usr/bin/pecl is needed by php-pecl-memcached-0.2.0-1.el5.remi.x86_64
        libmemcached.so.2()(64bit) is needed by php-pecl-memcached-0.2.0-1.el5.remi.x86_64
        libmemcached.so.2(libmemcached_2)(64bit) is needed by php-pecl-memcached-0.2.0-1.el5.remi.x86_64
        /usr/bin/pecl is needed by php-pecl-pdflib-2.1.6-1.el5.remi.x86_64
        libpdf.so.6()(64bit) is needed by php-pecl-pdflib-2.1.6-1.el5.remi.x86_64
        /usr/bin/pecl is needed by php-pecl-phar-1.2.2-1.el5.remi.x86_64
        /usr/bin/pecl is needed by php-pecl-ssh2-0.11.0-1.el5.remi.x86_64
        libssh2.so.1()(64bit) is needed by php-pecl-ssh2-0.11.0-1.el5.remi.x86_64
        /usr/bin/pecl is needed by php-pecl-xdebug-2.0.3-4.el5.remi.x86_64
        librecode.so.0()(64bit) is needed by php-recode-5.2.10-1.el5.remi.x86_64
        libnetsnmp.so.10()(64bit) is needed by php-snmp-5.2.10-1.el5.remi.x86_64
        net-snmp is needed by php-snmp-5.2.10-1.el5.remi.x86_64
        libtidy-0.99.so.0()(64bit) is needed by php-tidy-5.2.10-1.el5.remi.x86_64

~]# php -v
PHP 5.1.6 (cli) (built: Apr  7 2009 08:00:18)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

~]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]

~]# php -v
PHP 5.1.6 (cli) (built: Apr  7 2009 08:00:18)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

Et autant la commande j'ai compris mais la je capte pas pourquoi il me sort ces dépendances ...

+

Re: Php 5.1 vers php 5.2

Ben faut pas tout prendre non plus, juste les paquets nécessaires, c'est à dire ceux déjà présent (rpm -qa php-\*)

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

12 (edited by emilemecio 2009-11-25 09:31:51)

Re: Php 5.1 vers php 5.2

Bonjour Remi,

Bon alors pour être clair je vais te noter ce que j'ai fais car ca ne veut rien n'y faire :

ETAPE 1 - J'ai récup tout ce qui se trouvait dans l'archive que tu m'avais indiqué à savoir (http://rpms.famillecollet.com/enterprise/5/olds/x86_64/) via les commandes suivante:

wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-5.2.10-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-bcmath-5.2.10-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-cli-5.2.10-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-common-5.2.10-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-dba-5.2.10-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-devel-5.2.10-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-eaccelerator-0.9.5.2-2.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-embedded-5.2.10-1.el5.remi.x86_64.rpm

ETC POUR TOUS LES RPM

Ensuite sous tes bons conseils j'ai tapé ceci :

rpm -Uvh php*.rpm

ce qui m'a donné les erreur de dépendance ci-dessus, puis j'ai donc taper la commande:

rpm -qa php-\*

qui me retourne ceci:

php-gd-5.1.6-23.2.el5_3
php-common-5.1.6-23.2.el5_3
php-pdo-5.1.6-23.2.el5_3
php-xml-5.1.6-23.2.el5_3
php-mysql-5.1.6-23.2.el5_3
php-mbstring-5.1.6-23.2.el5_3
php-cli-5.1.6-23.2.el5_3
php-imap-5.1.6-23.2.el5_3

[EDIT] OU alors je dois tout supprimer sauf ceux de la commande : rpm -qa php-\* => Je vais essayer ca peut pas être pire :-) => SANS RESULTAT[EDIT]

Et la je vis pas vraiment ce que je dois faire de ceci maintenant ?
Je dois supprimer les RPM que je viens de télécharger ? Je l'ai fais mais quand je relance mon rpm -Uvh php*.rpm je me retrouve avec encore plus d'erreur de dépendance...

Merci d'avance pour tes éclairage...

PS: J'espère un jour pouvoir migrer mon PHP 5.1 vers 5.2 (C'était si pratique ton dépot de la semaine dernière :-))

Re: Php 5.1 vers php 5.2

Bonjour,

Je penses être dans le même cas que toi. J'essaye d'installer la version 5.2.10 sous une redhat entreprise 5.4 et je rencontre les mêmes soucis.

Après plusieurs recherches et test voilà ce que j'ai appris :
- le rpm de php5.2.10 fournit dans le dépôt rémi est fait pour mysql 5.1 alors que redhat entreprise 5 ne propose que la version 5.0
--> il installer le paquet "mysqlclient16-5.1.30-1.el5.remi" disponible dans le dépot "test" du dépot rémi pour résoudre le pb de "libmysqlclient.so" ou sinon installer mysql en version 5.1

- Le rpm "php-pdo-5.2.10" a besoin de la version 2 de sqlite hors dans la redhat entreprise 5 c'est la version 3 qui est disponible. il faut donc installer "sqlite2-2.8.17-2.el5.remi" du dépôt principal rémi.

Je te laisse pour info les manipulations que j'ai du réalisé chez moi, je suis par contre en 32bits et utilise moins de modules :

wget http://rpms.famillecollet.com/enterprise/5/olds/i386/php-cli-5.2.10-1.el5.remi.i386.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/i386/php-common-5.2.10-1.el5.remi.i386.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/i386/php-ldap-5.2.10-1.el5.remi.i386.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/i386/php-mysql-5.2.10-1.el5.remi.i386.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/i386/php-pdo-5.2.10-1.el5.remi.i386.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/i386/php-5.2.10-1.el5.remi.i386.rpm
wget http://rpms.famillecollet.com/enterprise/5/test/i386/mysqlclient16-5.1.30-1.el5.remi.i386.rpm
wget http://rpms.famillecollet.com/enterprise/5/remi/i386/sqlite2-2.8.17-2.el5.remi.i386.rpm

puis

rpm -Uvh mysqlclient16-5.1.30-1.el5.remi.i386.rpm
rpm -Uvh sqlite2-2.8.17-2.el5.remi.i386.rpm
rpm -Uvh php*.rpm

Re: Php 5.1 vers php 5.2

Okay merci de l'info je vais tester ce que tu m'as donné.

++