Topic: How compile spec's which include php-zts??

Hi,
I use php-fpm it means that me not needed thread safe libraries.
But when I try build imagick I got follow error message:

RPM build errors:
    File not found: /var/tmp/php-pecl-imagick-3.1.0RC1-3.1-root/usr/lib64/php-zts/modules/imagick.so
    File not found: /var/tmp/php-pecl-imagick-3.1.0RC1-3.1-root/usr/include/php-zts/php/ext/imagick

Of course "/var/tmp/php-pecl-imagick-3.1.0RC1-3.1-root/usr/lib64/php/modules/imagick.so" and "/var/tmp/php-pecl-imagick-3.1.0RC1-3.1-root/usr/include/php/ext/imagick" exist.

How I can "true" build this package?

My .rpmmacros file contains follow content:

%_topdir /root/rpmbuild/                                                                                                                                      
%rhel 5                                                                                                                                                       
%_with_oci8 1                                                                                                                                                 
%_with_ibase 1                                                                                                                                                
                                                                                                                                                              
                                                                                                                                                              
%php_ztsextdir  %{_libdir}/php-zts/modules                                                                                                                    
%php_ztsinidir  %{_sysconfdir}/php-zts.d                                                                                                                      
%php_ztsincldir %{_includedir}/php-zts/php                                                                                                                    
%php_ztsbindir  %{_bindir}                                                                                                                                    
%php_bindir     %{_bindir}

Re: How compile spec's which include php-zts??

you don't need to define such macros, they are provided by php-devel (/etc/rpm/macros.php)

I think the issue is from an old spec, and there is a lot of change in packaging ZTS extension (during merge in fedora repo)
So this spec probably need a lot of cleanups

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: How compile spec's which include php-zts??

Remi, can yo check spec file from imagick?

Re: How compile spec's which include php-zts??

Already done : https://github.com/remicollet/remirepo/ … 6752c281c2

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: How compile spec's which include php-zts??

Thanks. Now I removed

%php_ztsextdir  %{_libdir}/php-zts/modules                                                                                                                    
%php_ztsinidir  %{_sysconfdir}/php-zts.d                                                                                                                      
%php_ztsincldir %{_includedir}/php-zts/php                                                                                                                    
%php_ztsbindir  %{_bindir}                                                                                                                                    
%php_bindir     %{_bindir}

and builded successfuly imagick 3.1.0RC1 with php 5.4.3 with your spec file

Re: How compile spec's which include php-zts??

And, why don't you simply use the available binary RPM ?
http://rpms.famillecollet.com/enterpris … agick.html

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: How compile spec's which include php-zts??

Because your php-mysql depend's from mysql-libs... I prefer MariaDB, mysql-libs conflicts with MariaDB sad
I also created topic about here http://forums.famillecollet.com/viewtopic.php?id=1687

Re: How compile spec's which include php-zts??

Transaction Check Error:
  file /usr/share/mysql/charsets/README from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/armscii8.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/ascii.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/cp1250.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/cp1251.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/cp1256.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/cp1257.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/cp850.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/cp852.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/cp866.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/dec8.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/geostd8.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/greek.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/hebrew.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/hp8.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/keybcs2.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/koi8r.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/koi8u.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/latin1.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/latin2.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/latin5.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/latin7.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/macce.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/macroman.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/charsets/swe7.xml from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386
  file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.5.23-1.fc17.i686 conflicts with file from package MariaDB-server-5.3.5-113.el5.i386

Error Summary
-------------

Re: How compile spec's which include php-zts??

Well compat-mysql55 should avoid this dependencies, but best solution is probably to switch from php-mysql to php-mysqlnd which don't use libmysqlclient.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test