Topic: MAJ vers PHP5.4 CentOs6.3

Bonjour à vous toutes et tous,
Je débarque dans votre univers depuis 2 semaines et avance pas à pas dans mes acquis avec beaucoup de recherches mais là j'avoue être à l'arrêt. Soyez indulgents, je n'ai pas forcément le vocabulaire le plus juste alors je vais détailler. N'hésitez pas à me reprendre, je préfère que ce soit juste plutôt que faire de l'à peu près ! Je ne suis pas informaticienne donc je n'ai pas toujours la bonne logique de réflexion ou les connaissances pour avancer.
J'ai un serveur dédié avec Centos 6.3, PHP 5.3.19. J'ai besoin de faire une mise à jour de PHP en 5.4.10 (dernière version tant qu'à faire).
J'ai déjà eu l'occasion de faire une mise à jour avec atomicorp mais il n'a que 5.3.19 comme dernière version de PHP.
J'ai donc ouvert Putty, je me suis loggée et j'ai tapé :
- wget http://fr2.rpmfind.net/linux/remi/  --> mais si ce n'est pas la bonne url dites-le moi
La connexion se fait mais là, impossible de trouver la bonne commande
- yum --enablerepo=remi update php-\*
- yum --enablerepo=remi update php-\5.4*
- yum --enablerepo=remi update php-\5.4.10
Rien ne fonctionne

Je vous remercie par avance de votre aide et vous invite vivement à me prodiguer tous conseils utiles.

En vous souhaitant une excellente journée.

Re: MAJ vers PHP5.4 CentOs6.3

Commencer par la doc
http://blog.famillecollet.com/pages/Config
http://blog.famillecollet.com/pages/FAQ-en-Francais

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: MAJ vers PHP5.4 CentOs6.3

Bonjour Rémi,
Je vous remercie de votre retour.
J'ai déjà lu les 2 liens que vous m'indiquez. Malheureusement, cela ne m'aide pas à comprendre le fonctionnement ni ce que je dois faire ni pourquoi je le fais.
J'ai vraiment lu beaucoup de choses, fais beaucoup de recherches sur le net français et anglais et même réinitialiser 3 fois mon serveur pour avoir fait des erreurs et m'apercevoir de dysfonctionnements. Il y a beaucoup de documentation pour les initiés qui savent quelles commandes utiliser dans tel ou tel contexte pour tel ou tel résultat.
J'ai déjà fait l'installation avec atomicorp (même fait les mises à jour) dont j'ai "saisie" la démarche mais là je sèche. Il y a plusieurs liens qui avec la commande wget ne fonctionnent pas donc je dois forcément faire des erreurs dans le déroulement correcte de la connexion et l'installation de packages.

Re: MAJ vers PHP5.4 CentOs6.3

J'ai mis à jour la doc avec le nouveau lien vers le paquet d'autoconfiguration d'EPEL (version 6-8)

Donc en résumé:

wget http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm
yum --enablerepo=remi update
Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: MAJ vers PHP5.4 CentOs6.3

Rémi, je vous remercie.
Reprenez-moi si je me trompe : Je me connecte à la base epel 6.8 avec le premier lien. Avec le 2ème lien, je me connecte aux rpm additionnels. La commande rpm télécharge et installe cette base et les rpm additionnelles et la comande yum fait la mise à jour. Après quoi, je redémarre le serveur.
Ai-je bien compris le processus ?

Re: MAJ vers PHP5.4 CentOs6.3

Le premier lien permet de récupérer le paquet d'auto-configuration du dépôt EPEL
Le second lien permet de récupérer le paquet d'auto-configuration du dépôt REMI
La commande RPM installe ces 2 paquets et rends donc disponible leur contenu pour la commande suivante.

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: MAJ vers PHP5.4 CentOs6.3

Donc puisqu'avec des 2 liens d'auto-configuration, si j'utilise une commande yum install, le serveur ira chercher dans ces 2 bibliothèques, ainsi que dans celle d'atomicorp que j'ai installé au début, les packages dont j'ai besoin et en l'occurence PHP 5.4.7 (puisque 5.4.10 n'est pas disponible)
Il me restera donc à faire :
- yum --enablerepo=remi update php-\*

Re: MAJ vers PHP5.4 CentOs6.3

La 5.4.10 n'est pas sortie ?

Pourtant chez moi, il me demande la 5.4.10-1 et j'ai l'erreur sur ma centos6 :
Error: Package: 1:php-eaccelerator-0.9.6.1-20.el6.remi.x86_64 (@remi)
           Requires: php-common(x86-64) = 5.3.19
           Removing: php-common-5.3.19-1.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.3.19-1.el6.remi
           Updated By: php-common-5.4.10-1.el6.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.10-1.el6.remi
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (base)
               php-common(x86-64) = 5.3.3-3.el6_2.8
           Available: php-common-5.3.3-14.el6_3.x86_64 (updates)
               php-common(x86-64) = 5.3.3-14.el6_3
           Available: php-common-5.4.9-1.el6.remi.x86_64 (remi)
               php-common(x86-64) = 5.4.9-1.el6.remi

9 (edited by JaneBond 2012-12-22 22:57:28)

Re: MAJ vers PHP5.4 CentOs6.3

Après plusieurs erreurs et des recherches, je pense qu'il y avait des incompatibilités avec atomicorp. Après réinitialisation, l'installation et la mise à jour s'est bien passé.
J'ai souhaité installer php-mcrypt et j'ai une erreur :
yum install php-mcrypt
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* epel: mirror.de.leaseweb.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.3.3-1.el6 will be installed
--> Processing Dependency: php-api = 20090626 for package: php-mcrypt-5.3.3-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-mcrypt-5.3.3-1.el6.x86_64 (epel)
           Requires: php-api = 20090626
           Installed: php-common-5.4.10-1.el6.remi.x86_64 (@remi)
               php-api = 20100412-x86-64
           Available: php-common-5.3.3-3.el6_2.8.x86_64 (base)
               php-api = 20090626
           Available: php-common-5.3.3-14.el6_3.x86_64 (updates)
               php-api = 20090626
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

EDIT 23H55 : il fallait d'abord installer php-mcrypt-5.3.3-1.el6.x86_64. Voilà une erreur que j'ai comprise, que j'ai résolue et qui me rend fière de moi...(pas mal pour newbie blonde !!) Pour info, mon serveur a une installation de PHP de base en 5.3.19.

10 (edited by JaneBond 2012-12-22 18:10:52)

Re: MAJ vers PHP5.4 CentOs6.3

refuznik wrote:

La 5.4.10 n'est pas sortie ?

Cette version est dispo dans le dépôt qui correspond à ma config (je ne pensais pas que le dépôt qui me concernait contenait cette version. Suis novice et j'apprends au fur et à mesure !)
Avez-vous fait yum --enablerepo=remi update ? ou peut-être faut-il plutôt faire un upgrade ?? Là je ne pourrais pas vous le confirmer.

Re: MAJ vers PHP5.4 CentOs6.3

Merci de la réponse rapide, c'était sur un upgrade, alors par contre ne pas hésiter à me contredire mais je pense que sur php-eaccelerator que ça pose problème.

le début :
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-220.13.1.el6 will be erased
---> Package php-common.x86_64 0:5.3.19-1.el6.remi will be updated
--> Processing Dependency: php-common(x86-64) = 5.3.19 for package: 1:php-eaccelerator-0.9.6.1-20.el6.remi.x86_64
--> Finished Dependency Resolution

Re: MAJ vers PHP5.4 CentOs6.3

@refuznik eaccelerator est mort.

Donc il faut le désinstaller et utiliser un autre cache d'opcode (APC ou XCache)

Bon, il y a une version expérimentale dans remi-test, mais je pense vraiment que le projet est mort, je n'ai aucune réponse à mes rapports de bugs, le dépôt git n'a pas bougé depuis des mois, et franchement, certaines parties du code me font très peur.

Cf http://blog.famillecollet.com/post/2012 … or-1.0-dev

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: MAJ vers PHP5.4 CentOs6.3

JaneBond wrote:

yum install php-mcrypt
...
Error: Package: php-mcrypt-5.3.3-1.el6.x86_64 (epel)

Le dépôt "remi" n'étant pas activé par défaut, il faut toujours ajouter l'option --enablerepo=remi lors de l'ajout d'un module qui vient de ce dépôt.

On peut aussi l'activer par défaut en modifiant le remi.repo

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

14 (edited by JaneBond 2012-12-27 01:50:40)

Re: MAJ vers PHP5.4 CentOs6.3

Bonsoir Rémi,
Puis-je abuser de votre savoir ???
J'ai fait les mises à jour de base, la mise à jour de php, installé php5-ioncube-loader, php-zend-framework, php-mcrypt, libmemcached, curl, php-smarty2 et perl-.
J'ai réglé mon php.ini :
allow_url_include=on
session.auto_start=on
date.timezone=UTC
expose_php=off
max_input_vars=5000
register_argc_argv=off
output_buffering=ob_gzhandler
mysql.max_links=-1
mysql.max_persistent=-1
mysql.connect_timeout=60
default_socket_timeout = 1800000
pdo_mysql.cache_size = 2000
mysql.allow_persistent = On

J'ai réglé le serveur en module Apache (je vais passer en FastCGI). Mes sites fonctionnent. J'ai relevé quelques détails par rapport à un hébergement avec infogérance (ex : problème sur mes progressbar...)Pourriez-vous me dire si j'ai oublié quelques choses d'important ?