Topic: Upgrade PHP 5.1 to php 5.2 avec mcrypt

Bonjour,

très honnêtement je ne sais pas trop ou me tourner mais ayant installé un PHP 5.2 sur un CentOS via un rpm remi à savoir :

yum --enablerepo=remi --exclude=php*5.3* install php

Je suis entrain d'installer un Magento sur ce même serveur et il me faut impérativement mettre :

PHP Extension "mcrypt" must be loaded

Et mon problème est que je ne sais absolument pas comment faire ? Faut 'il refaire une installe de PHP5.2 avec une option dans la ligne de commande ?

Quand j'édite mon php.ini je ne trouve pas du tout de ligne à décommenter comme je vois ici et la à savoir :

;extension=php_mcrypt.dll

Actuellement j'ai juste fais une isntall comme ceci :

yum install mcrypt

J'ai redémmarré le serveur mais rien ne change dans le php.ini ...


Merci Remi de bien vouloir m'accorder quelque minute si tu as une idée sur le sujet...

Re: Upgrade PHP 5.1 to php 5.2 avec mcrypt

yum --enablerepo=remi --exclude=php*5.3* install php-mcrypt

+

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Upgrade PHP 5.1 to php 5.2 avec mcrypt

Remi j'ai merdé j'avais fais cette commande avant de voir ta réponse et j'avais oublié d'exclure le php*5.3*

Tu saurais me dire comment revenir à une 5.2 sans tout casser ?

Merci et désolé du dérangement...

Re: Upgrade PHP 5.1 to php 5.2 avec mcrypt

Désolé Remi du dérangement j'ai trouvé ;-)

yum --enablerepo=remi remove php\* 
yum --enablerepo=remi --exclude=php*5.3* install php php-mbstring php-pear php-mysql php-ldap php-mcrypt php-pear-MDB2 php-mysql ..... 

@bientôt et encore merci

Re: Upgrade PHP 5.1 to php 5.2 avec mcrypt

I updated my PHP from 5.1 to 5.2 a few months ago. Since then I noticed I don't have mcrypt. I tried everything I could too install it. Yum install...added to /etc/php.d/mcrypt.so etc. but nothing worked.

Someone suggeste I do yum update. Doing this has now got rid of json. phpinfo now says --disable-json.

This is what I currently have loaded:

Installed Packages php.x86_64 5.2.10-1.el5.centos installed php-cli.x86_64 5.2.10-1.el5.centos installed php-common.x86_64 5.1.6-39.el5_8 installed php-gd.x86_64 5.2.10-1.el5.centos installed php-imap.x86_64 5.2.10-1.el5.centos installed php-mbstring.x86_64 5.2.10-1.el5.centos installed php-mysql.x86_64 5.2.10-1.el5.centos installed php-pdo.x86_64 5.2.10-1.el5.centos installed php-xml.x86_64 5.2.10-1.el5.centos installed php5-ioncube-loader.x86_64 3.1-07051711 installed

I tried to use pecl to install json but had to install pecl first and using pecl now says phpize does not exist.