Topic: Mise à jour PHP / MySQL sur RHEL 5.4

Bonjour cher ancien collègue,

Je suis en train d'essayer de faire la mise à jour d'un de nos serveur RHEL 5.4 (64 bits).

Que j'essaye de lancer la mise à jour MySQL ou PHP :

yum --enablerepo=remi update mysql\*
yum --enablerepo=remi update php-\*

j'ai le même problème de dépendances :

libcurl-7.21.7-5.el5.remi.2.x86_64 from remi has depsolving problems
  --> Missing Dependency: openldap >= 2.3.43-12.el5_6.5 is needed by package libcurl-7.21.7-5.el5.remi.2.x86_64 (remi)
Error: Missing Dependency: openldap >= 2.3.43-12.el5_6.5 is needed by package libcurl-7.21.7-5.el5.remi.2.x86_64 (remi)

J'ai essaye de faire la mise à jour de licurl avant ça n'a rien donné ...

Aurais-tu une solution ?

D'avance merci pour ton aide,
Stéphane

Re: Mise à jour PHP / MySQL sur RHEL 5.4

openldap=2.3.43-12.el5_6.5 est dans les dépôts officiels (updates, depuis la 5.6)


P.S. Désolé, la PLC 5.4 n'est plus supportée wink  (commentaire d'un ancien collègue)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Mise à jour PHP / MySQL sur RHEL 5.4

Aïe ... Déjà que je m'éloignais du cadnat en faisant ça...
Centos 5.4 serait supportée ou pas ?

Au passage, j'espère que tout se passe bien pour toi wink

Re: Mise à jour PHP / MySQL sur RHEL 5.4

T'as besoin de quelle version de PHP exactement ?

Parce que RHEL 5.4 fournie déjà php53

Après il faut aussi la connecter au RHN.

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Mise à jour PHP / MySQL sur RHEL 5.4

Il me faut minimum PHP 5.3.3

Je vais regarder comment se fait la connexion au RHN dans ce cas.

Re: Mise à jour PHP / MySQL sur RHEL 5.4

Merci pour ton aide.

Est ce que CentOS 5.4 est maintenue pour la mise à jour PHP 5.4 ?

Re: Mise à jour PHP / MySQL sur RHEL 5.4

Donc, prendre le php53 fournit de base.

Et non, CentOS5.4 étant un clone de RHEL6.4, ça ne changera rien.
De toutes manières ces versions sont EOL (non maintenues), il faut donc mettre à jour sur la dernière version (5.9)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70