Topic: firefox 17 fc14 x86_64

Firefox 17 is the extended support version of Firefox until version 24 is released.  I need to support that version for a while and we don't have an RPM of it.  Do you still have your copy of it?  I think I may need the associated version of xulrunner as well.

Re: firefox 17 fc14 x86_64

Firefox 17esr is part of official Red Hat / CentOS repository.

Don't know what you need exactly for what usage, but all my history is in my github

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: firefox 17 fc14 x86_64

I wasn't aware that Firefox 17 was ever officially distributed for Fedora 14.  I can't find it in their repo.  I have clusters of automated test servers running Fedora 14, and need to put Firefox 17 on them.

Re: firefox 17 fc14 x86_64

Fedora 14 is EOL for a while.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: firefox 17 fc14 x86_64

I am aware. We are moving to Fedora 18, but not for a few months as some of our software is version locked and will require reworking.  It is a long process and in the meantime we still need to do testing with Firefox 17.  You still maintain Firefox for Fedora 14 on your repo, so I thought you might have done xulrunner and firefox 17.0.1 for Fedora 14.

Re: firefox 17 fc14 x86_64

As I said in my previous comment, all my spec history are on github.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: firefox 17 fc14 x86_64

I tried a build, but I am held up on needing a version of xulrunner-devel greater than what is available for fedora 14 (17.0.1-1 or greater).  How did you work around that?

Re: firefox 17 fc14 x86_64

You cannot workaround this requirement. Firefox version must match Xulrunner version.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

9 (edited by fishpen0 2013-04-16 17:03:41)

Re: firefox 17 fc14 x86_64

Your github doesnt have xulrunner-last-devel spec files.  I am still trying to build in fc14, correct me if I am wrong, but that means I need to also have a build of xulrunner-last-devel for fc14.

Re: firefox 17 fc14 x86_64

it is in the xulrunner folder

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi