Topic: Problème de mise à jour de version PHP 5.1.6 vers 5.2 ou plus

Bonjour à tous,

Je me permets de vous poser ce post car je ne me retrouve plus avec les paquets.

Mon objectif:
- Mettre à jour le paquet PHP à 5.1.6 à 5.2 ou Plus

Mon environnement
- CentOS 5.4 (php 5.1.6, Mysql 5.0.77)

Les actions que j'ai réalisés
- Positionnement de dépôt:

- Mise à jour de Mysql et PHP

yum --enablerepo=remi-test \
    --enablerepo=remi  update mysql\*

yum --enablerepo=remi-test \
    --enablerepo=remi  update php\*

Problèmes:
- Problème lors de l'exécution des commandes ci-dessus.

php-pear-XML-Tree-2.0.0-0.2.fc5.remi.noarch from remi has depsolving problems
  --> Missing Dependency: php-pear(XML_Parser) >= 1.1.0 is needed by package php-pear-XML-Tree-2.0.0-0.2.fc5.remi.noarch (remi)
php-pear-Services-Weather-1.4.3-1.fc5.remi.noarch from remi has depsolving problems
  --> Missing Dependency: php-pear(Net_FTP) >= 1.3.1 is needed by package php-pear-Services-Weather-1.4.3-1.fc5.remi.noarch (remi)
freetds-0.82-4.fc5.remi.i386 from remi has depsolving problems

-Après cela, le parseur php ne fonctionne plus, je crée un fichier contenant <?php phpinfo();>
mais le parseur envoie le code source php.

Besoin de lumière
-Est-ce quelqu'un a eu ce genre de problème ?
-Est-ce que ma procédure de mise à jour est correcte ?

Merci par avance à Remi de son soutien.

Linx.

Re: Problème de mise à jour de version PHP 5.1.6 vers 5.2 ou plus

Un "yum repolist" serait le bienvenu.

Il n'y a aucune raison qu'il ramène des paquets fc5 (fedora) sur une el5 (Redhat/Centos)

Donc visiblement une erreur de configuration.


+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème de mise à jour de version PHP 5.1.6 vers 5.2 ou plus

Remi,

Voila les infos sur "yum repolist"

# yum repolist
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
repo id                                                                                                          repo name                                                                                                                    status
addons                                                                                                           CentOS-5 - Addons                                                                                                            enabled:    0
base                                                                                                             CentOS-5 - Base                                                                                                              enabled: 2535
extras                                                                                                           CentOS-5 - Extras                                                                                                            enabled:  327
updates                                                                                                          CentOS-5 - Updates                                                                                                           enabled:  642
repolist: 3504

Effectivement, il ne va pas chercher dans le bon repo.
Pourtant, j'ai bien mis --enablerepo=remi-test et --enablerepo=remi
Il devrait aller le chercher.

Merci d'avance de votre aide.

Linx

Re: Problème de mise à jour de version PHP 5.1.6 vers 5.2 ou plus

Remi,

- J'ai re-installé le seveur sans apache,ni mysql et php

- J'ai positionné le repo avec

- J'ai exécute les commandes ci-dessous:

yum --enablerepo=remi-test --enablerepo=remi  install httpd
yum --enablerepo=remi-test --enablerepo=remi  install mysql
yum --enablerepo=remi-test --enablerepo=remi  install php

-Lors de l'installation de PHP, j'ai cette erreur

[root@yum.repos.d]# yum --enablerepo=remi-test --enablerepo=remi  install php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* remi: rpms.famillecollet.com
* remi-test: rpms.famillecollet.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php.i386 0:5.3.2-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.3.2-1.el5.remi for package: php
--> Processing Dependency: php-cli = 5.3.2-1.el5.remi for package: php
--> Processing Dependency: libgmp.so.3 for package: php
--> Running transaction check
---> Package gmp.i386 0:4.1.4-10.el5 set to be updated
---> Package php-cli.i386 0:5.3.2-1.el5.remi set to be updated
--> Processing Dependency: libedit.so.0 for package: php-cli
---> Package php-common.i386 0:5.3.2-1.el5.remi set to be updated
--> Finished Dependency Resolution
php-cli-5.3.2-1.el5.remi.i386 from remi has depsolving problems
  --> Missing Dependency: libedit.so.0 is needed by package php-cli-5.3.2-1.el5.remi.i386 (remi)
Error: Missing Dependency: libedit.so.0 is needed by package php-cli-5.3.2-1.el5.remi.i386 (remi)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Merci d'avance Remi.

Re: Problème de mise à jour de version PHP 5.1.6 vers 5.2 ou plus

Remi,

Je reconnais que je ne suis pas une flèche sous CentOS, cependant, j'ai vraiment suivi tous vos recommandations.
Serait-il possible, avoir les actions à faire venant de votre part, cela évitera les allés et retour de nos posts.
Actuellement, j'ai re-installé à nouveau mon serveur sans apache, ni mysql et php.
Il me reste plus que cette instructions de votre part.

Je rappelle l'objectif : mettre à niveau PHP à la version 5.2 minimum.

En terme de roadmap centOS, avez-vous une date prévisionnelle pour la sortie de la version 5.5 ?

Merci par avance Remi.

Linx.

Re: Problème de mise à jour de version PHP 5.1.6 vers 5.2 ou plus

En général, toutes les indications sont dans http://blog.famillecollet.com/pages/Config

Suffit de lire attentivement.
En particulier le paragraphe sur EL5.

wget http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm

(choisir le configuration manuelle était une mauvaise idée)

Et pour l'erreur ci-dessus, c'est juste qu'il manque EPEL, et comme indiqué, il est indispensable.

+

P.S. aucune idée pour la roadmap CentOS 5.5, mais il faudrait déjà que RHEL 5.5 soit disponible.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème de mise à jour de version PHP 5.1.6 vers 5.2 ou plus

Super Remi, et mille merci.

Bonne journée.


Linx.