Topic: ImageMagick / OpenEXR

ImageMagick was upgraded yesterday using 'yum update'.  Everything seemed to fine.

Today, the following errors are being displayed when running 'yum update'

Resolving Dependencies
--> Running transaction check
---> Package OpenEXR.x86_64 0:1.6.1-8.el5 set to be updated
--> Processing Dependency: libIlmThread.so.6()(64bit) for package: OpenEXR
--> Processing Dependency: libIex.so.6()(64bit) for package: OpenEXR
--> Processing Dependency: libImath.so.6()(64bit) for package: OpenEXR
--> Processing Dependency: libHalf.so.6()(64bit) for package: OpenEXR
--> Processing Dependency: libHalf.so.4()(64bit) for package: ImageMagick-last-libs
--> Processing Dependency: libIex.so.4()(64bit) for package: ImageMagick-last-libs
--> Processing Dependency: libIlmImf.so.4()(64bit) for package: ImageMagick-last-libs
--> Processing Dependency: libImath.so.4()(64bit) for package: ImageMagick-last-libs
--> Running transaction check
---> Package ilmbase.x86_64 0:1.0.1-6.el5 set to be updated
--> Processing Dependency: libHalf.so.4()(64bit) for package: ImageMagick-last-libs
--> Processing Dependency: libIex.so.4()(64bit) for package: ImageMagick-last-libs
--> Processing Dependency: libIlmImf.so.4()(64bit) for package: ImageMagick-last-libs
--> Processing Dependency: libImath.so.4()(64bit) for package: ImageMagick-last-libs
--> Finished Dependency Resolution
ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 from installed has depsolving problems
  --> Missing Dependency: libHalf.so.4()(64bit) is needed by package ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 (installed)
ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 from installed has depsolving problems
  --> Missing Dependency: libIlmImf.so.4()(64bit) is needed by package ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 (installed)
ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 from installed has depsolving problems
  --> Missing Dependency: libIex.so.4()(64bit) is needed by package ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 (installed)
ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 from installed has depsolving problems
  --> Missing Dependency: libImath.so.4()(64bit) is needed by package ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 (installed)
Error: Missing Dependency: libImath.so.4()(64bit) is needed by package ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 (installed)
Error: Missing Dependency: libIex.so.4()(64bit) is needed by package ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 (installed)
Error: Missing Dependency: libIlmImf.so.4()(64bit) is needed by package ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 (installed)
Error: Missing Dependency: libHalf.so.4()(64bit) is needed by package ImageMagick-last-libs-6.8.5.9-1.el5.remi.x86_64 (installed)

Do you know what is causing this issue?

Re: ImageMagick / OpenEXR

---> Package OpenEXR.x86_64 0:1.6.1-8.el5 set to be updated

I don't know where this package comes from.
I used OpenEXR-1.4.0a-5.el5 which is available in EPEL.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: ImageMagick / OpenEXR

Ok.

Let me trackdown that package, and make sure I am using the EPEL version.

Thank You.

Re: ImageMagick / OpenEXR

Right now I can neither read nor write the files. I tried manually
adding an exr delegate to the delegates.xml file, but that didn't seem
to have any effect. I don't know if I was doing it correctly, though. Is
there a specific syntax required for this delegate to work correctly?

Using imdisplay I cannot view a known good EXR. I get the "no decode
delegate" error message.

It must be something about the delegate system, but I really don't know
how it all works. What's really sad is that I also did this once before
last year too. I had it building for 64 bit Windows. Unfortunately, I no
longer have access to the disk with that project on it, so I can't just
switch the target and rebuild, and now I have no memory of whatever I
did to get it working before and cannot get it working at all!

Re: ImageMagick / OpenEXR

Thanks for sharing information,your information increase my knowledge.Your information very helpful for me.