Re: How to enable the repositories on SME Server (CentOS based)

I am still getting some missing dependencies,

[xx@xx ~]# yum --enablerepo=epel2,remi update mysql\*
Loaded plugins: fastestmirror, smeserver
Loading mirror speeds from cached hostfile
 * base: ftpmirror.your.org
 * smeaddons: sme-mirror.firewall-services.com
 * smeextras: sme-mirror.firewall-services.com
 * smeos: sme-mirror.firewall-services.com
 * smeupdates: sme-mirror.firewall-services.com
 * updates: mirrordenver.fdcservers.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.i686 0:5.1.69-1.el6_4 will be updated
---> Package mysql.i386 0:5.5.31-1.el5.remi will be an update
--> Processing Dependency: libssl.so.6 for package: mysql-5.5.31-1.el5.remi.i386
--> Processing Dependency: libcrypto.so.6 for package: mysql-5.5.31-1.el5.remi.i386
---> Package mysql-libs.i686 0:5.1.69-1.el6_4 will be updated
--> Processing Dependency: libmysqlclient.so.16 for package: perl-DBD-MySQL-4.022-1.el6.rfx.i686
--> Processing Dependency: libmysqlclient.so.16 for package: php-mysql-5.3.3-22.el6.i686
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: perl-DBD-MySQL-4.022-1.el6.rfx.i686
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: php-mysql-5.3.3-22.el6.i686
---> Package mysql-libs.i386 0:5.5.31-1.el5.remi will be an update
---> Package mysql-server.i686 0:5.1.69-1.el6_4 will be updated
---> Package mysql-server.i386 0:5.5.31-1.el5.remi will be an update
--> Running transaction check
---> Package compat-mysql51.i386 0:5.1.54-1.el5.remi will be installed
---> Package openssl098e.i686 0:0.9.8e-17.el6.centos.2 will be installed
---> Package php-mysql.i686 0:5.3.3-22.el6 will be updated
---> Package php-mysql.i386 0:5.4.15-1.el5.remi will be an update
--> Processing Dependency: php-pdo = 5.4.15-1.el5.remi for package: php-mysql-5.4.15-1.el5.remi.i386
--> Running transaction check
---> Package php-pdo.i686 0:5.3.3-22.el6 will be updated
---> Package php-pdo.i386 0:5.4.15-1.el5.remi will be an update
--> Processing Dependency: php-common = 5.4.15-1.el5.remi for package: php-pdo-5.4.15-1.el5.remi.i386
--> Running transaction check
---> Package php-common.i686 0:5.3.3-22.el6 will be updated
--> Processing Dependency: php-common(x86-32) = 5.3.3-22.el6 for package: php-5.3.3-22.el6.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-22.el6 for package: php-gd-5.3.3-22.el6.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-22.el6 for package: php-mbstring-5.3.3-22.el6.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-22.el6 for package: php-cli-5.3.3-22.el6.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-22.el6 for package: php-xml-5.3.3-22.el6.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-22.el6 for package: php-ldap-5.3.3-22.el6.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-22.el6 for package: php-imap-5.3.3-22.el6.i686
---> Package php-common.i386 0:5.4.15-1.el5.remi will be an update
--> Running transaction check
---> Package php.i686 0:5.3.3-22.el6 will be updated
---> Package php.i386 0:5.4.15-1.el5.remi will be an update
---> Package php-cli.i686 0:5.3.3-22.el6 will be updated
---> Package php-cli.i386 0:5.4.15-1.el5.remi will be an update
---> Package php-gd.i686 0:5.3.3-22.el6 will be updated
---> Package php-gd.i386 0:5.4.15-1.el5.remi will be an update
--> Processing Dependency: libt1.so.5 for package: php-gd-5.4.15-1.el5.remi.i386
---> Package php-imap.i686 0:5.3.3-22.el6 will be updated
---> Package php-imap.i386 0:5.4.15-1.el5.remi will be an update
--> Processing Dependency: libc-client.so.1 for package: php-imap-5.4.15-1.el5.remi.i386
---> Package php-ldap.i686 0:5.3.3-22.el6 will be updated
---> Package php-ldap.i386 0:5.4.15-1.el5.remi will be an update
--> Processing Dependency: libldap-2.3.so.0 for package: php-ldap-5.4.15-1.el5.remi.i386
--> Processing Dependency: liblber-2.3.so.0 for package: php-ldap-5.4.15-1.el5.remi.i386
---> Package php-mbstring.i686 0:5.3.3-22.el6 will be updated
---> Package php-mbstring.i386 0:5.4.15-1.el5.remi will be an update
---> Package php-xml.i686 0:5.3.3-22.el6 will be updated
---> Package php-xml.i386 0:5.4.15-1.el5.remi will be an update
--> Running transaction check
---> Package compat-openldap.i686 1:2.3.43-2.el6 will be installed
---> Package php-imap.i386 0:5.4.15-1.el5.remi will be an update
--> Processing Dependency: libc-client.so.1 for package: php-imap-5.4.15-1.el5.remi.i386
---> Package t1lib.i686 0:5.1.2-6.el6_2.1 will be installed
--> Finished Dependency Resolution
Error: Package: php-imap-5.4.15-1.el5.remi.i386 (remi)
           Requires: libc-client.so.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Re: How to enable the repositories on SME Server (CentOS based)

libc-client is part of base repository (RHEL or CentOS)
But it seems your are using some others clone (sme), so don't know where to find this package for this distro.
Perhaps you can try the CentOS package, but no warranty.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: How to enable the repositories on SME Server (CentOS based)

OK.  I am testing an alpha version and so maybe SME can see about adding the package or something.

Thanks.

29 (edited by Bibi94752 2014-03-14 09:35:56)

Re: How to enable the repositories on SME Server (CentOS based)

Thank you.