Topic: [GLPI 0.84.2] Installation rpm : problem de dépendances?

Bonjour,

J'essaye d'installer sur une configuration de test sous centOS 5.10 GLPI 0.84.2

Je tente de l'installer depuis le dépôt remi-test avec le gestionnaire de paquet

J'ai suivit cette procédure pour ajouter les dépôt de remi :

Pour Enterprise Linux (RHEL, CentOS) :

su -
cd /etc/yum.repos.d
wget http://rpms.famillecollet.com/enterprise/remi.repo

cependant quand je tente cette commande :

yum --enablerepo=remi-test install glpi

j'obtiens des erreurs de dépendance :

glpi-0.84.3-2.el5.remi.noarch from remi-test has depsolving problems
  --> Missing Dependency: php-ZendFramework2-ServiceManager is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
glpi-0.84.3-2.el5.remi.noarch from remi-test has depsolving problems
  --> Missing Dependency: php-ZendFramework2-Loader is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
glpi-0.84.3-2.el5.remi.noarch from remi-test has depsolving problems
  --> Missing Dependency: php-ZendFramework2-I18n is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
glpi-0.84.3-2.el5.remi.noarch from remi-test has depsolving problems
  --> Missing Dependency: php-ZendFramework2-Cache-apc is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
glpi-0.84.3-2.el5.remi.noarch from remi-test has depsolving problems
  --> Missing Dependency: php-ZendFramework2-Version is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
php53-common-5.3.3-21.el5.i386 from base has depsolving problems
  --> php53-common conflicts with php-common
glpi-0.84.3-2.el5.remi.noarch from remi-test has depsolving problems
  --> Missing Dependency: php-ZendFramework2-Cache is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
glpi-0.84.3-2.el5.remi.noarch from remi-test has depsolving problems
  --> Missing Dependency: php-ZendFramework2-Stdlib is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
Error: Missing Dependency: php-ZendFramework2-Cache is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
Error: Missing Dependency: php-ZendFramework2-Stdlib is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
Error: Missing Dependency: php-ZendFramework2-Loader is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
Error: Missing Dependency: php-ZendFramework2-Cache-apc is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
Error: Missing Dependency: php-ZendFramework2-I18n is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
Error: php53-common conflicts with php-common
Error: Missing Dependency: php-ZendFramework2-Version is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)
Error: Missing Dependency: php-ZendFramework2-ServiceManager is needed by package glpi-0.84.3-2.el5.remi.noarch (remi-test)

J'avoue ne pas comprendre pourquoi "php-ZendFramework2-" me fais des misère.

si qqn peut éclairer ma lanterne

Cordialement,

Re: [GLPI 0.84.2] Installation rpm : problem de dépendances?

Il faut activer remi-test ET remi pour les dépendances.

yum --enablerepo=remi,remi-test install glpi

P.S ZF2 est aussi dans EPEL, mais en testing pour l'instant

yum --enablerepo=epel-testing,remi-test install glpi
Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: [GLPI 0.84.2] Installation rpm : problem de dépendances?

Bonjour

Et merci pour ta réponse.

Je suis pas encore très au point concernant les dépôts.

je vais pouvoir tester GLPI 0.84.2 smile.

encore merci