Topic: impossible de maj vers PHP 5.4 sous CentOS 6.5

Bonjour,

J'ai une machine (serveur dédié OVH VPS Classic 2014) qui tourne sous CentOS 6.5.
J'ai besoin de passer à PHP 5.4.

J'ai suivi les instructions en faisant les instructions suivantes (j'ai retiré les URLs pour pouvoir poster ce message):

wget [...]/epel-release-6-8.noarch.rpm
wget [...]/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm
yum --enablerepo=remi update php\*

Ca ne marche pas du tout.
J'ai plein d'erreurs :

           php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-raphf-1.0.2-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-runkit-0.9-12.CVS20090215.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-sphinx-1.0.0-2.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-shout-0.9.2-6.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-radius-1.2.7-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-xdebug-2.1.4-1.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-uuid-1.0.3-3.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-amqp-1.2.0-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-ssh2-0.11.0-7.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-runkit-0.9-12.CVS20090215.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-memprof-1.0.0-3.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-ncurses-1.0.1-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-twig-ctwig-1.15.1-1.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-libpuzzle-0.11-7.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-suhosin-0.9.29-2.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-apc-3.1.9-2.el6.x86_64 (@base)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-ssh2-0.11.0-7.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-redland-1.0.7.1-1.el6.x86_64 (@epel)
           Requires: php-api = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php-api = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php-api = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php-api = 20100412-x86-64
Error: Package: php-xapian-1.2.7-1.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-xdebug-2.1.4-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-uuid-1.0.3-3.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-memprof-1.0.0-3.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-propro-1.0.0-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-xhprof-0.9.4-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-libpuzzle-0.11-7.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-parsekit-1.2-5.CVS20090309.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-mapi-7.1.8-3.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-suhosin-0.9.29-2.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-cairo-0.3.2-2.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-twig-ctwig-1.15.1-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-cairo-0.3.2-2.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-mongo-1.4.4-1.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-raphf-1.0.2-1.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.4.26-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.25-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Des suggestions ?

Merci d'avance pour le novice que je suis

Re: impossible de maj vers PHP 5.4 sous CentOS 6.5

Il faudrait la sortie complète.

Je pense à un blocage à cause d'un plugin (priority our protectbase).

Essayer avec l'option --noplugins

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: impossible de maj vers PHP 5.4 sous CentOS 6.5

Merci beaucoup Rémi pour ta réponse aussi rapide.

Je n'ai pas pu te mettre toute la sortie car cela dépasse la capacité de l'affichage de Putty.

Je regarde et je te tiens informé.