1 (edited by stephdl 2014-04-30 16:30:26)

Topic: Error: Package: php-mysql-5.4.27-1.el6.remi.i686 (remi)

Bonjour

Je tente d'upgrader php par vos dépôts 'remi-php55 et remi' en obtenant un problème de dépendance assez bizarre puisqu'il semble que php-pdo soit disponible en plusieurs versions différentes, et dans remi, et dans remi-php55

Pour la petite histoire mon OS est une SME Server v9 (EL6_6.5) et peut aussi être la cause de mon désagrément car cela n'est pas une 'pure' CentOS.

je vous ai attaché le log de yum.

[root@sme9 ~]# yum update php --enablerepo=epel,remi-php55,remi
Loaded plugins: fastestmirror, smeserver
Loading mirror speeds from cached hostfile
* base: miroir.univ-paris13.fr
* epel: mirror.ibcp.fr
* smeaddons: mirror.chiropratique.org
* smeextras: mirror.chiropratique.org
* smeos: mirror.chiropratique.org
* smeupdates: mirror.chiropratique.org
* updates: ftp.rezopole.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package php.i686 0:5.3.3-27.el6_5 will be updated
---> Package php.i686 0:5.5.11-1.el6.remi will be an update
--> Processing Dependency: php-common(x86-32) = 5.5.11-1.el6.remi for package: php-5.5.11-1.el6.remi.i686
--> Processing Dependency: php-cli(x86-32) = 5.5.11-1.el6.remi for package: php-5.5.11-1.el6.remi.i686
--> Running transaction check
---> Package php-cli.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-cli.i686 0:5.5.11-1.el6.remi will be an update
---> Package php-common.i686 0:5.3.3-27.el6_5 will be updated
--> Processing Dependency: php-common(x86-32) = 5.3.3-27.el6_5 for package: php-mysql-5.3.3-27.el6_5.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-27.el6_5 for package: php-imap-5.3.3-27.el6_5.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-27.el6_5 for package: php-process-5.3.3-27.el6_5.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-27.el6_5 for package: php-gd-5.3.3-27.el6_5.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-27.el6_5 for package: php-pdo-5.3.3-27.el6_5.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-27.el6_5 for package: php-xml-5.3.3-27.el6_5.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-27.el6_5 for package: php-mbstring-5.3.3-27.el6_5.i686
--> Processing Dependency: php-common(x86-32) = 5.3.3-27.el6_5 for package: php-ldap-5.3.3-27.el6_5.i686
---> Package php-common.i686 0:5.5.11-1.el6.remi will be an update
--> Processing Dependency: php-pecl-zip(x86-32) for package: php-common-5.5.11-1.el6.remi.i686
--> Processing Dependency: php-pecl-jsonc(x86-32) for package: php-common-5.5.11-1.el6.remi.i686
--> Running transaction check
---> Package php-gd.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-gd.i686 0:5.5.11-1.el6.remi will be an update
--> Processing Dependency: libt1.so.5 for package: php-gd-5.5.11-1.el6.remi.i686
--> Processing Dependency: libgd.so.3 for package: php-gd-5.5.11-1.el6.remi.i686
---> Package php-imap.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-imap.i686 0:5.5.11-1.el6.remi will be an update
---> Package php-ldap.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-ldap.i686 0:5.5.11-1.el6.remi will be an update
---> Package php-mbstring.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-mbstring.i686 0:5.5.11-1.el6.remi will be an update
---> Package php-mysql.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-mysql.i686 0:5.4.27-1.el6.remi will be an update
--> Processing Dependency: php-pdo(x86-32) = 5.4.27-1.el6.remi for package: php-mysql-5.4.27-1.el6.remi.i686
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_18) for package: php-mysql-5.4.27-1.el6.remi.i686
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16) for package: php-mysql-5.4.27-1.el6.remi.i686
--> Processing Dependency: libmysqlclient.so.18 for package: php-mysql-5.4.27-1.el6.remi.i686
---> Package php-pdo.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-pdo.i686 0:5.5.11-1.el6.remi will be an update
---> Package php-pecl-jsonc.i686 0:1.3.5-1.el6.remi.5.5 will be installed
---> Package php-pecl-zip.i686 0:1.12.4-1.el6.remi.5.5 will be installed
---> Package php-process.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-process.i686 0:5.5.11-1.el6.remi will be an update
---> Package php-xml.i686 0:5.3.3-27.el6_5 will be updated
---> Package php-xml.i686 0:5.5.11-1.el6.remi will be an update
--> Running transaction check
---> Package gd-last.i686 0:2.1.0-2.el6.remi will be installed
---> Package mysql-libs.i686 0:5.1.73-3.el6_5 will be updated
--> Processing Dependency: libmysqlclient.so.16 for package: perl-DBD-MySQL-4.022-1.el6.rfx.i686
--> Processing Dependency: libmysqlclient.so.16 for package: mysql-5.1.73-3.el6_5.i686
--> Processing Dependency: libmysqlclient.so.16 for package: mysql-server-5.1.73-3.el6_5.i686
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: mysql-server-5.1.73-3.el6_5.i686
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: mysql-5.1.73-3.el6_5.i686
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: perl-DBD-MySQL-4.022-1.el6.rfx.i686
--> Processing Dependency: libmysqlclient_r.so.16 for package: mysql-5.1.73-3.el6_5.i686
--> Processing Dependency: libmysqlclient_r.so.16 for package: mysql-server-5.1.73-3.el6_5.i686
--> Processing Dependency: libmysqlclient_r.so.16(libmysqlclient_16) for package: mysql-5.1.73-3.el6_5.i686
--> Processing Dependency: libmysqlclient_r.so.16(libmysqlclient_16) for package: mysql-server-5.1.73-3.el6_5.i686
--> Processing Dependency: mysql-libs = 5.1.73-3.el6_5 for package: mysql-5.1.73-3.el6_5.i686
---> Package mysql-libs.i686 0:5.5.37-1.el6.remi will be an update
---> Package php-mysql.i686 0:5.4.27-1.el6.remi will be an update
--> Processing Dependency: php-pdo(x86-32) = 5.4.27-1.el6.remi for package: php-mysql-5.4.27-1.el6.remi.i686
---> Package t1lib.i686 0:5.1.2-6.el6_2.1 will be installed
--> Running transaction check
---> Package compat-mysql51.i686 0:5.1.54-1.el6.remi will be installed
---> Package mysql.i686 0:5.1.73-3.el6_5 will be updated
---> Package mysql.i686 0:5.5.37-1.el6.remi will be an update
---> Package mysql-server.i686 0:5.1.73-3.el6_5 will be updated
---> Package mysql-server.i686 0:5.5.37-1.el6.remi will be an update
---> Package php-mysql.i686 0:5.4.27-1.el6.remi will be an update
--> Processing Dependency: php-pdo(x86-32) = 5.4.27-1.el6.remi for package: php-mysql-5.4.27-1.el6.remi.i686
--> Finished Dependency Resolution
Error: Package: php-mysql-5.4.27-1.el6.remi.i686 (remi)
           Requires: php-pdo(x86-32) = 5.4.27-1.el6.remi
           Removing: php-pdo-5.3.3-27.el6_5.i686 (@anaconda-base-201403301700.i386/9.0)
               php-pdo(x86-32) = 5.3.3-27.el6_5
           Updated By: php-pdo-5.5.11-1.el6.remi.i686 (remi-php55)
               php-pdo(x86-32) = 5.5.11-1.el6.remi
           Available: php-pdo-5.3.3-26.el6.i686 (base)
               php-pdo(x86-32) = 5.3.3-26.el6
           Available: php-pdo-5.4.26-1.el6.remi.i686 (remi)
               php-pdo(x86-32) = 5.4.26-1.el6.remi
           Available: php-pdo-5.4.27-1.el6.remi.i686 (remi)
               php-pdo(x86-32) = 5.4.27-1.el6.remi
           Available: php-pdo-5.5.10-1.el6.remi.1.i686 (remi-php55)
               php-pdo(x86-32) = 5.5.10-1.el6.remi.1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@sme9 ~]#

2 (edited by stephdl 2014-04-30 16:36:49)

Re: Error: Package: php-mysql-5.4.27-1.el6.remi.i686 (remi)

je viens de tester sur une centos6.5
# cat /etc/redhat-release
CentOS release 6.5 (Final)

je peux reproduire la même erreur en installant en premier les paquets suivants

yum install php php-pdo php-mysql mysql-server
puis
yum --enablerepo=epel,remi-php55,remi install php

[root@buildrpm yum.repos.d]# yum --enablerepo=epel,remi-php55,remi install php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.3-27.el6_5 will be updated
---> Package php.x86_64 0:5.5.11-1.el6.remi will be an update
--> Processing Dependency: php-common(x86-64) = 5.5.11-1.el6.remi for package: php-5.5.11-1.el6.remi.x86_64
--> Processing Dependency: php-cli(x86-64) = 5.5.11-1.el6.remi for package: php-5.5.11-1.el6.remi.x86_64
--> Running transaction check
---> Package php-cli.x86_64 0:5.3.3-27.el6_5 will be updated
---> Package php-cli.x86_64 0:5.5.11-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-27.el6_5 will be updated
--> Processing Dependency: php-common(x86-64) = 5.3.3-27.el6_5 for package: php-mysql-5.3.3-27.el6_5.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-27.el6_5 for package: php-pdo-5.3.3-27.el6_5.x86_64
---> Package php-common.x86_64 0:5.5.11-1.el6.remi will be an update
--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.5.11-1.el6.remi.x86_64
--> Processing Dependency: php-pecl-jsonc(x86-64) for package: php-common-5.5.11-1.el6.remi.x86_64
--> Running transaction check
---> Package php-mysql.x86_64 0:5.3.3-27.el6_5 will be updated
---> Package php-mysql.x86_64 0:5.4.27-1.el6.remi will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.27-1.el6.remi for package: php-mysql-5.4.27-1.el6.remi.x86_64
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_18)(64bit) for package: php-mysql-5.4.27-1.el6.remi.x86_64
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16)(64bit) for package: php-mysql-5.4.27-1.el6.remi.x86_64
--> Processing Dependency: libmysqlclient.so.18()(64bit) for package: php-mysql-5.4.27-1.el6.remi.x86_64
---> Package php-pdo.x86_64 0:5.3.3-27.el6_5 will be updated
---> Package php-pdo.x86_64 0:5.5.11-1.el6.remi will be an update
---> Package php-pecl-jsonc.x86_64 0:1.3.5-1.el6.remi.5.5 will be installed
--> Processing Dependency: /usr/bin/pecl for package: php-pecl-jsonc-1.3.5-1.el6.remi.5.5.x86_64
--> Processing Dependency: /usr/bin/pecl for package: php-pecl-jsonc-1.3.5-1.el6.remi.5.5.x86_64
---> Package php-pecl-zip.x86_64 0:1.12.4-1.el6.remi.5.5 will be installed
--> Running transaction check
---> Package mysql-libs.x86_64 0:5.1.73-3.el6_5 will be updated
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: mysql-5.1.73-3.el6_5.x86_64
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: mysql-server-5.1.73-3.el6_5.x86_64
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: 2:postfix-2.6.6-6.el6_5.x86_64
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: mysql-5.1.73-3.el6_5.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: mysql-server-5.1.73-3.el6_5.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: 2:postfix-2.6.6-6.el6_5.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
--> Processing Dependency: libmysqlclient_r.so.16()(64bit) for package: mysql-5.1.73-3.el6_5.x86_64
--> Processing Dependency: libmysqlclient_r.so.16()(64bit) for package: mysql-server-5.1.73-3.el6_5.x86_64
--> Processing Dependency: libmysqlclient_r.so.16(libmysqlclient_16)(64bit) for package: mysql-5.1.73-3.el6_5.x86_64
--> Processing Dependency: libmysqlclient_r.so.16(libmysqlclient_16)(64bit) for package: mysql-server-5.1.73-3.el6_5.x86_64
--> Processing Dependency: mysql-libs = 5.1.73-3.el6_5 for package: mysql-5.1.73-3.el6_5.x86_64
---> Package mysql-libs.x86_64 0:5.5.37-1.el6.remi will be an update
---> Package php-mysql.x86_64 0:5.4.27-1.el6.remi will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.27-1.el6.remi for package: php-mysql-5.4.27-1.el6.remi.x86_64
---> Package php-pear.noarch 1:1.9.4-27.el6.remi will be installed
--> Processing Dependency: php-xml for package: 1:php-pear-1.9.4-27.el6.remi.noarch
--> Processing Dependency: php-posix for package: 1:php-pear-1.9.4-27.el6.remi.noarch
--> Running transaction check
---> Package compat-mysql51.x86_64 0:5.1.54-1.el6.remi will be installed
---> Package mysql.x86_64 0:5.1.73-3.el6_5 will be updated
---> Package mysql.x86_64 0:5.5.37-1.el6.remi will be an update
---> Package mysql-server.x86_64 0:5.1.73-3.el6_5 will be updated
---> Package mysql-server.x86_64 0:5.5.37-1.el6.remi will be an update
--> Processing Dependency: libaio.so.1(LIBAIO_0.4)(64bit) for package: mysql-server-5.5.37-1.el6.remi.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.1)(64bit) for package: mysql-server-5.5.37-1.el6.remi.x86_64
--> Processing Dependency: libaio.so.1()(64bit) for package: mysql-server-5.5.37-1.el6.remi.x86_64
---> Package php-mysql.x86_64 0:5.4.27-1.el6.remi will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.27-1.el6.remi for package: php-mysql-5.4.27-1.el6.remi.x86_64
---> Package php-process.x86_64 0:5.5.11-1.el6.remi will be installed
---> Package php-xml.x86_64 0:5.5.11-1.el6.remi will be installed
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24)(64bit) for package: php-xml-5.5.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for package: php-xml-5.5.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18)(64bit) for package: php-xml-5.5.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13)(64bit) for package: php-xml-5.5.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: php-xml-5.5.11-1.el6.remi.x86_64
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml-5.5.11-1.el6.remi.x86_64
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml-5.5.11-1.el6.remi.x86_64
--> Running transaction check
---> Package libaio.x86_64 0:0.3.107-10.el6 will be installed
---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be installed
---> Package php-mysql.x86_64 0:5.4.27-1.el6.remi will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.27-1.el6.remi for package: php-mysql-5.4.27-1.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-mysql-5.4.27-1.el6.remi.x86_64 (remi)
           Requires: php-pdo(x86-64) = 5.4.27-1.el6.remi
           Removing: php-pdo-5.3.3-27.el6_5.x86_64 (@updates)
               php-pdo(x86-64) = 5.3.3-27.el6_5
           Updated By: php-pdo-5.5.11-1.el6.remi.x86_64 (remi-php55)
               php-pdo(x86-64) = 5.5.11-1.el6.remi
           Available: php-pdo-5.3.3-26.el6.x86_64 (base)
               php-pdo(x86-64) = 5.3.3-26.el6
           Available: php-pdo-5.4.26-1.el6.remi.x86_64 (remi)
               php-pdo(x86-64) = 5.4.26-1.el6.remi
           Available: php-pdo-5.4.27-1.el6.remi.x86_64 (remi)
               php-pdo(x86-64) = 5.4.27-1.el6.remi
           Available: php-pdo-5.5.10-1.el6.remi.1.x86_64 (remi-php55)
               php-pdo(x86-64) = 5.5.10-1.el6.remi.1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: Error: Package: php-mysql-5.4.27-1.el6.remi.i686 (remi)

bonsoir remi

Je me permet de venir poster la solution que j'ai finalement trouvé en lisant la documentation de votre site smile

yum --enablerepo=remi-php55,remi,epel update php\*

Merci le boulot effectué ici.

Re: Error: Package: php-mysql-5.4.27-1.el6.remi.i686 (remi)

Oui update php\* semble une meilleure option.

Encore un petit défaut de yum qui dans les cas précédents n'est pas capable de gérer le remplacement de php-mysql par php-mysqlnd...

Résolu smile

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test