Topic: Problème avec Firefox 3.6.3plugin1

Salut Remi,
Je viens d'installer Firefox 3.6.3plugin1 dans Fedora 12 et me suis rendu compte dès le lancement qu'il est en anglais. Pourtant je suis sous KDE 4.4.3-1 en français.
Par contre, j'ai mis Thunderbird 3.1 RC1 et lui est bien traduit en français !
Tu as une explication et une solution pour remettre Firefox en français ?
A+

Re: Problème avec Firefox 3.6.3plugin1

Quel sont les valeurs de

echo $LC_ALL
echo $LC_MESSAGES
echo $LANG

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème avec Firefox 3.6.3plugin1

Salut,

Les 2 premières commandes : rien. La 3 ème : fr_BE.UTF-8


[root@localhost ~]# echo $LC_ALL

[root@localhost ~]# echo $LC_MESSAGES

[root@localhost ~]# echo $LANG
fr_BE.UTF-8

Re: Problème avec Firefox 3.6.3plugin1

Pas de soucis sous F 13 ( je suis en multi boot avec F 12 ) mais là, j'ai Firefox 3.6.3-4 .
Oh, sorry, en écrivant cela je viens de me rendre compte que je suis sous F 13;:rolleyes:
Je reboote sous F 12 et je reposte les valeurs des commandes.

Re: Problème avec Firefox 3.6.3plugin1

Me revoilà sous F 12 cette fois-ci.
Les valeurs sont différentes pour la dernière commande :

[Fifi@Fifi ~]$ echo $LC_ALL

[Fifi@Fifi ~]$ echo $LC_MESSAGES

[Fifi@Fifi ~]$ echo $LANG
fr_FR.UTF-8
[Fifi@Fifi ~]$

J'ai donc FR sous F 12 au lieu de BE sous F 13. Ca vient de ça ?

Re: Problème avec Firefox 3.6.3plugin1

Quand tu le lances en ligne de commande, t'as des messages ?

Et en lançant

LANG=fr_BE.UTF-8 firefox

+

P.S. enfin, j'y crois pas trop, de toute manière, il n'y a pas de pack de langue pour la Belgique.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème avec Firefox 3.6.3plugin1

Bon, en attendant ta réponse, j'ai été chercher dans google et j'ai trouvé ceci : http://www.theodys.org/index.php/post/2 … hunderbird
J'ai suivi la procédure pour télécharger le fichier de langue fr.xpi : là : http://releases.mozilla.org/pub/mozilla … -i686/xpi/et l'installer.
J'ai vérifié dans about:config, general.useragent.locale . La valeur était en-US. Je l'ai changée en fr et redémarré Firefox.
Et je suis maintenant en français .
Problème résolu.
Par curiosité, j'ai été voir dans Thunderbird. Et là, la valeur de general.useragent.locale est : en-US , comme Firefox avant que je ne change et pourtant  Thunderbird est en français et je n'ai pas téléchargé le fr.xpi. Je n'y comprend rien !

Re: Problème avec Firefox 3.6.3plugin1

Si je lance Firefox en ligne de commande, il se lance, sans aucun message. Mais bon, maintenant comme le problème est réglé ... c'est sans doute normal.

Re: Problème avec Firefox 3.6.3plugin1

Idem avec la commande LANG=fr_BE.UTF-8 firefox : Firefox se lance sans messages.
J'aurais dû essayer avant de changer dans about:config et de télécharger le fr.xpi, mais j'ai vu ta réponse trop tard.

Re: Problème avec Firefox 3.6.3plugin1

Installer le fr.xpi me semble une mauvaise solution qui va poser des problèmes lors d'une prochaine mise à jour.

Est-ce que tu peux désinstaller cette extension est corriger le script de lancement de firefox, dans lequel j'ai trouvé une petite erreur (ben oui, le dépôt remi-test ça sert aussi à ça)

dans /usr/bin/firefox, ligne 62, remplacer

## not used for remi ## MOZ_XUL_DIR="$MOZ_LIB_DIR/XULRUNNER_DIRECTORY"

Par

## firefox DIR for remi 
MOZ_XUL_DIR="$MOZ_DIST_BIN"

Cette correction sera, bien sur, intégrée à la prochaine construction du RPM (pour la 3.6.4 finale je pense)

Merci d'avance pour le retour.

+

P.S. http://github.com/remicollet/remirepo/c … 473bb190b3
P.S.2 je viens de corrigé un nouvelle fois...

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème avec Firefox 3.6.3plugin1

Bon finalement, j'ai poussé un build de la 3.6.4 build6 pour F12 avec le correctif pour les langues.

à tester.

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème avec Firefox 3.6.3plugin1

Salut Remi,

Je suis parti en vacances le 10 très tôt sans avoir lu tes deux dernières réponses. Je suis rentré hier soir.
Par curiosité, je vais essayer la correction du script de lancement de firefox après avoir désinstallé l'extension fr.xpi. Je te dirai ce que ça donne.
Par après, j'installerai la 3.6.4 build6.
A+ et merci !

Re: Problème avec Firefox 3.6.3plugin1

Salut Remi,
Je viens d'installer firefox-3.6.4-0.3.build6.fc12.remi.x86_64 ... tout va bien, plus de problème de langue.

Avant cela, j'avais désinstallé le fr.xpi dans firefox-3.6.3-2.plugin1.fc12.remi.x86_64, mais je n'avais pas trouvé la ligne

## not used for remi ## MOZ_XUL_DIR="$MOZ_LIB_DIR/XULRUNNER_DIRECTORY"

dans /usr/bin/firefox que tu me disais de changer en

## firefox DIR for remi
MOZ_XUL_DIR="$MOZ_DIST_BIN"

... ( ??? )
J'ai donc mis à jour vers firefox-3.6.4-0.3.build6.fc12.remi.x86_64.

J'en ai profité aussi pour migrer vers thunderbird-3.1-0.2.rc2.fc12.remi.x86_64

A+

Re: Problème avec Firefox 3.6.3plugin1

> tout va bien, plus de problème de langue.
Nickel alors wink

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi