Topic: el6 libwebp - depency ImageMagick-last-libs-6.9.1.2-1.el6.remi

Seems I have a problem with ImageMagick-last-libs-6.9.1.2-1.el6.remi requiring a version of libwebp that your remi repo for CentOS 6 doesn't provide ?

  • CentOS 6 remi repo has only libwebp 0.3.1-2 version

  • CentOS 7 remi repo has libwebp 0.4.3-3 version

however, ImageMagick-last-libs-6.9.1.2-1.el6.remi in CentOS 6 requires libwebp 0.4.3-3 version !

Resolving Dependencies
--> Running transaction check
---> Package ImageMagick-last.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
--> Processing Dependency: ImageMagick-last-libs(x86-64) = 6.9.1.2-1.el6.remi.1 for package: ImageMagick-last-6.9.1.2-1.el6.remi.1.x86_64
--> Processing Dependency: libfftw3.so.3()(64bit) for package: ImageMagick-last-6.9.1.2-1.el6.remi.1.x86_64
--> Processing Dependency: libMagickWand-6.Q16.so.2()(64bit) for package: ImageMagick-last-6.9.1.2-1.el6.remi.1.x86_64
--> Processing Dependency: libMagickCore-6.Q16.so.2()(64bit) for package: ImageMagick-last-6.9.1.2-1.el6.remi.1.x86_64
---> Package ImageMagick-last-c++.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
---> Package ImageMagick-last-c++-devel.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
---> Package ImageMagick-last-devel.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
--> Running transaction check
---> Package ImageMagick-last-libs.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
--> Processing Dependency: libwebp.so.5()(64bit) for package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.1.x86_64
---> Package fftw.x86_64 0:3.2.1-3.1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.1.x86_64 (remi)
           Requires: libwebp.so.5()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Re: el6 libwebp - depency ImageMagick-last-libs-6.9.1.2-1.el6.remi

This package is (now) in EPEL.

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: el6 libwebp - depency ImageMagick-last-libs-6.9.1.2-1.el6.remi

See http://rpms.famillecollet.com/rpmphp/zo … pm=libwebp

(and libwebp was only available in remi repo for EL-6, never for EL-7)

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: el6 libwebp - depency ImageMagick-last-libs-6.9.1.2-1.el6.remi

thanks Remi so specifically need to install libwebp from epel before installing ImageMagick-last

Re: el6 libwebp - depency ImageMagick-last-libs-6.9.1.2-1.el6.remi

In all case, EPEL is mandatory for remi repository.

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: el6 libwebp - depency ImageMagick-last-libs-6.9.1.2-1.el6.remi

Indeed thanks

Re: el6 libwebp - depency ImageMagick-last-libs-6.9.1.2-1.el6.remi

smile

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi