Topic: php-pq support PHP 7

Done port for PHP 7
https://github.com/m6w6/ext-pq/issues/1

Will be good to add it to the repository remi-php70

Thank.

Re: php-pq support PHP 7

Just uploaded on the repository: php-pecl-pq-2.0.0-0.1.20150819gite381164

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: php-pq support PHP 7

Ok, thank.

#yum install php-pq

Why would need these dependencies?

Install dependencies:
php-pear    noarch 1:1.10.0-0.5.dev2.el7.remi                 remi-php70 348 k
php-process x86_64 7.0.0-0.3.RC1.el7.remi                     remi-php70  68 k
php-xml     x86_64 7.0.0-0.3.RC1.el7.remi                     remi-php70 197 k

Re: php-pq support PHP 7

Because I forget to drop the dep. on pear wink

Notice: for years, all pecl extension packages have a runtime dependency on php-pear.
Dropping it is something new/experimental, only available for packages in my repository.

I've just uploaded .2 release which fix this.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

5 (edited by S.A.N 2015-08-25 16:07:30)

Re: php-pq support PHP 7

Ok
Now all is well, thank! smile