1 (edited by Elie 2016-03-24 08:47:32)

Topic: Résolu : Problème de dépendances php

Bonjour,

Depuis hier lors ce que je veux faire une mise à jour des paquets php et autres dépendances, j'ai un message d'erreur indiquant que la version requise de php-composer n'est pas présente dans vos dépôts. Actuellement la version de php installé est la 5.4. Par ailleurs, j'ai installé GLPI depuis vos dépôts.

Voici le résultat de mon yum-update :

Modules complémentaires chargés : fastestmirror, priorities
base                                                     | 3.6 kB     00:00
epel/x86_64/metalink                                     |  27 kB     00:00
epel                                                     | 4.3 kB     00:00
extras                                                   | 3.4 kB     00:00
remi                                                     | 2.9 kB     00:00
remi-php55                                               | 2.9 kB     00:00
remi-safe                                                | 2.9 kB     00:00
updates                                                  | 3.4 kB     00:00
(1/10): base/7/x86_64/group_gz                             | 155 kB   00:00
(2/10): epel/x86_64/group_gz                               | 169 kB   00:01
(3/10): epel/x86_64/updateinfo                             | 518 kB   00:00
(4/10): extras/7/x86_64/primary_db                         | 101 kB   00:00
(5/10): remi/primary_db                                    | 1.2 MB   00:01
(6/10): remi-php55/primary_db                              | 185 kB   00:01
(7/10): remi-safe/primary_db                               | 361 kB   00:01
(8/10): updates/7/x86_64/primary_db                        | 3.2 MB   00:03
(9/10): base/7/x86_64/primary_db                           | 5.3 MB   00:07
(10/10): epel/x86_64/primary_db                            | 3.9 MB   00:09
Determining fastest mirrors
 * base: distrib-coffee.ipsl.jussieu.fr
 * epel: mirror.karneval.cz
 * extras: centos.quelquesmots.fr
 * remi: rpms.remirepo.net
 * remi-php55: rpms.remirepo.net
 * remi-safe: rpms.remirepo.net
 * updates: mirror.ate.info
1452 packages excluded due to repository priority protections
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet php.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-ZendFramework2-Navigation.noarch 0:2.4.9-1.el7.remi sera obsolète
---> Le paquet php-ZendFramework2-View.noarch 0:2.4.9-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Paginator-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-I18n-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Mvc-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Form-2.4.9-1.el7.remi.noarch
---> Le paquet php-bcmath.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-bcmath.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-cli.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-cli.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-common.x86_64 0:5.4.45-5.el7.remi sera mis à jour
--> Traitement de la dépendance : php-gmp pour le paquet : php-phpseclib-2.0.1-1.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : php-ZendFramework2-Json-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : php-ZendFramework2-Log-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : php-tcpdf-6.2.12-1.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : php-doctrine-annotations-1.2.7-1.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : 1:glpi-fusioninventory-0.90.0.1.1-1.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : php-ZendFramework2-Stdlib-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : glpi-0.90.1-3.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : php-ZendFramework2-Ldap-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-json pour le paquet : phpMyAdmin-4.4.15.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-zip pour le paquet : php-ZendFramework2-Filter-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-zip pour le paquet : 1:glpi-fusioninventory-0.90.0.1.1-1.el7.remi.noarch
--> Traitement de la dépendance : php-zip pour le paquet : phpMyAdmin-4.4.15.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-pecl-zip(x86-64) pour le paquet : php-common-5.5.33-1.el7.remi.x86_64
---> Le paquet php-common.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-gd.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-gd.x86_64 0:5.5.33-1.el7.remi sera utilisé
--> Traitement de la dépendance : gd-last(x86-64) >= 2.1.1 pour le paquet : php-gd-5.5.33-1.el7.remi.x86_64
--> Traitement de la dépendance : libvpx.so.1()(64bit) pour le paquet : php-gd-5.5.33-1.el7.remi.x86_64
--> Traitement de la dépendance : libgd.so.3()(64bit) pour le paquet : php-gd-5.5.33-1.el7.remi.x86_64
---> Le paquet php-imap.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-imap.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-intl.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-intl.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-ldap.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-ldap.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-mbstring.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-mbstring.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-mcrypt.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-mcrypt.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-mysql.x86_64 0:5.4.45-5.el7.remi sera obsolète
---> Le paquet php-mysqlnd.x86_64 0:5.5.33-1.el7.remi sera obsolète
---> Le paquet php-pdo.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-pdo.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-pecl-igbinary.x86_64 0:1.2.1-1.el7.remi.5.4 sera mis à jour
---> Le paquet php-pecl-igbinary.x86_64 0:1.2.1-1.el7.remi.5.5 sera utilisé
---> Le paquet php-pecl-lzf.x86_64 0:1.6.3-1.el7.remi.5.4 sera mis à jour
---> Le paquet php-pecl-lzf.x86_64 0:1.6.3-1.el7.remi.5.5 sera utilisé
---> Le paquet php-pecl-msgpack.x86_64 0:0.5.7-1.el7.remi.5.4 sera mis à jour
---> Le paquet php-pecl-msgpack.x86_64 0:0.5.7-1.el7.remi.5.5 sera utilisé
---> Le paquet php-process.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-process.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-recode.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-recode.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-tidy.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-tidy.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-xml.x86_64 0:5.4.45-5.el7.remi sera mis à jour
---> Le paquet php-xml.x86_64 0:5.5.33-1.el7.remi sera utilisé
---> Le paquet php-zendframework-zend-navigation.noarch 0:2.6.1-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-stdlib) >= 2.7 pour le paquet : php-zendframework-zend-navigation-2.6.1-1.el7.remi.noarch
---> Le paquet php-zendframework-zend-view.noarch 0:2.6.5-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-stdlib) >= 2.7 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-loader) >= 2.5 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-eventmanager) >= 2.6.2 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
---> Le paquet tzdata.noarch 0:2016a-1.el7 sera mis à jour
---> Le paquet tzdata.noarch 0:2016b-1.el7 sera utilisé
--> Lancement de la transaction de test
---> Le paquet gd-last.x86_64 0:2.1.1-2.el7.remi sera installé
--> Traitement de la dépendance : libtiff.so.5(LIBTIFF_4.0)(64bit) pour le paquet : gd-last-2.1.1-2.el7.remi.x86_64
--> Traitement de la dépendance : libtiff.so.5()(64bit) pour le paquet : gd-last-2.1.1-2.el7.remi.x86_64
--> Traitement de la dépendance : libfontconfig.so.1()(64bit) pour le paquet : gd-last-2.1.1-2.el7.remi.x86_64
---> Le paquet libvpx.x86_64 0:1.3.0-5.el7_0 sera installé
---> Le paquet php-ZendFramework2-View.noarch 0:2.4.9-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Paginator-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-I18n-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Mvc-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Form-2.4.9-1.el7.remi.noarch
---> Le paquet php-gmp.x86_64 0:5.5.33-1.el7.remi sera installé
---> Le paquet php-pecl-jsonc.x86_64 0:1.3.9-1.el7.remi.5.5 sera installé
---> Le paquet php-pecl-zip.x86_64 0:1.13.2-1.el7.remi.5.5 sera installé
--> Traitement de la dépendance : libzip.so.4()(64bit) pour le paquet : php-pecl-zip-1.13.2-1.el7.remi.5.5.x86_64
---> Le paquet php-zendframework-zend-navigation.noarch 0:2.6.1-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-stdlib) >= 2.7 pour le paquet : php-zendframework-zend-navigation-2.6.1-1.el7.remi.noarch
---> Le paquet php-zendframework-zend-view.noarch 0:2.6.5-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-stdlib) >= 2.7 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-loader) >= 2.5 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-eventmanager) >= 2.6.2 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Lancement de la transaction de test
---> Le paquet fontconfig.x86_64 0:2.10.95-7.el7 sera installé
---> Le paquet libtiff.x86_64 0:4.0.3-14.el7 sera installé
--> Traitement de la dépendance : libjbig.so.2.0()(64bit) pour le paquet : libtiff-4.0.3-14.el7.x86_64
---> Le paquet libzip-last.x86_64 0:1.1.2-1.el7.remi sera installé
---> Le paquet php-ZendFramework2-View.noarch 0:2.4.9-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Paginator-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-I18n-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Mvc-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Form-2.4.9-1.el7.remi.noarch
---> Le paquet php-zendframework-zend-navigation.noarch 0:2.6.1-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-stdlib) >= 2.7 pour le paquet : php-zendframework-zend-navigation-2.6.1-1.el7.remi.noarch
---> Le paquet php-zendframework-zend-view.noarch 0:2.6.5-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-stdlib) >= 2.7 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-loader) >= 2.5 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-eventmanager) >= 2.6.2 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Lancement de la transaction de test
---> Le paquet jbigkit-libs.x86_64 0:2.0-11.el7 sera installé
---> Le paquet php-ZendFramework2-View.noarch 0:2.4.9-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Paginator-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-I18n-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Mvc-2.4.9-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-view) = 2.4.9 pour le paquet : php-ZendFramework2-Form-2.4.9-1.el7.remi.noarch
---> Le paquet php-zendframework-zend-navigation.noarch 0:2.6.1-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-stdlib) >= 2.7 pour le paquet : php-zendframework-zend-navigation-2.6.1-1.el7.remi.noarch
---> Le paquet php-zendframework-zend-view.noarch 0:2.6.5-1.el7.remi sera obsolète
--> Traitement de la dépendance : php-composer(zendframework/zend-stdlib) >= 2.7 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-loader) >= 2.5 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Traitement de la dépendance : php-composer(zendframework/zend-eventmanager) >= 2.6.2 pour le paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch
--> Résolution des dépendances terminée
Erreur : Paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch (remi)
             Requiert : php-composer(zendframework/zend-loader) >= 2.5
             Installé  : php-ZendFramework2-Loader-2.4.9-1.el7.remi.noarch (@remi)
                 php-composer(zendframework/zend-loader) = 2.4.9
             Disponible : php-ZendFramework2-Loader-2.4.8-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-loader) = 2.4.8
Erreur : Paquet : php-ZendFramework2-Paginator-2.4.9-1.el7.remi.noarch (@remi)
             Requiert : php-composer(zendframework/zend-view) = 2.4.9
             Suppression  : php-ZendFramework2-View-2.4.9-1.el7.remi.noarch (@remi)
                 php-composer(zendframework/zend-view) = 2.4.9
             Rendu obsolète par : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-view) = 2.6.5
             Disponible : php-ZendFramework2-View-2.4.8-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-view) = 2.4.8
Erreur : Paquet : php-ZendFramework2-Mvc-2.4.9-1.el7.remi.noarch (@remi)
             Requiert : php-composer(zendframework/zend-view) = 2.4.9
             Suppression  : php-ZendFramework2-View-2.4.9-1.el7.remi.noarch (@remi)
                 php-composer(zendframework/zend-view) = 2.4.9
             Rendu obsolète par : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-view) = 2.6.5
             Disponible : php-ZendFramework2-View-2.4.8-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-view) = 2.4.8
Erreur : Paquet : php-zendframework-zend-navigation-2.6.1-1.el7.remi.noarch (remi)
             Requiert : php-composer(zendframework/zend-stdlib) >= 2.7
             Installé  : php-ZendFramework2-Stdlib-2.4.9-1.el7.remi.noarch (@remi)
                 php-composer(zendframework/zend-stdlib) = 2.4.9
             Disponible : php-ZendFramework2-Stdlib-2.4.8-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-stdlib) = 2.4.8
Erreur : Paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch (remi)
             Requiert : php-composer(zendframework/zend-stdlib) >= 2.7
             Installé  : php-ZendFramework2-Stdlib-2.4.9-1.el7.remi.noarch (@remi)
                 php-composer(zendframework/zend-stdlib) = 2.4.9
             Disponible : php-ZendFramework2-Stdlib-2.4.8-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-stdlib) = 2.4.8
Erreur : Paquet : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch (remi)
             Requiert : php-composer(zendframework/zend-eventmanager) >= 2.6.2
             Installé  : php-ZendFramework2-EventManager-2.4.9-1.el7.remi.noarch (@remi)
                 php-composer(zendframework/zend-eventmanager) = 2.4.9
             Disponible : php-ZendFramework2-EventManager-2.4.8-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-eventmanager) = 2.4.8
Erreur : Paquet : php-ZendFramework2-Form-2.4.9-1.el7.remi.noarch (@remi)
             Requiert : php-composer(zendframework/zend-view) = 2.4.9
             Suppression  : php-ZendFramework2-View-2.4.9-1.el7.remi.noarch (@remi)
                 php-composer(zendframework/zend-view) = 2.4.9
             Rendu obsolète par : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-view) = 2.6.5
             Disponible : php-ZendFramework2-View-2.4.8-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-view) = 2.4.8
Erreur : Paquet : php-ZendFramework2-I18n-2.4.9-1.el7.remi.noarch (@remi)
             Requiert : php-composer(zendframework/zend-view) = 2.4.9
             Suppression  : php-ZendFramework2-View-2.4.9-1.el7.remi.noarch (@remi)
                 php-composer(zendframework/zend-view) = 2.4.9
             Rendu obsolète par : php-zendframework-zend-view-2.6.5-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-view) = 2.6.5
             Disponible : php-ZendFramework2-View-2.4.8-1.el7.remi.noarch (remi)
                 php-composer(zendframework/zend-view) = 2.4.8
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest

Je vous remercie par avance pour votre aide.

Re: Résolu : Problème de dépendances php

Thanks for the report.

My fault, I recently push those 2 packages in "remi" (instead of "remi-test" which have full ZF 2.5)

Should be fixed now (as soon as the mirror you are using will be synced)

--skip-broken is a workaround.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: Résolu : Problème de dépendances php

Bonjour,

Merci pour la réactivité. Je vous confirme que le problème est résolu.

Bonne journée.

Re: Résolu : Problème de dépendances php

Super, merci de la confirmation smile

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70