Topic: Some package requires php(language) >= 5.5 or 5.6

PHP 5.4 is dead since September 2015
PHP 5.5 is dead since July 2016

Lot of projects already require newer version of PHP to run, and "remi" repository is designed to provide the latest.

Some examples:
- phpMyAdmin requires PHP 5.5 since 4.4 (current is 4.6)
- PHPUnit requires PHP 5.6 since 5.0 (current is 5.5)
- Symfony Framework 3 requires PHP 5.5
- Nette Framework 2.4 requires PHP 5.6
- Zend Framework 2.5 requires PHP 5.6
- etc

Previously these packages were stored in the "remi-test" repository.

Since August 2016, these packages are slowly moved to "remi" repository.

So, I you really want to keep the old un-maintained PHP version 5.4 or 5.5 (yes, I will keep them online, and for some time with some security backports), you can't use these recent applications, and have to exclude them from the repository.

But you should really consider upgrading to ones of the supported versions of PHP

See the Configuration Wizard.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Some package requires php(language) >= 5.5 or 5.6

Today statistics are :

    7.1.0beta =  0.4%
    7.0.9     = 11.9%
    5.6.24    = 33.8%
    5.5.38    = 23.2%
    5.4.45    = 30.7%

So ~54% for old versions, really too much and only ~46% for supported ones.

I hope this move will encourage users to upgrade, and change this numbers in the right way.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Some package requires php(language) >= 5.5 or 5.6

Probably worth a blog post, so PHP version 5.6 needed

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Some package requires php(language) >= 5.5 or 5.6

Hi,

  First of all, thank you for your great work with your repositories, I find them extremely useful!

  I am facing now some problems because of the requirement of php > 5.5 in phpMyAdmin. I am executing phpMyAdmin with php56 as softwarecollection anyway, but I understand your reasons for requiring a php base >= 5.5 . I have no problem updating the base php as I am not using it anyway.

  I understand that I am supposed to add either remi-php55 or remi-php56 to fulfill the requirement. You mentioned that in the near future you will replace the base php in the "remi" repo from 5.4 to either 5.5 or 5.6 . Do you have any time estimate for that? I am just trying to figure out if I add temporarily remi-php56 or I wait for a more recent php version in "remi".

   Thanks!

Re: Some package requires php(language) >= 5.5 or 5.6

> You mentioned that in the near future you will replace the base php in the "remi" repo from 5.4 to either 5.5 or 5.6

No, "remi" will always stay at same version.
1 repo per version.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70