Topic: Some package requires php(language) >= 5.5 or 5.6
PHP 5.4 is dead since September 2015
PHP 5.5 is dead since July 2016
Lot of projects already require newer version of PHP to run, and "remi" repository is designed to provide the latest.
- phpMyAdmin requires PHP 5.5 since 4.4 (current is 4.6)
- PHPUnit requires PHP 5.6 since 5.0 (current is 5.5)
- Symfony Framework 3 requires PHP 5.5
- Nette Framework 2.4 requires PHP 5.6
- Zend Framework 2.5 requires PHP 5.6
Previously these packages were stored in the "remi-test" repository.
Since August 2016, these packages are slowly moved to "remi" repository.
So, I you really want to keep the old un-maintained PHP version 5.4 or 5.5 (yes, I will keep them online, and for some time with some security backports), you can't use these recent applications, and have to exclude them from the repository.
But you should really consider upgrading to ones of the supported versions of PHP
See the Configuration Wizard.
Laptop: Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70