1 (edited by slayer 2016-11-10 14:49:41)

Topic: php 5.6.28/7.0.13 breaks php-pecl-ssh2

Dear remi,

I updated one of our production machines with activated remi-php56 repo and figured out that php was updated to 5.6.28.
That gave us some major problems with our php application. A "opendir" command with a ssh2.sftp ressource failed.

this is what yum update printed out:

php                               x86_64                      5.6.28-1.el7.remi                      remi-php56                      2.6 M

the machines setup:

centos 7 with epel and remi-php56 enabled (not remi-test)

why did that happen? Do you release RC versions to remi-php56 or is it a mistake?

After downgrading php to 5.6.27 everything works fine again.

Thanks for your anweser, due to we use remi in production environments I would appreciate a short answer.

kind regards,
daniel

Re: php 5.6.28/7.0.13 breaks php-pecl-ssh2

Yes, I'm aware of this issue.

Try php-pecl-ssh2-0.13-3 which solves this issue.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: php 5.6.28/7.0.13 breaks php-pecl-ssh2

> Do you release RC versions to remi-php56 or is it a mistake?

No mistake. RC version are in remi-test. remi-php56 only contains GA release.
And if 5.6.28 is not yet announced, it is already available, https://github.com/php/php-src/releases/tag/php-5.6.28, and building it for my repository is part of the PHP project QA, so is usually available shortly before announcement (exactly as windows downloads)

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: php 5.6.28/7.0.13 breaks php-pecl-ssh2

Additional information:

PHP 5.6/7.0 Release managers are aware of this breakage, but as this is related to a security fix in parse_url (PHP bug #73192), we choose to keep this change and not revert it or differ new releases (7.0.13 is now already announced).

So I've adapted (upstream) ssh2 extension for this change

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

5 (edited by slayer 2016-11-10 15:26:28)

Re: php 5.6.28/7.0.13 breaks php-pecl-ssh2

thanks for all the information.
can be closed for my part.

Re: php 5.6.28/7.0.13 breaks php-pecl-ssh2

@slayer: can you confirm, 5.6.28 + updated ssh2 also fix the issue for you ?

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: php 5.6.28/7.0.13 breaks php-pecl-ssh2

yes, works very well. thanks again.

Re: php 5.6.28/7.0.13 breaks php-pecl-ssh2

Thanks for taking the time to report this breakage, and for feedback on the fix.

Closing.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70