Topic: Cent OS 7.3 php56more

I have a production app server with CentOS 7.3 with multiple php versions (5.4.16 and 5.6.25). I have installed PHP 5.6 using software collection as per the instruction on rh-php56 (https://www.softwarecollections.org/en/ … /rh-php56/).

Everything works fine without any issues but when I tried to install mongodb php module 'php.net/manual/en/mongodb.installation.pecl.php' (url) is missing on the rh-php56 list. rh-php56 only has support for rh-php56-php-pecl-mongo which is a deprecated library. Now I am kind of stuck with rh-php56 and am not sure how to install mongodb php module. So am wondering whether it's possible to install using 'softwarecollections.org/en/scls/remi/php56more/' (url) will it work with rh-php56 without any conflict? or do I have to uninstall the rh-php56 and install the php 5.6 using remi?

Sorry for the long explanation and question, this is a production server and am afraid to make changes without clear understanding of the changes I make.

Any help greatly appreciated!

Thank you

Re: Cent OS 7.3 php56more

php56more repository is mostly deprecated, and I don't really plan to update it anymore.

Development now happen in CentOS SCLo SIG: https://wiki.centos.org/SpecialInterestGroup/SCLo

So, using centos-release-scl package (available on centos extras repository) you can get rh-php56-* packages (from RHSCL official collection) and sclo-php56-* additional packages maintained by the SIG (aka, by me).

And sclo-php56-php-pecl-mongodb exists there.

Also explain in https://blog.remirepo.net/pages/PECL-ex … RPM-status (search for SCLo in the page)

P.S. see http://ftp-stud.fht-esslingen.de/pub/Mi … 6_64/sclo/

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: Cent OS 7.3 php56more

Hi Remi!

Thank you very much for the quick response and explaining it in detail and pointing in the right direction, it's so helpful!!!!

So I assumed that it's just enabling the repository using 'yum install centos-release-scl' and install the 'sclo-php56-php-pecl-mongodb'.

Thank again for the help and all your open source community contributions smile