Topic: msodbcsql version

Hello,
I had an issue with a pdo_sqlsrv connection segfaulting (https://github.com/Microsoft/msphpsql/issues/427), which I was
able to fix by replacing msodbcsql-13.0.0.0-2.el7.remi.x86_64 with msodbcsql-13.1.8.0-1.x86_64 from microsoft's repo, and installing pdo_sqlsrv via pecl.

I can't use php-sqlsrv from remi repo after installing msodbcsql, since it has a dependency on msodbcsql-libs-13.0.0.0

If I have understood everything correctly, is it possible for you to update msodbc and msodbc-libs to a later version?

Thankyou!

Re: msodbcsql version

> I can't use php-sqlsrv from remi repo after installing msodbcsql, since it has a dependency on msodbcsql-libs-13.0.0.0

You can, using msodbcsql from Microsfot repo.

# LANG=C yum list installed msodbc\* \*sqlsrv\* mssql\*
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Installed Packages
msodbcsql.x86_64                                                         13.1.8.0-1                                                            @packages-microsoft-com-prod        
msodbcsql-libs.x86_64                                                    13.0.0.0-2.el7.remi                                                   @remi-safe                          
mssql-server.x86_64                                                      14.0.600.250-2                                                        @packages-microsoft-com-mssql-server
mssql-tools.x86_64                                                       14.0.6.0-1                                                            @packages-microsoft-com-prod        
php70-php-sqlsrv.x86_64                                                  4.0.8-1.el7.remi                                                      @remi-safe                          
php71-php-sqlsrv.x86_64                                                  4.0.8-1.el7.remi                                                      @remi-safe                          

> If I have understood everything correctly, is it possible for you to update msodbc and msodbc-libs to a later version?

I'd like to be able to update it.... but can't find the sources (only the ones for 13.0.0.0)
I should probably ask Microsoft about them

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: msodbcsql version

Upstream bug tracker => https://github.com/Microsoft/msphpsql/issues/433

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: msodbcsql version

Notice
- msodbcsql provides /opt/microsoft/msodbcsql/lib64/libmsodbcsql-13.1.so.8.0
- msodbcsql-libs provides /opt/microsoft/msodbcsql/lib64/libmsodbcsql-13.0.so.0.0

So both can be installed
And you can choose version in odbcinst.ini

[ODBC Driver 13 for SQL Server]
Description=Microsoft ODBC Driver 13 for SQL Server
Driver=/opt/microsoft/msodbcsql/lib64/libmsodbcsql-13.1.so.8.0
Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: msodbcsql version

Thankyou for your fast response.

Everything is working for me now, using php-sqlsrv from remi, msodbcsql from microsoft, and editing odbcinst.ini as you described.

Re: msodbcsql version

smile

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70