Topic: Overriding PHP settings doesn't work after update 7.1.4 => 7.1.9

Hello,

I'm using CentOs 6.9 64bit with apache 2.2 + mod_fastcgi + php-fpm. Yesterday I've updated PHP from 7.1.4 to 7.1.9 (remi-php71 repo), after this, settings from php-fpm pool (/etc/php-fpm.d/*.conf) and vhosts .user.ini files aren't respected. Only php.ini settings can be seen in _phpinfo().

What I did (with remi-safe repo from now on):
- reinstalled all php, apache and yum repo packages;
- removed all php packages and installed php71 from Software Collection packages;
- removed all php packages and installed older - 7.1.8 version;

Nothing from above helped.

I've tried Webtatic 7.1.8 packages to check if it's not PHP itself, but their version seems to be fine.

Is there anything, that I could do?

Re: Overriding PHP settings doesn't work after update 7.1.4 => 7.1.9

Strange, I cannot really reproduce

1/ pool configuration

in php.d/date.ini: date.timezone=Europe/Paris
in php-fpm.d/www.conf: php_value[date.timezone] = Europe/London

phpinfo: date.timezone    Europe/London    Europe/London

2/ .user.ini

in php.d/date.ini: date.timezone=Europe/Paris
in .user.ini: date.timezone = "Europe/Berlin"

phpinfo: date.timezone    Europe/Berlin    Europe/Paris

3/

BTW, if configuration present in pool configuration, cannot be overriden by .user.ini (all version, 5.4, 5.5, 5.6, 7.0, 7.1 and 7.2)
Need to check

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Overriding PHP settings doesn't work after update 7.1.4 => 7.1.9

Remi,

Thank you for a fast response.

After my last post I had another try to install php71 package from your repo, and I just realized that there is /etc/httpd/conf.d/php71-php.conf file created, which overrides my vhosts mod_fastcgi config with mod_php configuration. Obviously fpm pool config wouldn't work that way, apparently .user.ini either.

After I commented out this file, everything works just fine.

Thanks again and sorry for your trouble.

Re: Overriding PHP settings doesn't work after update 7.1.4 => 7.1.9

About the 3rd case, having some value in system configuration, pool configuration and .user.ini

I open https://bugs.php.net/bug.php?id=75212
and https://github.com/php/php-src/pull/2756 for a possible fix

I prefer to wait for some other PHP dev for feedback.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Overriding PHP settings doesn't work after update 7.1.4 => 7.1.9

> I just realized that there is /etc/httpd/conf.d/php71-php.conf file created

This file comes with php or php71-php (mod_php) if you use php-fpm or php71-php-fpm you obviously don't need to install mod_php package.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70